01-31-2016 08:31 PM
30 12
tools
  1. seq1's Avatar
    After installing Windows 10 build 10536, the Windows Central app on my phone has become really slow in responding. The in-app navigation takes ages to complete.

    I have tried uninstalling and reinstalling the app, but its still the same.

    Anybody else having the same issue. I am planning to roll back to 8.1 and then try updating again.
    09-16-2015 10:59 AM
  2. azlkk's Avatar
    +1

    Same thing here. But I'm so happy to lose the loading loop issue on my L920 and intermittently on my L640 that I can live with it.
    seq1 likes this.
    09-16-2015 11:28 AM
  3. snakebitten's Avatar
    Widely reported at Windows Central.
    A bit of irony, indeed.

    I love that app. Far less sexy using browser.
    seq1 likes this.
    09-16-2015 11:45 AM
  4. seq1's Avatar
    Thanks a lot. So that means I don't have to roll back to 8.1.
    I thought it's an issue with my phone.
    09-16-2015 11:54 AM
  5. hotraia's Avatar
    It's really frustrating to use the windows central app now 😠
    09-16-2015 12:13 PM
  6. floppyedonkey's Avatar
    Slow but not horrible.
    09-16-2015 12:24 PM
  7. Sedp23's Avatar
    It's been slow for a long time now. Desperately in need of a update
    09-16-2015 12:33 PM
  8. SLMalling's Avatar
    Where's the front page story for this? ;)
    09-17-2015 10:33 AM
  9. Laura Knotek's Avatar
    Moved to WindowsCentral app for Windows Phone support forum.
    aximtreo likes this.
    09-17-2015 01:10 PM
  10. davidewart's Avatar
    Same here. I am not planning a re-install as this issue is only with WC.
    09-17-2015 03:10 PM
  11. rider2040's Avatar
    Same here. I am not planning a re-install as this issue is only with WC.
    I installed 10536 last night. Everything was working great except for the WC app. Today I did a hard reset and after spending hours installing apps and setting up my phone, I found that it didn't help the WC app at all. So, don't bother doing a reset if everything else is working because it won't solve the WC problem.
    09-18-2015 05:37 PM
  12. rianext's Avatar
    Yup find it extremely slow myself on the latest build...using a low end phone though, L625...
    09-18-2015 05:38 PM
  13. tariqsaad16's Avatar
    Same here
    09-19-2015 03:02 AM
  14. jason2234's Avatar
    Yep same here. not unusable but there's a good second delay on all selections
    09-19-2015 03:05 AM
  15. hotraia's Avatar
    They really should something about it. And why don't they make a windows 10 mobile app!!!!!
    09-21-2015 07:07 AM
  16. piknikdouille's Avatar
    Same here, super slow on 10536. A hard reset didn't solve the issue.
    09-21-2015 07:36 AM
  17. Nogitsune Micah's Avatar
    They really should something about it. And why don't they make a windows 10 mobile app!!!!!
    If I remember correctly, Daniel said the developer they had is no longer with them so that is why the app is outdated looking and needs improvement and why there likely is no win10 app at the moment...but I do remember him saying something about finding a new developer for it.
    Laura Knotek likes this.
    09-22-2015 09:13 AM
  18. hotraia's Avatar
    If I remember correctly, Daniel said the developer they had is no longer with them so that is why the app is outdated looking and needs improvement and why there likely is no win10 app at the moment...but I do remember him saying something about finding a new developer for it.
    Will this explains
    09-22-2015 05:05 PM
  19. rider2040's Avatar
    It's kind of a sad state of affairs when even an app called Windows Central doesn't support the current version of Windows and soon to be released version of Windows Mobile.
    09-22-2015 11:56 PM
  20. Sedp23's Avatar
    If I remember correctly, Daniel said the developer they had is no longer with them so that is why the app is outdated looking and needs improvement and why there likely is no win10 app at the moment...but I do remember him saying something about finding a new developer for it.

    Why don't they just port their Android or ios app over?
    09-30-2015 06:02 PM
  21. Nogitsune Micah's Avatar
    Why don't they just port their Android or ios app over?
    Probably because the IOS app is just the forum app(Which we can get on tapatalk) and the android app is ugly and they probably want to provide users with a NATIVE APP for Windows not some ported crap.
    seq1 likes this.
    09-30-2015 10:44 PM
  22. seq1's Avatar
    Looks like Windows Central app works fine on Windows 10 Mobile build 10581.
    10-29-2015 02:57 PM
  23. rider2040's Avatar
    Looks like Windows Central app works fine on Windows 10 Mobile build 10581.
    The app was working much better for me on 10581 until this morning when it now crashes every time I try to open the forums. When I restart the app, I get the error "an unhandled exception occurred." Is anyone else seeing this?
    10-31-2015 05:56 AM
  24. Sedp23's Avatar
    Probably because the IOS app is just the forum app(Which we can get on tapatalk) and the android app is ugly and they probably want to provide users with a NATIVE APP for Windows not some ported crap.

    Tapatalk is another app that needs a updating . What happened to their windows 10 new app that's in the store never seen any work or updates on it. Doesn't even log me in have to use classic for now and the notifications on that are broken
    10-31-2015 06:47 AM
  25. njstol01's Avatar
    The app was working much better for me on 10581 until this morning when it now crashes every time I try to open the forums. When I restart the app, I get the error "an unhandled exception occurred." Is anyone else seeing this?
    Yes, new member here and just installed Windows Central app, and most of it seems fine until I try the forums buttons,where it crashes.
    (was hoping the app would be faster then my laptop where these forums are slow no matter what system I use!)
    12-25-2015 05:57 PM
30 12

Similar Threads

  1. Replies: 3
    Last Post: 09-29-2015, 03:33 PM
  2. Windows 10 mobile build 10536 stuck at 51% downloading and no internal storage left
    By David Rupnik in forum Windows 10 Mobile Insider Preview
    Replies: 3
    Last Post: 09-17-2015, 11:38 AM
  3. Windows 10 mobile build 10536 1004 data connection bug
    By dioni87 in forum Windows 10 Mobile Insider Preview
    Replies: 4
    Last Post: 09-17-2015, 02:54 AM
  4. How is the experience of a low end Lumia 520 on latest build 10536?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 09-16-2015, 04:43 PM
  5. Slack for Windows desktop update brings the classic icon back on Windows 7 and 8
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 09-16-2015, 10:30 AM
LINK TO POST COPIED TO CLIPBOARD