1. Dylan O Brien's Avatar
    I keep getting this error:

    Get-appxprovisionedpackage : An attempt was made to load a program with an incorrect for

    At line:1 char:1
    + Get-appxprovisionedpackage –online | where-object {$_.packagename –li ...
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Get-AppxProvisionedPackage], COMExcepti
    + FullyQualifiedErrorId : Microsoft.Dism.Commands.GetAppxProvisionedPackageCommand
    03-20-2015 10:23 AM
  2. ssapre's Avatar
    Did you try the commands that MS says to run if you see issues with people hub in latest update? I dont have a link ready, but I think windowscentral covered it in the article for 10041 update.
    03-20-2015 11:03 AM
  3. Dylan O Brien's Avatar
    Yeah and thats the error I get when I put in the command.
    03-20-2015 11:18 AM
  4. anon(5335899)'s Avatar
    open powershell in administrator mode and excute this:

    Get-appxprovisionedpackage –online | where-object {$_.packagename –like "*windowscommunicationsapps*"} | remove-appxprovisionedpackage –online

    re-install Mail, People and Calendar from the Store with the green tile
    03-20-2015 02:59 PM
  5. Dylan O Brien's Avatar
    Windows PowerShell
    Copyright (C) 2015 Microsoft Corporation. All rights reserved.

    PS C:\WINDOWS\system32> Get-appxprovisionedpackage –online | wher
    pps*"} | remove-appxprovisionedpackage –online
    Get-appxprovisionedpackage : An attempt was made to load a progra
    At line:1 char:1
    + Get-appxprovisionedpackage –online | where-object {$_.packagena
    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo : NotSpecified: (:) [Get-AppxProvisio
    + FullyQualifiedErrorId : Microsoft.Dism.Commands.GetAppxProv

    PS C:\WINDOWS\system32>
    03-20-2015 07:52 PM
  6. Dylan O Brien's Avatar
    Still not working.
    03-20-2015 07:52 PM
  7. mrpuny's Avatar
    Still not working.
    I was having the same error. I tried refreshing the system and running the powershell command, same error again. Then I reset the system and I was able to run the fix command. Resetting wasn't a big deal in my case since I installed the preview in a dual boot config in its own partition, and I didn't have anything important in that partition. Not sure if there's a better/less drastic solution.
    03-20-2015 09:08 PM

Similar Threads

  1. Replies: 20
    Last Post: 04-12-2016, 01:44 PM
  2. Where is the next build?
    By Pie ty in forum Windows Insider Program
    Replies: 93
    Last Post: 03-27-2015, 03:04 PM
  3. Error 0X80070002 Apps won't update
    By Joseph Anthony2 in forum Other Operating Systems
    Replies: 3
    Last Post: 03-22-2015, 03:30 AM
  4. Is W10TP Smooth on the 635 yet?
    By Green Buddy in forum Windows Phones
    Replies: 2
    Last Post: 03-21-2015, 11:15 AM
  5. Diorama - a very simple tilt shift app for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion & Contests
    Replies: 0
    Last Post: 03-20-2015, 08:30 AM