1. okizen's Avatar
    I've already installed 14977 as a fast insider but in Phone update it still says ‘Updates are available - Windows 10 Insider Preview 14977 (RS_PRERELEASE) ’ and when i click ‘Install now’, the button just flashes and does nothing. Has anyone else experienced this?
    12-11-2016 01:33 AM
  2. abhishek singh21's Avatar
    have you done a soft reset? to do that hold together volume down + power key until phone reboots.
    Guytronic likes this.
    12-12-2016 04:53 AM
  3. Wang Shun's Avatar
    Yes I have this issue for a few days. And what's worse is that I cannot install any apps or even update apps.
    12-12-2016 05:44 AM
  4. Wang Shun's Avatar
    Will that work? Wanna give it a try.
    Originally posted by abhishek singh21
    have you done a soft reset? to do that hold together volume down + power key until phone reboots.
    12-12-2016 05:45 AM
  5. Bugbog's Avatar
    I've been hit worse on my Lumia 1520!. My Transport app stopped opening, and I thought that this was just some sort of app failure, then my Book reader stopped in the same fashion (displays the app logo, but goes no further), and I realised something was wrong. Checked the Phone Update and found that the PreRelease 14977 update had failed; error 0x8000097 (or some such). Then my main tech-feed apps stopped. My bluetooth headset has become gimped (only works once I've woken and unlocked the phone, or sometimes even had to navigate back to the Groove app!). Where my device used to get a full two days of runtime (sometimes even 3). Now I'll be lucky to get one full day. On occasion it has even gone and died on me late in the day, with no warning!

    I finally had enough and performed a reset, then recovered from a backup. The problems remained. I then reset without resorting to the backup, but fresh; Alas, all problems still remained. I then did a Hard reset and tried both with backup restored and without. Bupkiss! Now it won't even allow me to download some apps from my library stating "your phone cannot run this app!"

    I've tried going into the slow-ring, then hard\soft resetting; no joy! I've tried using the Windows Device Recovery Tool; it sees my device, can open files, but is unable to "read" my phone info, and so 'fails'. It's getting so that, after two years of use, It would seem that my L1520 has been rendered unusable and I'll seemingly have to replace my phone before I thought I would need to. Or is there still hope?

    I'm not prepared though to pay 500 for a new phone, nor am I willing to settle for anything less than a six-inch device. So I'm quite limited in what I can get. Given the upcoming Win10-on-ARM for 2017, is the Cube WP10 a good tide over?
    12-23-2016 11:05 AM

Similar Threads

  1. Update for 'Display' app failed
    By Barstow15 in forum Windows Apps
    Replies: 6
    Last Post: 01-02-2017, 12:27 PM
  2. excel issue
    By 19791995 in forum Windows Apps
    Replies: 1
    Last Post: 12-20-2016, 05:26 PM
  3. Battery issues on Lumia 730!
    By abhinavsaprey in forum Windows 10
    Replies: 8
    Last Post: 12-17-2016, 11:06 AM
  4. Update problems
    By acicrox in forum Microsoft Surface Pro
    Replies: 1
    Last Post: 12-11-2016, 05:19 AM
  5. W10 Latest Updates!
    By holdum333 in forum Windows 10
    Replies: 0
    Last Post: 12-10-2016, 08:49 AM