1. 7thblue's Avatar
    Does anyone have this issue - when I use put the focus on wi-fi instead of 3g, it does not automatically push new emails onto my gmail account. I have to manually go into the account and click "sync" for it to upload new messages. Is there a way to fix this? I am consuming tons of data on 3g, which is why I switch to wi-fi whenever I can.
    01-08-2011 01:52 PM
  2. IamNabil's Avatar
    It works fine for me. What is your interval set to?
    01-08-2011 04:45 PM
  3. 7thblue's Avatar
    I set it to "when items arrive" but it auto-syncs sporadically.. can't figure out why - I have two other mail boxes on the phone which I recently set to "manual sync" and did not fix this problem with my primary gmail account. Does it matter that this gmail account also syncs with my ipad and somehow gmail can't handle multiple syncs? I am now keeping both 3G data connection and wi-fi on to see if email syncs reliably. Didn't want to do that before because I read that with both 3G and wifi on, data can still be leeched on the 3G and consume the data plan...
    01-08-2011 06:35 PM
  4. Rich Edmonds's Avatar
    Have you tried having your iPad off while using your phone? Might be a slight issue there, although there shouldn't be a problem with multiple synchronisation (same with having your phone and mail client on your PC on at once). Have you also tried re-adding the GMail account?
    01-10-2011 04:43 AM
  5. 7thblue's Avatar
    The problem seems to go away when I keep both 3g and WiFi on. Slightly disappointed with the WiFi compatibility with this otherwise fantastic phone. Had problem with texting on WiFi as well.
    01-10-2011 09:46 AM
  6. action_efn_jackson's Avatar
    Makes sense. The push only works when data is on. Just like a picture MMS. If data is off the pics won't go or come through.
    01-10-2011 09:50 AM
  7. 7thblue's Avatar
    So push only works with 3g on? It worked too when I only had WiFi on but it was inconsistent.. Don't know why
    01-10-2011 11:29 AM
  8. Rich Edmonds's Avatar
    Do you turn 3G completely off when using WiFi in the settings?
    01-10-2011 02:05 PM
  9. 7thblue's Avatar
    When I turned 3g data connection off leaving only the WiFi , Gmail would not push consistently. But 3g + WiFi seems okay... Seems lika waste though and WiFi is also faster
    01-10-2011 04:17 PM
  10. rijc99's Avatar
    When the phone is off the wifi is turned off also. That's why when you turn the phone on, the wifi has to reconnect. So when phone is off and 3G is off too, Gmail will not push. No connection is available.

    Take a look at your wifi status next time you turn the phone on... you'll notice the status symbol showing that its connecting.

    Also, if you are downloading a big app, don't forget to make sure the screen is on because it will fall back to 3G for download if you're not careful. (ie. Trying to install a 300MB app. You only need to start the download on wifi. Once it has started, you can turn wifi off and it will continue to download.)
    7thblue likes this.
    01-14-2011 01:14 AM
LINK TO POST COPIED TO CLIPBOARD