1. trippcook's Avatar
    Okay, guys, I'm a heavy podcast listener, with a ton of podcasts in my desktop Zune software that I used to sync over to my Windows Phone. I was really pumped to get Mango's over-the-air podcast downloading (I was a huge fan of this using DrPodder on my old Palm Pre, and was one of the only things I missed after my switch to WP7). However, to download podcasts over the air, it looks like I have to re-subscribe from my phone. When I do this, the phone starts auto-downloading a ton of podcasts I've already listened to.

    Is there a way to make the phone "see" my podcast history in Zune and not download stuff I've already listened to? I want the phone to autodownload new eps, but I don't want to have to manually download and delete every single ep of a show just to get the phone "caught up" to where I already was. Am I missing something easy here?
    09-27-2011 08:28 PM
  2. Lopes's Avatar
    I can't even get that far. I'll find a podcast, hit subscribe, then confirm, then get bounced back to the podcast's overview screen with nothing haven taken effect.

    Sent from my Venue Pro using Board Express
    09-27-2011 09:20 PM
  3. gerrymad's Avatar
    That was pretty much my experience. I tried deleteing the ones which got set up by the subscribe and then subscribing from inside of the podcast which came form Zune, but this led to problems as well. I ended up just going through th epain of doing what you're doing downloading and then markin gthe episodes as played.

    DrPodder sure was nice wasn't it?
    09-27-2011 11:14 PM
  4. Lopes's Avatar
    How're you guys even getting the subscribing through the phone working? It's keeping me in and endless loop as I described in my earlier post.
    09-28-2011 08:38 AM
  5. skipperczt's Avatar
    I have the same problem. Hit subscribe... then confirm.... sends me back to the previous screen with the subscribe button on the bottom again. Frustrating!
    09-29-2011 09:43 AM
  6. a3p3g's Avatar
    I have the same problem. Hit subscribe... then confirm.... sends me back to the previous screen with the subscribe button on the bottom again. Frustrating!
    same here. what phone are you using? i'm on a hd7 (just curious if theres any common traits here)

    a friend of mine's husband works for microsoft and said I could send them my issue's and they're testers would look into it . i emailed that along w/ a question about the lack of ad2p video audio support this morning so we'll see if i get a response. hopefully the podcast thing can be fixed because thats one feature i was looking forward to
    09-29-2011 09:58 AM
  7. dawindbag's Avatar
    I have the same issue. The phone doesn't seem to play nice with the podcast subscriptions on the Zune software and it duplicates and redownloads podcasts I've already listened to. Also, it doesn't seem to delete already played podcasts the way the Zune software does. I really appreciate the OTA functionality, this is a massive plus for Mango, but the implementation doesn't work very well.

    I might switch back to using just the Zune software to subscribe to all my podcasts and let it sync wirelessly. Then, on the off chance that I need to do a OTA download of a podcast I'll do it manually without subscribing on the phone. Not ideal, but better than all the duplication and played podcasts not deleting.
    09-29-2011 11:34 PM
  8. skipperczt's Avatar
    a3p3g.... I've got the hd7 pro... US Cellular. I thought about going back to the old version, and then updating to Mango again to see if that would do it but that's kind of a pain just to try gettting podcasts working!
    09-30-2011 10:27 PM
  9. baseballbert's Avatar
    I use the Simpi RSS app to get my podcasts. Works well.

    Sent from my non mindless sheep iphone Samsung Focus using Board Express
    09-30-2011 11:57 PM
  10. lumic's Avatar
    Try establishing a good WiFi connection then subscribing.

    You can limit the number of podcasts downloaded on the subscription settings page, but it will download the number of podcasts you specify starting from the most recent and skipping any podcasts you already have in your collection.
    10-01-2011 01:48 AM
  11. skipperczt's Avatar
    I got it working. I restored the phone back to the original version, deleted all the music and podcasts on the phone. Updated to Mango again, and it suddenly worked! I don't know if all that was necessary but it did the trick :) I figured deleting all the music was a little overkill, but it made the backup quicker so what the heck.
    10-01-2011 08:06 AM
  12. cdook's Avatar
    Yea I had the issue where it kept redownloading old podcasts. It would redownload everything every time it looked for updates. I had to connect the phone to my PC. Delete the podcast subscription on Zune. Then I disconnected, deleted the podcasts and unsubscribed. I rebooted the phone for good measure then resubscribed. This seemed to fix that issue for me.
    10-01-2011 02:56 PM
  13. a3p3g's Avatar
    I got it working. I restored the phone back to the original version, deleted all the music and podcasts on the phone. Updated to Mango again, and it suddenly worked! I don't know if all that was necessary but it did the trick :) I figured deleting all the music was a little overkill, but it made the backup quicker so what the heck.
    how did you restore to the original version? i thought about doing a phone reset via the phone settings (i'm assuming that would reset the phone to a fresh mango version correct since thats the current version?? or would this just reset back to the factory version)
    10-01-2011 03:50 PM
  14. a3p3g's Avatar
    ok i got ambitious and did a phone reset via the settings menu and thankfully it only did a factory reset to 7.5 so didnt have to do any more updates. and podcasts works now!
    thanks for the tip!
    10-01-2011 04:46 PM
LINK TO POST COPIED TO CLIPBOARD