1. mihesq's Avatar
    I wanted to sync my gmail contacts but after syncing the account to the phone, the names of people transfer but not the numbers. When I look on my account online all the numbers are there with the contacts names. Anyone know why the numbers are not syncing over with the names of my contacts?
    11-27-2011 03:55 PM
  2. Major's Avatar
    Deselect Google contact sync from your Google account, then sync your GMail contacts to your Live account. They should show up instantly, this time as Live contacts. That's how I did it to avoid any sync problems.
    11-27-2011 05:23 PM
  3. mihesq's Avatar
    Deselect Google contact sync from your Google account, then sync your GMail contacts to your Live account. They should show up instantly, this time as Live contacts. That's how I did it to avoid any sync problems.
    The problem is I have two wp7 phones that I want to use the same live account on but not the same contacts. If I sync the gmail contacts to my live account they will show up on my other phone. The reason I want the same live account is to share games and music on two phones, just not the contacts.
    11-27-2011 06:16 PM
  4. Major's Avatar
    Try switching phone A from Gmail contacts to Live contacts and vice versa on phone B, just to eliminate the phone as the problem.
    11-27-2011 06:27 PM
  5. mihesq's Avatar
    Try switching phone A from Gmail contacts to Live contacts and vice versa on phone B, just to eliminate the phone as the problem.
    no good. This is my girl friends phone so I tried syncing my Gmail to it and was able to pull contacts and numbers. I tried syncing her Gmail to my phone with the same results as her phone, contacts with no numbers. I'm able to uncheck live contacts with my phone and only use Gmail with success.

    Maybe I can make a new live account for her, sync her gmail to it and see if that somehow works. This is beginning to frustrate me.
    11-27-2011 07:11 PM
  6. Loxias's Avatar
    no good. This is my girl friends phone so I tried syncing my Gmail to it and was able to pull contacts and numbers. I tried syncing her Gmail to my phone with the same results as her phone, contacts with no numbers. I'm able to uncheck live contacts with my phone and only use Gmail with success.

    Maybe I can make a new live account for her, sync her gmail to it and see if that somehow works. This is beginning to frustrate me.
    So....syncing contacts to your phone via either account brings no numbers but both accounts sync fine on her phone?
    11-27-2011 08:52 PM
  7. mihesq's Avatar
    So....syncing contacts to your phone via either account brings no numbers but both accounts sync fine on her phone?
    syncing contacts from her Gmail does not work with either phone. My Gmail syncs just fine on both phones.
    11-27-2011 10:18 PM
  8. mihesq's Avatar
    So I exported her Gmail contacts into a new live account, then synced that live account to the phone and still the same thing, all the contacts are there but no numbers carry over.
    11-27-2011 11:37 PM
  9. thed's Avatar
    Back when I got my phone I moved all of my contacts from GMail into Hotmail. When I did that, it put everyone's mobile numbers into the 'other phone' field in Hotmail, which strangely doesn't get synced to the phone. Maybe that's what is happening here.

    I had to manually move all the numbers into the mobile phone field to get things to sync, which was kind of a pain. Since then I've realized that if you export contacts from GMail in Outlook format and then import that file into Hotmail it will correctly set the numbers as mobile.
    11-28-2011 09:12 AM
  10. pseudoware's Avatar
    I've been thru similar contact pains. I just bit the bullet and manually entered everyone in my Focus, but it was worth it. WL contacts syncs up nicely on various devices/platfirms, w/phone #s categorized correctly on each.

    Of course, one WL acct WP device is required if using separate contacts, as the OP has discovered.

    Sent from my Inspire 4G using Tapatalk
    11-28-2011 10:36 AM
  11. Major's Avatar
    Perhaps she doesn't put new contact numbers in the right field, like the above post states.
    11-28-2011 10:57 AM
  12. Jake_M's Avatar
    -Export all Gmail contacts to Outlook CSV
    -Open CSV in your editor (I used Excel)
    -Delete the Notes column (in Excel click the top of the column and hit delete)
    -Save your CSV
    -Delete all contacts in Gmail (Don’t panic, Gmail has an easy to use recovery feature if you screw up)
    -With Gmail Contacts empty, use Gmail’s import utility to import the contacts you exported in the above step from Windows Live
    -Go to your Microsoft Windows 7 Phone and sync
    01-06-2012 12:36 PM
  13. jfa1's Avatar
    som posters in another simlar thread indicated that mobile numbers in gmail were ending up synced to WL in other and not showing up to be able to dial properly because of that!
    01-06-2012 09:20 PM
  14. danisnotstan's Avatar
    I also had issues syncing Gmail, but a bit different than previously described. (A little background...) I had an HTC Arrive a few months back. I synced my Gmail contacts, calendar and email no problem. I updated the phone to Mango and everything was still fine. I decided to sell the phone and switch back to my Evo. A few months pass and I recently got the itch to have an Arrive again so I bought a used one yesterday that came with Mango pre-installed. Long story short, the phone would not let me sync Gmail at all. If I selected "Google" from the list of available accounts to sync, it kept giving me errors. (ironically, it didn't give me a reason for the error, it just said "Attention Required" next to the account name and if I pressed the sync button, the error said something like update failed, please try again later, error # blah blah blah (8 something). I was able to sync my email ONLY by entering my Gmail info as an "Other Account" but this didn't help contacts or my calendar. This also didn't allow me to set receive "items as they arrive". I spent an hour on the phone with Sprint and they claimed it was a Mango issue (rep claimed to find this info on an HTC website). I inquired about a possible downgrade back to NODO since I didn't have previous problems syncing Gmail and the rep was going to transfer me to someone else to "look into that". I then gave up and put the phone down for the night and hung up. I was about to use an alternate way to load the contacts today when I decided to play around with the phone a little more first. I REALLY wanted my contacts and calendar syncing properly in Gmail since I switch phones often and I find that more convenient than switching services. It turns out if I deselected "contacts" from the sync option under "Google Account" on the phone, then it synced my calendar and email. I then went to my Gmail account on the computer and before exporting my contacts, I decided to look at a few of them and I noticed some people had birthdays listed like "January 8, 1". I decided to fix the "1" to "1980" or whatever correct year and sure enough I went back to my phone, selected "sync contacts" and it did no problem! I know this isn't completely relevant to the OP's thread, but this is one of the first threads that popped up when I Googled the issue. Hopefully listing this here can help someone else who has the same issue.

    On a side note, my Windows Live account has shown "attention required" on both of my Arrives. It claims my password is incorrect when it is not. I'm able to access my Xbox avatar and the Marketplace, etc without a problem.
    01-08-2012 06:53 PM
  15. anishabshah's Avatar
    doesnt work
    11-18-2012 06:42 AM
LINK TO POST COPIED TO CLIPBOARD