1. IamDefiler's Avatar
    I have an Arrive w/ Mango. It used to connect to my WiFi at home with no issues, but for the past week or so I've noticed it no longer connects and relies on the cellular network for data. It has no problem connecting to any other WiFi network.

    There have been no changes to my access point and all other WiFi devices can connect with no issues. I've tried rebooting the phone, pulling the battery, deleting and re-adding my network in the list of known networks. On my router side I've rebooted it, checked and double checked the password, cleared all expired ARP tables, etc.

    I'm at a loss. Does anyone have any ideas?
    12-15-2011 08:17 AM
  2. protonhead's Avatar
    I don't know about your router, but most will allow you to back up the settings to your PC. Do that first, then reset your router to factory defaults and see if you can connect. If you can, then there HAS been some change to the router. You would have to start putting in your settings one by one to find the culprit. If you can't connect - have a friend bring their phone over. If they can connect then it must be the Arrive.
    12-15-2011 09:29 AM
  3. IamDefiler's Avatar
    Well, I have three other phones in the house (Hero, Evo, Blackberry Tour) as well as two Touchpads, laptops, etc. and all connect with no problem. DHCP pool has plenty of IPs left to administer. I'll try a few other things and then give the router reset thing a try. It's a Netgear 3700 BTW.
    12-15-2011 09:46 AM
  4. protonhead's Avatar
    Is your SSID hidden?
    12-15-2011 11:07 AM
  5. IamDefiler's Avatar
    Nope.
    12-15-2011 11:13 AM
  6. protonhead's Avatar
    Does the Arrive see your network? Can it connect to WiFi in stores?
    12-15-2011 11:21 AM
  7. IamDefiler's Avatar
    Sees it with no problem. When I try to connect it prompts for a pass, which I enter correctly. It can connect to any other WiFi I encounter, both secured and unsecured.

    I'm going to try a soft reset and see if that helps.
    12-15-2011 11:23 AM
  8. protonhead's Avatar
    Something in the phone settings must be wrong. Delete your network from the phone and then try again.
    IamDefiler likes this.
    12-15-2011 11:34 AM
  9. IamDefiler's Avatar
    Well, looks like that did the trick. What a simple solution to such a PITA problem. RESOLVED!

    EDIT: Just read your comment above. Soft resetting the phone fixed it. I did attempt to delete the network and reconnect but that did not fix the issue. Thanks for your help though!
    12-15-2011 11:35 AM
LINK TO POST COPIED TO CLIPBOARD