1. Exomondo's Avatar
    Well I've still been unable to get the latest updates that I keep getting notified of. I've tried 2 Windows 7 PCs and a Mac.

    I've tried Zune, I've tried Mac Connector, I've tried WP7 Update Cab Sender, I've tried resetting to the Factory Settings and updating, I even tried the 'Walshed' phone tool (as some users upgrading to Mango seemed to get the same error, naturally the tool said my phone wasn't 'Walshed' anyway). I keep getting the 80180048 error and none of the solutions seem to work.

    After multiple start-from-scratch re-installs I think I'm pretty much done here, don't really want to waste any more time with this, my phone is out of warranty too so no help there.
    03-22-2012 10:28 PM
  2. selfcreation's Avatar
    whats your current OS version? and whats your carrier? and is your phone under warranty?

    settings--> About --> More info --> OS Version --> ?????????
    03-23-2012 01:20 PM
  3. Exomondo's Avatar
    7720.68, Optus AU, No.
    03-25-2012 04:41 PM
  4. Luisraul924's Avatar
    Are carriers as nice and capitalistic over there as they are here in the U.S.? if so then you might be able to b!tch at them until they do something about it like I've done before... No?
    03-25-2012 04:49 PM
  5. canesfan625's Avatar
    I've heard of USB drivers missing causing this before.

    Others say to re-flash a stock rom onto your phone
    03-25-2012 05:05 PM
  6. SolunaKitty's Avatar
    You may need to update the WPSupportTools, and in that case:

    Download for x64

    Download for x86

    I had the same error, and this solved it.
    03-25-2012 05:30 PM
LINK TO POST COPIED TO CLIPBOARD