1. JessicaYupYup's Avatar
    So I just got a new lumia 900 3 days ago and I love it! But I sadly have a serious problem...my work email will just not work at all. I have been on the phone with our IT people and AT&T with no help whatsoever.

    My work email is kind of confusing we use google apps to handle it. our address is *****@mycompany.com, but when I log into our webmail it takes us to a custom gmail setup. I could make my work email available on the iphone and computer but it is just not working at all on my lumia. No matter how I try to set it up, gmail, outlook, other, it just tells me my info is wrong.

    If this doesn't get fixed I will have no choice but to return the phone which I really don't want to do.

    I would appreciate it so much if any of you could help as no one else has been able to so far. :(
    04-12-2012 04:42 PM
  2. iwannhs's Avatar
    So I just got a new lumia 900 3 days ago and I love it! But I sadly have a serious problem...my work email will just not work at all. I have been on the phone with our IT people and AT&T with no help whatsoever.

    My work email is kind of confusing we use google apps to handle it. our address is *****@mycompany.com, but when I log into our webmail it takes us to a custom gmail setup. I could make my work email available on the iphone and computer but it is just not working at all on my lumia. No matter how I try to set it up, gmail, outlook, other, it just tells me my info is wrong.

    If this doesn't get fixed I will have no choice but to return the phone which I really don't want to do.

    I would appreciate it so much if any of you could help as no one else has been able to so far. :(
    have you tried advanced setup?
    04-13-2012 10:08 AM
  3. gapost's Avatar
    Are you trying to access webmail through the Internet, or setting up an email account? If you put in your email and password, you can click try again and it will take you to Advanced settings, where you can put in your pop and smtp settings.

    If you have Imap, you can try somthing like Nuevasync and get imap email.

    You could also go to gmail and add that account as a second account in gmail and then get your mail that way.
    socialcarpet likes this.
    04-13-2012 10:15 AM
  4. welsbloke's Avatar
    I think you have to enable pop or imap on your account then configure it that way.

    It will probably also have the pop/imap details.

    I am guessing google apps does not have a custom autodiscover option.
    04-13-2012 10:23 AM
  5. socialcarpet's Avatar
    There's a trick to setting up these custom Gmail accounts, I haven't tried in on WP7, but I remember doing it on iPhones and Androids... on the iPhone I think I needed to set it up as an exchange account and the username was the entire email address, i.e. joe@joescompany.com.

    I think I've still got a Gmail account for a clients business that is active. Let me try to set it up on my Lumia and see if I can figure it out for you. BRB..
    04-13-2012 11:36 AM
  6. socialcarpet's Avatar
    Ok, I think I've got it!

    I tried setting up the custom Google Apps Gmail just using Gmail as the choice and the same thing happened to me, I couldn't check the email, it said my info was wrong...

    So I deleted that account, went back in and created a new account using ADVANCED SETUP and it worked.

    So here's what you need to do. Delete the work Gmail account on your phone you have now.

    1.) Go back into ADD AN ACCOUNT and choose "advanced setup"
    2.) Enter your full email address (****@mycompany.com) and password
    3.) Select "Internet email"

    4.) Account name set to whatever you want, work etc, or whatever the default that appears there is, leave alone.
    5.) Incoming mail server should be: imap.gmail.com
    6.) Account type: Choose IMAP4
    7.) Username: Enter your entire work email again here, so "****@mycompany.com" or whatever it is.
    8.) Enter your password in the password field
    9.) Outgoing SMTP server is: smtp.gmail.com
    10.) Click Advanced settings. Leave the first two boxes checked and check "Require SSL for incoming mail" You may want to check it for outgoing too, up to you.

    Finish up, set it to check every 15 min and give it a try. Let us know what happens. I just did this myself and it worked flawlessly.

    If you still have trouble, it could be some restriction in how your work email is set up at the administrators end, but if other people get their work gmail on their phones, then there is no reason why this shouldn't work for you as well...

    :)
    JessicaYupYup likes this.
    04-13-2012 12:15 PM
  7. JessicaYupYup's Avatar
    Ok, I think I've got it!

    I tried setting up the custom Google Apps Gmail just using Gmail as the choice and the same thing happened to me, I couldn't check the email, it said my info was wrong...

    So I deleted that account, went back in and created a new account using ADVANCED SETUP and it worked.

    So here's what you need to do. Delete the work Gmail account on your phone you have now.

    1.) Go back into ADD AN ACCOUNT and choose "advanced setup"
    2.) Enter your full email address (****@mycompany.com) and password
    3.) Select "Internet email"

    4.) Account name set to whatever you want, work etc, or whatever the default that appears there is, leave alone.
    5.) Incoming mail server should be: imap.gmail.com
    6.) Account type: Choose IMAP4
    7.) Username: Enter your entire work email again here, so "****@mycompany.com" or whatever it is.
    8.) Enter your password in the password field
    9.) Outgoing SMTP server is: smtp.gmail.com
    10.) Click Advanced settings. Leave the first two boxes checked and check "Require SSL for incoming mail" You may want to check it for outgoing too, up to you.

    Finish up, set it to check every 15 min and give it a try. Let us know what happens. I just did this myself and it worked flawlessly.

    If you still have trouble, it could be some restriction in how your work email is set up at the administrators end, but if other people get their work gmail on their phones, then there is no reason why this shouldn't work for you as well...

    :)
    Socialcarpet, I CAN NOT THANK YOU ENOUGH.

    You did what my IT guy and the AT&T people couldn't do, you let me use my work email. I had been googling this as well but there didn't seem to be any info.

    If I were you I would try to publish this somewhere so that other people who use google apps will have this info as well.

    You are the best, thank you thank you thank you.
    socialcarpet likes this.
    04-13-2012 12:35 PM
  8. socialcarpet's Avatar
    I'm so glad that worked for you, Jessica.

    iwannhs deserves credit too, for putting us on the right track. :)
    04-13-2012 12:56 PM
  9. inteller's Avatar
    gawd....your company uses gmail for business? I'm sorry.
    04-13-2012 02:12 PM
  10. socialcarpet's Avatar
    gawd....your company uses gmail for business? I'm sorry.
    I've actually set this up for a friends business and it works very well. Integrates with Google Apps nicely. You can treat it like any other email account, you don't have an @gmail.com address, you can have @yourcompany.com. It automatically gives all your employees a way to use/share Google docs, corporate calendar, etc and for a lot less money and complication than Microsoft's exchange/office services and it has all of the admin services most small businesses would need, you can remote wipe phones from it, etc.

    A lot of colleges and even some medium sized companies with over 100 employees use it believe it or not.
    04-13-2012 02:40 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD