1. ldj's Avatar
    As a previous Android user all my contact information is stored in Google. Moving over to Windows Phone, I've connected my Google account to Windows Live and I can now see all my contacts in the Windows Live Contacts page.
    Despite this my Lumia 900 still only shows contacts that I've manually created on the phone. None of the ones from Google are appearing on my phone.

    Is there something I need to do either on the phone or in Windows live to get them to appear?

    Thanks
    05-12-2012 11:05 AM
  2. scottcraft's Avatar
    I have my contacts synced with Gmail and they are working fine on my phone. I don't think I linked the accounts when I set up my phone, but it'sneen a while so I'm not completely sure. I'll check and see.

    Sent from my Windows 7 phone using Board Express
    05-12-2012 06:46 PM
  3. scottcraft's Avatar
    In my settings I have Gmail, Yahoo and windows live listed separately. Hope that helps.

    Sent from my Windows 7 phone using Board Express
    05-12-2012 06:51 PM
  4. gapost's Avatar
    Do you have your Google account in the People hub? If so, when you filter the contacts, is the Google account checked? I don't really see any reason to put your Google contacts into Windows Live. WP does an excellent job of syncing with Google contacts and also calender.
    05-12-2012 07:02 PM
  5. psiu_glen's Avatar
    Yeah, I never linked the accounts, I'd rather they be separate for simplicities sake, but the contact management in WP7 has a few places to check.

    First of all in your account settings.
    Make sure you are syncing contacts of course.
    Then in the People hub itself, you can filter which contacts you want to show. The beauty of this is that you can filter them so they won't show, but a search will reveal them.

    And then you can link the contacts within the People hub of course (so I can have the various contacts for my mom all linked under one contact for example).

    So in practical usage I only view the Hotmail contacts. But all the Google (which are mostly a duplicate of the Hotmail contacts), Facebook and Twitter contacts are there, I just don't see them unless I am searching for someone. Pretty brilliant.

    This is another thing that I'm looking at iOS and wondering why people think it's so great...the contact handling seems to be really basic and primitive.
    05-12-2012 08:46 PM
  6. c8m6p's Avatar
    Went through this exact problem. I was using google's ecosystem for both contacts and e-mail.

    Google contacts, imported into Live.com, wouldn't show, I tried everything, including a new Live account from scratch.

    Facebook contacts also didn't show by purely importing Facebook contacts into Live.com. Some people have claimed to get it to work but I haven't.

    Either way, if you don't want to move off Google, you can bypass syncing these things on the web Live.com portal, and instead do it on your phone. Just add a gmail account on your phone, check the option to sync contacts, email, calendar etc. Do the same with Facebook, on your phone, not on the web portal.

    However, I decided to switch over from Google's services to Live's. The integration with Hotmail is unbelievable. Delete email on your computer, it's instantly gone from phone. Delete an email on phone, its instantly gone from computer. Folders sync flawlessly. All in all it's definetely tighter than Google integration on this phone.

    I also exported my Google contacts as an outlook file, then imported them into Live.com. All the fields carry over fine, you get an exact replica of your contacts on Live.com. Now I'm just using Live for contacts, e-mail, calendar etc. Google doesn't really bring that much more to the table, and the tighter integration with the phone is worth it to me.

    I also now forward all my Gmail messages to my Live inbox. Now I'm just using my Live inbox full time. My gmail will just be archived eventually.
    05-13-2012 07:33 PM
  7. Idelgado782's Avatar
    I am using google because I have my calendars set up to sync on my mac and I also share my calendars with my girlfriend. I wouldn't mind switching everything over to live but I don't know how I would keep the set up that we have now. Does anyone have any suggestions?

    Sent from my Lumia 900 using Board Express
    05-13-2012 08:29 PM
  8. c8m6p's Avatar
    I am using google because I have my calendars set up to sync on my mac and I also share my calendars with my girlfriend. I wouldn't mind switching everything over to live but I don't know how I would keep the set up that we have now. Does anyone have any suggestions?

    Sent from my Lumia 900 using Board Express
    I would mess around with the live.com calendar, see if it can keep all the functionality you have now, e.g. syncing to your mac, sharing with your gf, etc.

    If it fits your needs just take an hour and transfer your contacts and calendar stuff from Gmail to Live. IMO it would be worth it, the Hotmail/Live integration with the phone is excellent.

    As I said in my previous post, contacts can be exported from Gmail to Live in 2 minutes. You can set up your Gmail to automatically forward to your Live account so you won't be missing any e-mails.

    I'm not sure how transferring the calendar would work, or what type of functionality it offers when compared to Gmail, as far as syncing with Mac, and sharing. but I'm not a heavy calendar user, so maybe someone else can chime in.

    Good luck to you.
    05-15-2012 07:54 AM
  9. sting7k's Avatar
    As a previous Android user all my contact information is stored in Google. Moving over to Windows Phone, I've connected my Google account to Windows Live and I can now see all my contacts in the Windows Live Contacts page.
    Despite this my Lumia 900 still only shows contacts that I've manually created on the phone. None of the ones from Google are appearing on my phone.

    Is there something I need to do either on the phone or in Windows live to get them to appear?

    Thanks
    Just sync your gmail account with the Lumia. Done.
    05-15-2012 08:02 AM
  10. warmth's Avatar
    1. Unselect the contacts sync from your phone, wait until Gmail account gets all its processing done.
    2. Select all your contacts on Gmail, untag them with "My Contacts" then press the UNDO button of your recent changes (repeat this step for each page of contacts that you have).
    3. Go back to your phone, select the contact sync in the Gmail settings and enjoy watching your contacts again syncing.

    Note: wait until is all synced to watch for them in the people hub.
    08-12-2012 07:25 PM
LINK TO POST COPIED TO CLIPBOARD