1. theomodsim's Avatar
    I was typing in Japanese on my DVP last evening (running update 8107) and noticed that one of the Japanese characters (kanji) was not rendered correctly. Specifically, the kanji "choku" (直) is rendered without the vertical line on the left. I also checked the emulator distributed with the Windows Phone SDK and it also incorrectly renders this character.

    Has anyone else ran into problems similar to this?
    06-29-2012 06:07 PM
  2. rbrunner's Avatar
    That's one of the characters that has a slightly different shape in Japanese and in Simplified Chinese, and it depends which kind of font you use to display it. Have a look here:

    Characters which have several different shapes - Chinese Language and Usage Beta - Stack Exchange

    So I don't think something is really wrong, but maybe WP7 makes some problematic choices regarding Kanji / Hanzi fonts.
    theomodsim likes this.
    06-30-2012 01:50 AM
  3. theomodsim's Avatar
    Thanks for the link and explanation; I didn't realize that it's rendering that particular kanji as the Simplified Chinese variant.

    I'm thinking that this is a bug, as the kanji in question is rendered using the Simplified Chinese variant even when using the Japanese QWERTY IME on the phone (so it's not just a font issue for a particular app or website). Hopefully this gets sorted out in WP8, otherwise I could see a large number of Japanese users being pretty upset that their phone can't properly display characters of their language.
    06-30-2012 01:09 PM
  4. eric12341's Avatar
    Well if it's just that one character it won't be a big deal at all. Sometimes even Spanish letters such as or get displayed incorrectly if browsers /apps don't support it.
    06-30-2012 10:57 PM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD