1. MikeySoft's Avatar
    Has anyone gotten the update to 7.10.8773.98 Tango on a HTC Titan II Yet?

    I'm just wondering given it seem as if everyone seems to have gotten it with every other phone other than Titan II.

    Even the old HTC Surround has been updated.

    I even tried the HTC Direct forum.

    Thanks.
    07-14-2012 11:35 AM
  2. jimski's Avatar
    Has anyone gotten the update to 7.10.8773.98 Tango on a HTC Titan II Yet?



    I'm just wondering given it seem as if everyone seems to have gotten it with every other phone other than Titan II.



    Even the old HTC Surround has been updated.



    I even tried the HTC Direct forum.



    Thanks.
    Really! I haven't plugged my Surround into the PC in a week to check. Are you sure.

    Sent from my Lumia 900 using Board Express Pro
    07-14-2012 02:56 PM
  3. MikeySoft's Avatar
    Really! I haven't plugged my Surround into the PC in a week to check. Are you sure.

    Sent from my Lumia 900 using Board Express Pro
    Yup. Used to have a surround. I recently went to a Titan II. I gave my Surround to a friend... He said he got the update on July 4th.
    07-14-2012 03:01 PM
  4. MancFox's Avatar
    I have a sim-free Radar that's not been updated yet, I think HTC are being a little slow!
    07-16-2012 08:31 AM
  5. campbellc's Avatar
    Nada! Can any shed any light on the Tango/Titan II no update issue?
    07-16-2012 08:37 AM
  6. jimski's Avatar
    Yup. Used to have a surround. I recently went to a Titan II. I gave my Surround to a friend... He said he got the update on July 4th.
    Hmm, and the phone is branded AT&T? Interesting.

    Sent from my Lumia 900 using Board Express Pro
    07-16-2012 09:14 AM
LINK TO POST COPIED TO CLIPBOARD