1. Solidstate89's Avatar
    I wasn't exactly sure whether this would go under the hardware category or General, but seeing as I believe the issue is with their Network (and I didn't see any sub-category for networks) I guess it's worth going here.

    Anyways, I'm currently a Sprint subscriber but I wanted to try out StraightTalk for a month and see what they're like. I purchased a Focus Flash for cheap off Amazon and paid for a month of their service. Just literally picked up the SIM today and registered it. So far so good. I'm getting HSPA+ speeds out here where I live which is certainly better than Sprint's (but meaningless as if I'm at home I'm always on WiFi) but when trying out the network in my area I noticed a couple of things.

    One, Netflix just timed out. Now I know "streaming" is technically against their ToS but I've heard people can still obviously get it working. I just wanted to see if I had the necessary bandwidth for it. It got to 7% and just failed. No big deal, I don't exactly watch it a lot on my phone, much less in an area without WiFi. However my real issue right now is with using GPS-enabled Maps.

    The GPS works just fine. Locks on very quickly. However unless I'm on WiFi, I instantly get an error telling me it's unable to connect to the servers. I've tried both Bing Maps and GMaps Pro, both give me the same error - instantaneously. Now I've received the error before on my Arrive when I'm in a weak-signal area, but it usually takes a couple minutes before it just times out. This almost as if they're blocking the connection instantly on their end. If this keeps up I plan on contacting them on Monday directly about this issue, but in the mean time, I'm curious if anyone else has had this issue with their network? Is it perhaps the particular phone (Note: I can browse the web and receive/post updates to the People Hub just fine)? I kind of doubt it given it works over WiFi and it does say I have a "4G" data connection.

    So far though, between these (seemingly forced) restrictions and the fact they store their passwords in plain-text, I have been completely underwhelmed by them, even despite the improved speeds of AT&T's network (which they use in my area) compared to Sprint.
    07-14-2012 05:41 PM
  2. Solidstate89's Avatar
    Welp, I'm an *****. Somehow the APN was reset so even though it said I had cellular connection I obviously wasn't getting any data.

    If a Mod sees this, they can lock the thread.
    07-14-2012 07:30 PM