1. andy_wh2000's Avatar
    Hey all, new to the forums, not to the site.
    I'd posted in the HD7 forum but I'm thinking this is more of a software issue, so I'm posting here. I've had my HD7 for over a 1 1/2 years now, no problems. Just yesterday thought my camera started acting up. All my research pulled up the usual problem with the HD7 camera where it closes immidiately. My problem is the camera app will stay open, everything works fine, but when I go to take a picture it closes and no picture is saved to the camera roll. Also I can start a video but as soon as I end it the same thing happens. I factory reset my phone. It worked briefly and started all over again. This time around if I try to open my photo album or camera roll it exits out to the home screen.
    Any clues?
    Thanks

    OS version: 7.10.8107.79
    FW version: 2250.21.51202.531
    HW version: 0002
    09-30-2012 10:40 PM
  2. HeyCori's Avatar
    If you've already done a factory reset then its either a hardware issue or an app causing the camera to stay open.
    10-01-2012 12:26 AM
  3. andy_wh2000's Avatar
    I dunno. Its very odd. the camera opens and captures the viewfinder normal. Its when I try to take a picture or end a video recording it closes. The big clue to it being software is that I cant even access my photo hub.
    10-01-2012 01:49 AM
  4. carey1216's Avatar
    i'm having the same exact issue with my samsung focus so it's definitely not a hardware issue. please help!
    10-01-2012 07:10 AM
  5. palandri's Avatar
    Exactly what steps did you follow when you performed a factory reset?
    10-01-2012 07:20 AM
  6. carey1216's Avatar
    Exactly what steps did you follow when you performed a factory reset?
    i hit "restore default settings" on the camera app but nothing appears to have happened. I'm reluctant to reset my whole phone (even though I've just backed everything up). Is that the best option for a fix?
    10-01-2012 07:33 AM
  7. palandri's Avatar
    i hit "restore default settings" on the camera app but nothing appears to have happened. I'm reluctant to reset my whole phone (even though I've just backed everything up). Is that the best option for a fix?
    That's what I would do, but it's your decision.
    10-01-2012 07:48 AM
  8. andy_wh2000's Avatar
    I went into phone settings>about>reset your phone.
    It wiped everything clean. All my apps, media, accounts, etc.
    The camera worked briefly when I did it then stopped working again.

    I did take Figure 8 Dash's suggestion that it could be an app causing the problem and deleted all my apps again. The camera is working fine right now. I've started to reinstall apps and check the camera after each install with no problem.

    Its just odd that it happened out of the blue. I hadn't installed any new apps or updates for a while when it happened.

    Thanks for the suggests ya'll.
    Rodolfo#WP likes this.
    10-01-2012 12:24 PM
  9. Rodolfo#WP's Avatar
    Thanks for sharing your fix strategy. You may want to particularly check for apps that warn you that they "require" camera-access, including those where camera access makes no functional sense to you/us.
    10-01-2012 04:25 PM
LINK TO POST COPIED TO CLIPBOARD