1. SouthpawJosh's Avatar
    I have a work e-mail account through an Exchange server. When I check my e-mails on my desktop and mark my messages as read, and throughout the day do the same thing and it syncs regularly, then I go to my phone, and while it has current e-mails, it doesn't mark that I've read them. This happens in my inbox, as well as sub-folders that have rules designating e-mails to those folders directly.

    Other than manually marking them as read, is there something I'm missing? I checked the sync settings on my phone (Lumia 900) and didn't see anything. Other than that I know we changed/updated our e-mail server, but I updated that information to the best of my knowledge.
    11-26-2012 11:06 AM
  2. cenit's Avatar
    Same problem here, using a Lumia 920. My emails often are not marked as read on the server even if I have read them on my phone.
    01-01-2013 07:56 AM
  3. RN50's Avatar
    Have you tried pressing the refresh button after you have read your emails?

    Mine wasn't marking it as read until i started pressing refresh.
    01-01-2013 08:21 AM
  4. cenit's Avatar
    Have you tried pressing the refresh button after you have read your emails?

    Mine wasn't marking it as read until i started pressing refresh.
    yes pressing refresh works the way it is supposed, but coming from an iPhone where it was not required I always forgot that.
    Also, if I move the message to another folder, sometimes forcing refresh moves the message also on the server but still does not mark it as read...
    01-01-2013 08:49 AM
  5. jdawgvandyk's Avatar
    I'm having the same problem, quite annoying - and have not found a way around it either. I mean if I open the mail on my WP8 then move to another folder on my exchange server the mail items should be marked read, however they are still marked unread in outlook.

    Sorry all I will still search!
    01-03-2013 03:20 PM
  6. cenit's Avatar
    @jdawgvandyk: A workaround is to read the email, sync the account then move the email to the new folder. Very slow procedure, btw...
    Also, the problem arises when deleting emails: the email in the trash is marked as unread on the server (both outlook.com and gmail.com).

    Bad implementation of Exchange ActiveSync from the creator itself... :(
    01-04-2013 07:33 AM
  7. ousooner314's Avatar
    It's the most inconvenient syncing implementation I've seen compared to other mobile platforms. Every other platform automatically syncs changes made on the device back to the server. I've created a feature suggestion on the uservoice forum suggesting they fix this. Feel free to vote if interested - Two-way full email sync.
    01-04-2013 04:59 PM
  8. xpxp2002's Avatar
    I've been trying to get this fixed for years, as it has been an issue since at least as far back as Windows Mobile 6 and WP7. I still don't understand how with thousands of Microsoft employees using this OS, nobody has noticed this huge nuisance of an issue. Consider voting to have this fixed: Fix unread state for moved/deleted emails. – Feature Suggestions for Windows Phone-
    12-19-2013 03:08 PM

Similar Threads

  1. mark all emails as read?
    By laney182 in forum Nokia Lumia 920
    Replies: 5
    Last Post: 02-20-2015, 12:54 PM
  2. Mark Forums as Read
    By GoodThings2Life in forum Site Feedback & Help
    Replies: 4
    Last Post: 09-01-2012, 06:07 PM
  3. Automatic Sync of exchange accounts
    By ike3505 in forum Windows Phone 7
    Replies: 10
    Last Post: 05-08-2012, 06:07 PM
  4. Google Account not syncing on Lumia 710
    By macbookboy in forum Windows Phone 7
    Replies: 3
    Last Post: 04-13-2012, 08:59 AM
  5. All my Exchange contact folders are not syncing
    By newstormuser09 in forum Windows Phone 7
    Replies: 2
    Last Post: 05-28-2011, 11:19 PM
LINK TO POST COPIED TO CLIPBOARD