1. Eirenarch's Avatar
    Hello,
    In the last couple of weeks I have some strange problems with battery. When the phone is used in a way that consumes battery (app or game) in a couple of minutes it announces that the battery is low and seconds after this shuts down. Sometimes it doesn't even show the message. If I try to turn it on again it powers down unless it is plugged in a charger. Interestingly if I remove the battery and put it in the phone again it starts just fine. Sometimes the battery indicator is at half when this happens and I can continue using the phone as a phone (i.e. no serious app usage) for a day. The phone is Samsung Omnia W running the latest version of WP (7.10.8862.144 which I think is the 7.8 live tile fix version). I feel like this is a battery problem and not software but I have never seen battery problems before and the problem escalated really quickly after it happened for the first time. Is this how a battery dies and should I purchase a new one or this is some other issue?
    03-22-2013 04:22 PM
  2. realwarder's Avatar
    This is exactly how my Li-ion batteries in my laptops have died.. they suddenly stop holding a charge and power off when not empty and drop large chunks in the percentage gauge, so it sounds like a battery issue to me. If you've had the phone for a couple of years this is likely.
    03-22-2013 06:54 PM
  3. ishan_122's Avatar
    I am having the exact same problems which started from a few days back...Even i suspect its a battery failure but my phone is just 1 year old. Dont expect the battery to die soon. If you could tell me the solution you took for this problem, it would be really helpfull. Thanks!!
    05-10-2013 12:50 PM
  4. Eirenarch's Avatar
    It was the battery. My phone works fine now. I actually think the battery was becoming weak long before I had the severe problems. Now the battery lasts much longer and I often skip charging it in the evenings as I have no problem going two or even three days with one charge (depends on the usage of course).
    05-11-2013 06:41 PM
  5. Indrajeet Singh's Avatar
    I have exactly same problem. Omnia W was working perfectly fine for one year and suddenly it has started getting shut even when battery shows 50% and I also thought it may be battery issue but put a brand new battery problem returned after few days. I did factory reset and installed apps afresh but problem remains.
    05-25-2013 12:25 PM

Similar Threads

  1. Lumia 900 overheating plus battery problem?
    By apoc527 in forum Nokia Lumia 900
    Replies: 28
    Last Post: 08-27-2014, 02:10 AM
  2. Replies: 11
    Last Post: 01-31-2012, 06:15 PM
  3. Post-Mango Battery problems? Solution here.
    By Baka in forum Windows Phone 7
    Replies: 18
    Last Post: 10-10-2011, 05:38 PM
LINK TO POST COPIED TO CLIPBOARD