1. Indrajeet Singh's Avatar
    I have been using Samsung Omnia W for last one and half year. Recently I changed battery after 7.8 update since then it is madness. few things unusual-
    1. Battery does not seem to be charging fully as after an hour or so though it shows charging but phone is cold and % increase is very slow. after 2-3 hours also it reaches only 90% and simply refuses to move. Trying to reach 100% damaged one battery and now replaced with another one. It only reaches 60% or so after 2 hours
    2. Once charger is removed and phone used for few minutes, battery remaining jumps by some odd amount like from 60% to 82 or 91%
    3. Phone discharges very slowly- even after a day's use it is still 40-50%
    4. problem starts now from 40-50% to Switch off, it sometimes just takes one short call. even with no use it sometimes takes 5-10mintues from that level to switch off
    5.Battery is completely discharged and it takes 10minutes of recharge to turn it back
    6. Even if I charge it to 8-10%, after little use it shows 30-40% and then will switch off as above

    Done soft and hard reset, nothing works. I am thinking of just throwing it away
    HELP PLS...
    07-20-2013 01:01 PM
  2. Tbronl's Avatar
    I once had the problem with my LG optimus 7, that the phone charged really slow. For me it helped to pull out the battery, and hold down the 'power' button for about 30 seconds or so, to ensure the phone had no power left. After that i put the battery back in, and i havent had the problem since. I see however that you have already tried another battery, so i don't know if this solution works for you.
    07-20-2013 02:15 PM
  3. Indrajeet Singh's Avatar
    tried this many times but does not help
    Samsung service center is of no help. does not understand problem just format and gave it back.
    07-25-2013 11:57 AM
  4. Indrajeet Singh's Avatar
    Is this so unique problem!!! No answers yet
    07-29-2013 12:37 PM
  5. inteller's Avatar
    time to get a new phone.
    07-29-2013 01:23 PM
  6. Bas Bouwman's Avatar
    Hi,

    I'm experiencing almost the exact same problem right now.
    It's charging to 98%, then works fine, until 70% or so. Then it just shuts off. After I put it back on, it shut off again.
    The third time (often after removing the battery) it works, and the battery level climbs up (!!!) from 6% to 35%, for example.

    Have you found a solution?
    I would like to know what to do about it.
    08-01-2013 08:44 AM
  7. MrSean490's Avatar
    I know someone who had this issue. Had to hard-reset.
    08-02-2013 09:45 AM
  8. Bas Bouwman's Avatar
    Problem solved by buying a new battery.
    I discovered the battery was swollen, so I immediately stopped using my phone and ordered a new battery.
    And it worked!
    08-05-2013 09:42 AM

Similar Threads

  1. how long does your battery lasts?
    By alvydasn in forum Nokia Lumia 925
    Replies: 101
    Last Post: 01-11-2014, 03:36 AM
  2. Kill Switch in Future Updates?
    By Blkacesvf41 in forum Windows Phone 8
    Replies: 15
    Last Post: 07-23-2013, 10:25 AM
  3. Qi charging pad voltage
    By link68759 in forum Cases & Accessories
    Replies: 2
    Last Post: 07-20-2013, 09:09 PM
  4. whatsapp Notification problem
    By Saurabh Vatsa in forum Windows Phone 8
    Replies: 4
    Last Post: 07-20-2013, 08:36 AM
LINK TO POST COPIED TO CLIPBOARD