1. JudgeHolden's Avatar
    Hey,

    I've looked at what others have said, but none seem to have this exact issue. I started the update, hitting "Install," with 65% battery left. The phone showed "Restarting," and I put it down on my Fatboy. A minute later I look over and it's showing a dead battery icon with a plug flashing on it. It was sitting on the charger at the time, and as I mentioned, it had 65% left. It's been plugged into my computer for about 20 minutes since, keeps showing that icon.

    Has anyone else had this issue? On an Icon.
    04-14-2014 10:14 PM
  2. 3earnhardt3's Avatar
    Same exact problem on 928 and icon. Had to attempt a soft restart several times while plugged in to get the icon to work. After everything is said and done it works fine.
    04-14-2014 10:18 PM
  3. andyqkw's Avatar
    Same on my Lumia 925, had approx. 75% battery juice left and all of a sudden the battery went dead upon restart.

    Connect it to the charger and it is good to go again.
    04-14-2014 10:24 PM
  4. JudgeHolden's Avatar
    Thanks, I tried that, but this time it worked, haha.


    And... now my Cobalt is more light purple than ever.
    04-14-2014 10:39 PM

Similar Threads

  1. Roaming icon (triangle) always on after 8.1 update.
    By David Van Ryn in forum Windows Phone 8.1 Preview for Developers
    Replies: 26
    Last Post: 10-26-2015, 05:10 AM
  2. 8.1 update
    By reejan bhattarai in forum Developers Corner
    Replies: 1
    Last Post: 04-15-2014, 01:55 AM
  3. New to WP8 and already on 8.1. Hi guys!
    By officially_juju in forum New to the Forums? Introduce Yourself Here!
    Replies: 6
    Last Post: 04-15-2014, 12:22 AM
  4. Improve battery life
    By joseiloaizach in forum Windows Phone 8
    Replies: 1
    Last Post: 04-14-2014, 10:58 PM
LINK TO POST COPIED TO CLIPBOARD