1. LTTG's Avatar
    Is anybody here experiencing some lag with 8.1?? My 720 is lagging a bit when closing apps (the start screen animation stutters).
    So, are you having problems too? And will a hard reset fix that??
    04-15-2014 11:39 AM
  2. denispage's Avatar
    I have lag only in photo hub and music app (terrible lag). But the overall OS, perfect!
    04-15-2014 11:42 AM
  3. iXesh's Avatar
    Bro I updated and also reset my phone, but still it lag...
    And most of app terminates after pressing back ...
    Only some app runs in background like facebook and one inbuilt app battery sense...
    Comment some more bug 🐛 that you are 😊ing
    04-15-2014 11:45 AM
  4. Kalyan Chowdary's Avatar
    Lag lag every where on my Lumia 720
    04-15-2014 11:51 AM
  5. altafmahmood's Avatar
    There is lag for phones having 512 MB Ram. Basically Microsoft has removed the cap on the memory allotted to each process so when any app is opened it used more memory for faster access so the background app are closed and then restarts giving the little bit of lag. Still tolerable not like lagadroid. Also the apps would be updated to support not closing on pressing back button hopefully. Go to battery saver and kill all the apps you don't want in the background.
    04-15-2014 11:57 AM
  6. iXesh's Avatar
    I got the solution, reset your phone and format your memory card as well, now its work well,
    I installed 7.8GB apps,
    Music 8GB,
    Video 6GB,
    N Photos 5GB...
    And its work well,
    Still you will face some lag and crash only first time....
    After that I work well...
    04-18-2014 09:20 AM
  7. iXesh's Avatar
    And try to restart your phone after installing new apps or games
    04-18-2014 09:22 AM
  8. Impenneteri's Avatar
    I have a 720 and it did have minor lag like start screen stutters right after finishing update. I did power and reset my phone and it's working fine.
    04-18-2014 09:25 AM
  9. rockstarzzz's Avatar
    There is no lag with Dev Preview and I can confirm that, how? Because I am using it on Lumia 520, Lumia 925, Lumia 720 and Lumia 1020. None of these lag, at all.
    What you need to do is hard reset, after setting up the preview. Why? Because system files between WP8 and the preview aren't exactly the same. The installer is meant to add and remove files automatically but if you have used a PC before, you would realise it isn't always as easy as that. By performing a hard reset, you keep all the new files, you get rid of old temp files that installer may or may not have removed and you remove all old apps. DO NOT restore a back up if you want to see how optimised the Dev Preview is. Start fresh, install apps that are compatible with WP8.1

    If you install whatsapp, facebook, twitter and Skype and think they aren't doing what they should do - they wont. Why? They aren't updated for this OS. They work best with WP8.0 and won't take advantage of any features that WP8.1 has to offer in the preview.
    LTTG likes this.
    04-18-2014 09:29 AM
  10. LTTG's Avatar
    Ok so I did a hard reset, but I'm still facing those start screen animation stutters when closing apps.
    Note: I restored my apps from a backup, does that affect the performance??
    04-18-2014 10:09 AM
  11. rockstarzzz's Avatar
    Ok so I did a hard reset, but I'm still facing those start screen animation stutters when closing apps.
    Note: I restored my apps from a backup, does that affect the performance??
    Check in store if you apps are still trying to download in background. If there are background tasks still in progress where they are still setting up the phone - you will see this. Also read this - http://forums.windowscentral.com/win...ml#post2454567
    04-18-2014 10:14 AM
  12. jmerrey's Avatar
    I have just a bit of stutter on my 1520 from time to time.
    04-18-2014 10:21 AM
  13. LTTG's Avatar
    I got the solution, reset your phone and format your memory card as well, now its work well,
    I installed 7.8GB apps,
    Music 8GB,
    Video 6GB,
    N Photos 5GB...
    And its work well,
    Still you will face some lag and crash only first time....
    After that I work well...
    You don't have animation stutters when closing apps anymore? Will formatting my memory card fix the stutters, even if I don't have apps installed on it??
    04-18-2014 02:57 PM
  14. iXesh's Avatar
    Reset and format your memory card too....
    Other wise wait for official 8.1 update...
    04-20-2014 12:45 AM
  15. Alessandro Dutenhefner's Avatar
    I have the same problem. It was there before 8.1 but one could barely notice and it was rare. Now it is a lot more intense after 8.1 update (Lumia 1520)
    05-14-2014 12:01 PM
  16. Rangan Das's Avatar
    Yup, happens too on my L1320. Became less when I switched to a class 10 card. If you have background apps that are running, then move those to the Phone memory.
    Get rid of unnecessary apps. Clean the temp files and restart your phone once a day. I do that regularly. My phone runs better now. Wait for the official release. That will reduce the lags.
    05-14-2014 12:07 PM

Similar Threads

  1. 2G or 3G or LTE No Indication in Windows Phone 8.1
    By prabu31 in forum Windows Phone 8.1 Preview for Developers
    Replies: 7
    Last Post: 08-28-2014, 08:23 AM
  2. Replies: 4
    Last Post: 06-06-2014, 01:13 PM
  3. wp 8.1 battery issues
    By Dhaval Thakur in forum Windows Phone 8.1 Preview for Developers
    Replies: 14
    Last Post: 04-21-2014, 09:23 PM
  4. Bug Fix in WP8.1
    By kcuk in forum Windows Phone 8.1 Preview for Developers
    Replies: 2
    Last Post: 04-15-2014, 11:43 AM
  5. Uncover a dark mystery in Enigmatis 2: Mists of Ravenwood on Windows Phone and Windows 8
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-15-2014, 11:10 AM
LINK TO POST COPIED TO CLIPBOARD