1. anon(8141948)'s Avatar
    Well, it's weird. I had uploaded a picture on Facebook this Tuesday. I was bragging a bit, uploading pictures of the new version of the OS, WP 8.1, and today a friend pointed it out who updated to WP 8.1 the next day. He owns a Lumia 525 and I am a Lumia 520 user FYI.

    So he commented saying his updated phone shows 'Cellular+SIM' whereas my phone was showing 'Mobile+SIM' that time, and then when today I checked my phone, it showed 'Cellular+SIM'. Anybody else who noticed something like this?

    Attaching a few screenshots of my phone taken on Wednesday and today.

    wp_ss_20140415_0051.png

    wp_ss_20140415_0063.png

    wp_ss_20140418_0009.png

    wp_ss_20140418_0010.png
    04-18-2014 06:28 AM
  2. psgenious's Avatar
    english US = CELLULAR , AIRPLANE MODE etc.
    english UK, INDIA = MOBILE, FLIGHT MODE etc.
    anon(8141948) likes this.
    04-18-2014 06:32 AM
  3. anon(8141948)'s Avatar
    That makes sense. Yeah.
    04-18-2014 06:39 AM

Similar Threads

  1. No Cellular Data 8.1
    By Benito Sifuentes in forum Windows Phone 8.1 Preview for Developers
    Replies: 39
    Last Post: 07-31-2015, 10:12 AM
  2. 520 with no sim card
    By narv in forum Nokia Lumia 520
    Replies: 1
    Last Post: 04-15-2014, 10:50 PM
  3. Lumia 920 TINFOILED after update (no cellular or wifi data)
    By DrewT3 in forum Windows Phone 8.1 Preview for Developers
    Replies: 4
    Last Post: 04-15-2014, 12:11 PM
  4. Nokia bumps Network+ system app to support dual-SIM Windows Phones
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 04-15-2014, 07:40 AM
  5. How do I pin cellular+sim on action centre ?
    By Aalok05 in forum Windows Phone 8.1 Preview for Developers
    Replies: 3
    Last Post: 04-15-2014, 02:09 AM
LINK TO POST COPIED TO CLIPBOARD