1. Michael Kerametlian's Avatar
    IE11 doesn't work on mobile network but works fine on Wifi.

    Error message: "We can't display this page right now. The website you're trying to reach may be experiencing technical difficulties. Try again later. Error: Cannot find server or DNS error"

    My APN settings are fine, considering UC browser works perfectly fine on my mobile network, it's just IE who decided to (pardon my French) **** the bed two days ago.
    04-22-2014 01:03 AM
  2. Himanshu Chowdhary's Avatar
    did you tried deleting IE history/cache files ?
    I am using Ie 11 on mobile data and it works fine. Which website are you trying to access on mobile data ?
    Laura Knotek likes this.
    04-22-2014 01:07 AM
  3. Michael Kerametlian's Avatar
    Yeah I deleted my history just to be sure.

    Weirdly enough, TD Canada Trusts' easyweb works, but no other website does >_>
    04-22-2014 01:29 AM
  4. Laura Knotek's Avatar
    How fast is your mobile network? Do you have 3G, EDGE, GPRS?
    04-22-2014 01:45 AM
  5. Michael Kerametlian's Avatar
    4G on Videotron in Montreal.

    Then again, I've had issues being on Videotron and not being able to receive MMS txts since I got the 920 then 1020. I can send MMS, but cannot receive >_>
    04-22-2014 01:47 AM
  6. Laura Knotek's Avatar
    4G on Videotron in Montreal.

    Then again, I've had issues being on Videotron and not being able to receive MMS txts since I got the 920 then 1020. I can send MMS, but cannot receive >_>
    What device do you have?

    What carrier was your unlocked device originally branded to? It looks like Videotron supports the AWS bands (1700 and 2100) which would be the same as those used by T-Mobile USA. Limitations to our support
    04-22-2014 02:06 AM
  7. Michael Kerametlian's Avatar
    Using the 1020 that was bought from a Rogers subsidiary.
    04-22-2014 02:13 AM
  8. Laura Knotek's Avatar
    Using the 1020 that was bought from a Rogers subsidiary.
    That should work then, since the Rogers devices have the proper bands.
    Himanshu Chowdhary likes this.
    04-22-2014 02:25 AM
  9. Michael Kerametlian's Avatar
    hah obviously it 'should' work, it just doesn't.
    It's strange as hell, worked well when I got a sim card for Rogers when I went to Toronto for a week, but the minute I'm on Videotron's sim, I can't receive MMS txts.

    Either way, this thread was mainly put out to make whomever it concerns aware that there must be some sort of bug with IE
    04-22-2014 02:35 AM
  10. Laura Knotek's Avatar
    hah obviously it 'should' work, it just doesn't.
    It's strange as hell, worked well when I got a sim card for Rogers when I went to Toronto for a week, but the minute I'm on Videotron's sim, I can't receive MMS txts.

    Either way, this thread was mainly put out to make whomever it concerns aware that there must be some sort of bug with IE
    Do you have Access Point installed? access point | Windows Phone Apps+Games Store (United States)
    04-22-2014 02:40 AM
  11. Michael Kerametlian's Avatar
    Yeah, the ONLY difference I see between the APN settings is this: "MCC : 302 MNC : 500" These two options do not exist on Access Point.
    04-22-2014 02:46 AM
  12. Lalit_S's Avatar
    I'm having the exact same issue with my 920 on Koodo as well! It's funny as it brings up suggestions as I type URL's or searches, but once I hit enter, I get the same error.
    04-24-2014 09:40 PM
  13. mburazin's Avatar
    Having the same issue here. I have a unlocked 620 on Airvoice Wireless. Everything works just fine on Wi-Fi, but as soon as I go off the Wi-Fi grid I get the DNS error. The funny thing is I can do web searches on Bing/Cortana, navigate with HERE Drive+, etc. but I can't pull up any webpages in IE on my 3G cell connection. I sure hope this gets fixed soon.
    04-28-2014 02:11 PM
  14. Zaki Maksyutov's Avatar
    The same issue for me as well: 8.1 dev preview, Lumia 1020 from Rogers, using Koodo, access point configured to use Koodo, everything works (bing, email, store, suggestions) beside browser.
    04-30-2014 11:59 PM

Similar Threads

  1. I need a clock with a double-wide transparent tile
    By Jazmac in forum Windows Phone 8.1 Preview for Developers
    Replies: 18
    Last Post: 05-31-2014, 04:33 PM
  2. (UPDATED WITH INSTRUCTIONS!) My non-US HTC 8S Works Beautifully with 8.1- Cortana included!
    By jefbeard911 in forum Windows Phone 8.1 Preview for Developers
    Replies: 39
    Last Post: 05-20-2014, 10:39 AM
  3. Weird intermittent clock problem with my 2520
    By EBynum in forum Nokia Lumia 2520
    Replies: 4
    Last Post: 04-29-2014, 08:39 PM
  4. Amazing Weather HD updated with trasnparent tiles
    By Baryex86 in forum Windows Phone 8.1
    Replies: 11
    Last Post: 04-23-2014, 04:47 PM
  5. Issues with 'working' Lumia 920
    By Quinn FitzGerald in forum Nokia Lumia 920
    Replies: 8
    Last Post: 04-22-2014, 03:10 AM
LINK TO POST COPIED TO CLIPBOARD