1. mariusmuntean's Avatar
    Hello guys
    I wanted to share my latest solution which seems to work for now, regarding reported issues on wp 8.1 with Lumia devices, especially 1520,1020,920.
    I've had these problems after updating to 8.1, even with a hard reset and settings the phone as new:
    - wifi disconnecting, limited connectivity or not connecting at all
    - huge lag when returning to home screen
    - lag in games
    - very often screen sensitivity issue
    - screen not waking up only after several pressing on the power button
    What I did:
    - reflashed with ncs a wp8.0 firmware from Germany carrier free with setup new phone
    - updated all system apps
    - updated to 8.1
    Now only sometimes I have the screen sensitivity issue but the rest are gone and it' been more than 10 hours
    05-13-2014 02:01 PM
  2. Himanshu Chowdhary's Avatar
    Thanks for sharing this with us
    05-13-2014 08:52 PM
  3. Will6371's Avatar
    How bad was your swipe/touch problem before and will you please remember to update this thread every few days.

    Thanks
    05-14-2014 05:16 AM
  4. Apurv Patani's Avatar
    Hello guys
    I wanted to share my latest solution which seems to work for now, regarding reported issues on wp 8.1 with Lumia devices, especially 1520,1020,920.
    I've had these problems after updating to 8.1, even with a hard reset and settings the phone as new:
    - wifi disconnecting, limited connectivity or not connecting at all
    - huge lag when returning to home screen
    - lag in games
    - very often screen sensitivity issue
    - screen not waking up only after several pressing on the power button
    What I did:
    - reflashed with ncs a wp8.0 firmware from Germany carrier free with setup new phone
    - updated all system apps
    - updated to 8.1
    Now only sometimes I have the screen sensitivity issue but the rest are gone and it' been more than 10 hours
    can u be a little more specific....how to reflash it with ncs...and what is ncs????
    05-14-2014 08:02 AM
  5. Paolo Cardelli's Avatar
    Hello guys
    I wanted to share my latest solution which seems to work for now, regarding reported issues on wp 8.1 with Lumia devices, especially 1520,1020,920.
    I've had these problems after updating to 8.1, even with a hard reset and settings the phone as new:
    - wifi disconnecting, limited connectivity or not connecting at all
    - huge lag when returning to home screen
    - lag in games
    - very often screen sensitivity issue
    - screen not waking up only after several pressing on the power button
    What I did:
    - reflashed with ncs a wp8.0 firmware from Germany carrier free with setup new phone
    - updated all system apps
    - updated to 8.1
    Now only sometimes I have the screen sensitivity issue but the rest are gone and it' been more than 10 hours
    I can confirm this.
    The only problems I had with my Lumia 920 8.1 were:

    -Bad Phone signal;
    -Manual Backup always failed at 96%;
    -Some lag.

    What I did was:

    1) Restored the whole Lumia 920 with Official WP8.0 + Black + my OEM carrier by simply installing, and using the official Nokia Software Recovery Tool (after install, just plug the phone USB to PC, open it, and clic on "Restore" on the main page, and let it do its things), downloadable here: http://download.fds-ncom.nokia.com/s...lInstaller.exe ;

    2) Started as New Phone, and not restored anything yet. Updated all the stock apps, and then downloaded and installed Preview for Developers, enabled it, and then did the update to 8.1 ;

    3) When finished, I did a second Factory Reset like this: Turned off the phone, Turned on the phone with Power Button, and then immediately pressed the Volume Down button until an exclamation mark appeared (!), and immediately after pressed: Volume Up, Volum Down, Power, Volume Down. The phone will Reset itself, reboot, and start as new;

    4) When finished, DID NOT refreshed the old backup, and started as new phone;

    5) Re-installed all my apps, and customized/synced everything again. Then did a Soft Reset (Power + Volume Down for some secs).


    Now is all working smoothly without lag, my Manual Backup finally works (it fully completes without erros!), and my radio signal is stronger and more stable then before.
    Still testing my battery life, but it seems improved as well.
    All notifications working in real-time too.

    No other bugs or problems found so far.

    Highly recommend this procedure for a truly, Clean Install, of 8.1
    05-14-2014 08:30 AM

Similar Threads

  1. Odd keyboard color on Nokia Lumia 925
    By Krishna Chaitanya Muppaneni in forum Nokia Lumia 925
    Replies: 6
    Last Post: 05-16-2014, 04:34 PM
  2. Should I update to Windows Phone 8.1 Preview?
    By Terence John Vidal in forum Windows Phone 8.1 Preview for Developers
    Replies: 10
    Last Post: 05-16-2014, 07:36 AM
  3. Have a Lumia Icon with 8.1 Preview? Hold off on that Treasure Tag purchase until Cyan
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 1
    Last Post: 05-16-2014, 07:30 AM
  4. GPS location. Does not update. Lumia 520
    By Thomas Jordan in forum Nokia Lumia 520
    Replies: 7
    Last Post: 05-16-2014, 04:12 AM
  5. Silly question...#1: Does the DP automatically send phone information to Microsoft?
    By peacefulberry in forum Windows Phone 8.1 Preview for Developers
    Replies: 4
    Last Post: 05-13-2014, 08:35 PM
LINK TO POST COPIED TO CLIPBOARD