1. David P2's Avatar
    I've had a hunt for this but can't really find a definitive answer. I recently did a hard reset on my 620 running 8.1, and for some reason it hasn't pulled down my contacts from outlook.com when it has done in the past. Calendar and emails are fine - it just refused to pull down my contacts, so I was missing quite a few numbers (mostly from my non-Facebook people, and people whom I have the number of, but isn't readily available on Facebook).

    Could it be a region thing? I set it to US (instead of UK) during setup for more Cortana playing - only way I could get the new updates (such as the quiz and the separators). I use a live.co.uk address as my Microsoft account.
    06-13-2014 05:44 PM
  2. CyclingGuyNola's Avatar
    Have you tried going into: People\Settings\Add Contacts and adding your email?

    Also check under: People\Settings\Filter Contact List and make sure your email is checked.
    06-13-2014 05:48 PM
  3. David P2's Avatar
    Have you tried going into: People\Settings\Add Contacts and adding your email?

    Also check under: People\Settings\Filter Contact List and make your email is checked.
    Thanks for the quick reply. Have just tried your suggestion - it just says an account using that email address already exists. Also, the 'show contacts from my' box is ticked for Outlook. If I go into Outlook.com on the desktop (and People in Windows 8.1) all my contacts are present and show as Outlook and whatever other service they are on..
    06-13-2014 05:55 PM
  4. gapost's Avatar
    Go to People, settings, filter contact list, uncheck Outlook, click ok and go out of People. Wait a couple of minutes, go in and check contacts for Outlook. Report back on results.
    06-13-2014 06:13 PM
  5. David P2's Avatar
    Sadly still no joy after your suggestion.
    06-13-2014 06:21 PM
  6. SinisterDuck's Avatar
    So do you have some contacts syncing, or none at all?
    06-14-2014 08:58 AM
  7. David P2's Avatar
    Some Outlook-only contacts aren't coming down at all.
    06-14-2014 09:06 AM
  8. SinisterDuck's Avatar
    Is the Outlook.com account your main account on the phone (using your Microsoft account when setting up the phone), or one that was added after?
    06-14-2014 09:13 AM
  9. AnestisL820's Avatar
    Go to settings/email+ accounts and force synconization with your account... Not sure if it works but give it a try...
    06-14-2014 09:16 AM
  10. SinisterDuck's Avatar
    On your phone, go to People, settings, filter contact list, and make sure "Hide contacts without phone numbers" is off.
    06-14-2014 09:24 AM
  11. David P2's Avatar
    Thanks for the suggestions - I've done many syncs to no avail and at the top of People under 'contacts' it says showing all. Hide contact without numbers is turned off.
    06-14-2014 09:26 AM
  12. SinisterDuck's Avatar
    If you haven't tried, and it's an add-on account, delete it, restart the phone, and re-add the account.
    06-14-2014 09:33 AM
  13. David P2's Avatar
    It's the master account. The contacts are definitely up there - both People in Windows 8.1 and Outlook.com show them as present and correct, they just aren't making it down to my phone.
    06-14-2014 09:34 AM
  14. gapost's Avatar
    It might be a region thing since you have a UK email and set it up as US. The only other thing I would say is to try a hard reset.
    06-14-2014 09:46 AM
  15. SinisterDuck's Avatar
    Definitely weird. The only other (obvious) thing I can think of is making sure under settings that the account is checked. For example, I use another account to sync my contacts and have my master account unchecked. Otherwise, sorry, but I've run out of ideas to help you with this, other than maybe contact Microsoft or Nokia and ask them.
    06-14-2014 09:51 AM
  16. David P2's Avatar
    Cheers for the suggestions guys.
    06-14-2014 09:54 AM
  17. David P2's Avatar
    I've just done a downgrade to 8.0 (to test a theory). That was successful, and as if by magic, all my Outlook contacts have synced properly. Now back to 8.1.
    06-14-2014 10:38 AM

Similar Threads

  1. photo in comment with facebook?
    By wasim sallam in forum Applications
    Replies: 3
    Last Post: 12-22-2014, 07:59 AM
  2. What u guys think of Firefox os?
    By akthelonelyman in forum Phone Wars
    Replies: 11
    Last Post: 06-18-2014, 04:53 AM
  3. Replies: 2
    Last Post: 06-14-2014, 04:20 PM
LINK TO POST COPIED TO CLIPBOARD