1. vedichymn's Avatar
    I've noticed now that when I delete messages on my phone, they are just "archived", which is a godawful behavior, regardless of what the settings are in the IMAP settings page on my gmail account.

    Did the behavior around deleted messages with GMail accounts change in 8.1, or did my gmail settings somehow get messed up or something? I can't find anything else on the phone settings or GMail settings that would explain this behavior, and it's ONLY happening to messages that get deleted on my phone, not any other devices.
    07-06-2014 07:02 PM
  2. ShreyansShah's Avatar
    I've noticed now that when I delete messages on my phone, they are just "archived", which is a godawful behavior, regardless of what the settings are in the IMAP settings page on my gmail account.

    Did the behavior around deleted messages with GMail accounts change in 8.1, or did my gmail settings somehow get messed up or something? I can't find anything else on the phone settings or GMail settings that would explain this behavior, and it's ONLY happening to messages that get deleted on my phone, not any other devices.
    there was something odd in gmail since begining.
    prior to 8.1, deleted mails were transfered to "deleted mails" folders (tagged) instead of going to trash.
    after 8.1, i have not gave thought about it. i will check.
    07-06-2014 11:55 PM
  3. mpt15's Avatar
    See this thread http://forums.windowscentral.com/win...o-further.html

    The solution worked for me.
    07-07-2014 12:11 AM
  4. vedichymn's Avatar
    there was something odd in gmail since begining.
    prior to 8.1, deleted mails were transfered to "deleted mails" folders (tagged) instead of going to trash.
    after 8.1, i have not gave thought about it. i will check.
    Yeah, they certainly aren't ending up in "deleted items", just getting archived.

    See this thread http://forums.windowscentral.com/win...o-further.html

    The solution worked for me.
    I don't see anything in there with a sync date newer than 2013, I believe that was just for controlling EAS, but I'll poke around.
    07-07-2014 12:29 AM
  5. mpt15's Avatar
    Yeah, they certainly aren't ending up in "deleted items", just getting archived.



    I don't see anything in there with a sync date newer than 2013, I believe that was just for controlling EAS, but I'll poke around.
    Using that link, I logged in to my account. Under "manage devices" I see Windows Phone.
    Tapping that takes me to a page where I can check the option for "Enable "Delete Email As Trash" for this device.".

    hope it works for you too.
    07-07-2014 12:33 AM
  6. vedichymn's Avatar
    Using that link, I logged in to my account. Under "manage devices" I see Windows Phone.
    Tapping that takes me to a page where I can check the option for "Enable "Delete Email As Trash" for this device.".

    hope it works for you too.
    Sadly, that was already checked and nothing there looks in any way current. Anyone else having this issue?
    07-07-2014 12:24 PM
  7. mattdreed's Avatar
    I'm so glad to hear I'm not the only one having issues. I'm also frustrated with Gmail not deleting messages that had been deleted on the phone and simply archiving them. Up until 8.1 I had no issues with deleted items syncing (using method in the link). Now, even though everything is set correctly, the issue remains on 2 Google apps accounts and a regular Gmail account.
    07-07-2014 09:48 PM
  8. gmyzak's Avatar
    Same issue here. Went to https://m.google.com/sync/settings/iconfig/, checked the 'Enable "Delete Email As Trash" for this device' option, saved, but nothing changed. Deleting still only make emails archived. Has anyone been able to solve it yet?
    07-11-2014 08:42 AM
  9. ShreyansShah's Avatar
    funny thing is, if u delete it through any other mail app, it deletes it, not just archive.
    i m having metromail installed and being used parallel on my phone. i deleted one mail from metromail, it went to trash. i confirmed it on PC.
    07-12-2014 04:46 AM
  10. Cersdo's Avatar
    Starting from today? My Gmail cant connect, and i cant add new Gmail account.
    Some one got same or its just me?

    Error code: 80072F05
    07-12-2014 08:31 AM
  11. Cersdo's Avatar
    Sorry. Found the problem. My time was set to manually.
    07-12-2014 08:41 AM
  12. mpt15's Avatar
    I found this setting by logging in to in gmail.com:
    Settings > forwarding and pop/imap >

    "when i mark a message in imap as deleted" > Turn off auto-expunge.

    You can then choose not to archive the deleted mails, and instead move to trash or immediately delete forever.
    07-15-2014 08:06 AM
  13. gmyzak's Avatar
    I found this setting by logging in to in gmail.com:
    Settings > forwarding and pop/imap >

    "when i mark a message in imap as deleted" > Turn off auto-expunge.

    You can then choose not to archive the deleted mails, and instead move to trash or immediately delete forever.
    Does this work for you? Regardless of what the IMAP settings are, my emails still don't move to the Trash.
    07-16-2014 06:16 AM
  14. ShreyansShah's Avatar
    I found this setting by logging in to in gmail.com:
    Settings > forwarding and pop/imap >

    "when i mark a message in imap as deleted" > Turn off auto-expunge.

    You can then choose not to archive the deleted mails, and instead move to trash or immediately delete forever.
    i am gonna try, but i am really doubtful about it. as i have stated earlier, the default mail app archives them, but if u delete through MetroMail, it trashes it.
    thus, it got to be something with the default mail app, not with gmail.
    07-17-2014 12:13 AM
  15. vedichymn's Avatar
    i am gonna try, but i am really doubtful about it. as i have stated earlier, the default mail app archives them, but if u delete through MetroMail, it trashes it.
    thus, it got to be something with the default mail app, not with gmail.
    Yeah, this changed 100% when I installed 8.1 Sadly, the just released 8.1 update doesn't fix it.
    08-04-2014 02:11 PM
  16. AR_B's Avatar
    This is Expected behaviour. Because GOOGLE, support itself says following :

    Source : support.google.com/mail/answer/78755


    If you delete a message from your inbox or one of your custom folders in your IMAP client, it will still appear in [Gmail]/All Mail.

    Here's why: in most folders, deleting a message simply removes that folder's label from the message, including the label identifying the message as being in your inbox. [Gmail]/All Mail shows all of your messages, whether or not they have labels attached to them.

    If you want to delete a message from all folders, move it to the [Gmail]/Trash folder.
    09-10-2014 11:54 PM
  17. pedmar007's Avatar
    Why is Google so afraid of MS that they don't offer any apps for the WP OS, they don't offer support to the minute few that's already there and yet Google/Android has the lion share of the market with respect to devices and OSes used and yet it's a problem to just update, lend us an app or two. Seriously can MS after getting an official YT app from Google or and other mainstream apps currently in usage around the world take the away the market share from Google?? Yes competition is there no matter what but why offer the same support to your biggest/only rival Apple your apps and services and have 0 fear from them why is that? MS right now is playing catchup and when a step or two is gained you pull 3 ahead but still find it hard to allow WP to have a decent OS with properly working apps. Maybe if you and MS could get along then there wouldn't be stupid annoyances of deleting an email and having it go to anywhere but the TRASH!!!
    09-11-2014 12:14 AM

Similar Threads

  1. How to check username in Skype app
    By md_minhaj in forum Ask a Question
    Replies: 8
    Last Post: 08-19-2014, 03:33 PM
  2. Looking for notes and task list\to do in one app
    By erda0 in forum Applications
    Replies: 8
    Last Post: 07-08-2014, 07:48 PM
  3. Dark Way Down, find the light in this totally free puzzle game for Windows Phone
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-06-2014, 04:42 PM
  4. Lumia 930 flipcover makes an appearance in Italy
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 07-06-2014, 01:30 PM
LINK TO POST COPIED TO CLIPBOARD