1. jansuklje's Avatar
    Hi,

    Ever since the latest WP update (currently on WP8.1 Update, firmware 3051.50009.1424.0003) my Windows 8.1 PC doesn't detect my Lumia. I get "The latest device malfunctioned and Windows does not recognize it. There is also Unknown USB device (Device descriptor request failed) listed under Universal Serial Bus controllers in Device manager. Nothing under portable devices.

    What I have tried:
    - replacing usb cable (using original one) -> no luck
    - soft reset phone -> no luck
    - turning the phone off and plug it in -> no go
    - manually uninstalling the device from device manager, restarting the PC and try again -> nope
    - plugged brother's lumia 930 -> works like a charm

    I'm slowly losing my mind, I have no idea what else can I try.

    Any help is appreciated.

    Edit. Ok so I've got access to laptop, plugging my phone there and the same problem happens at first - the device can't be recognized but a few moments later somehow it gets recognized and connected. The problem seems to be on my PC, can anyone help me out completely removing all the WP drivers (including registry entries) so I can install them fresh?

    Thanks
    08-28-2014 06:56 AM
  2. jansuklje's Avatar
    Sorry for the bump. Anyway I have solved this by formatting my PC (it was long overdue anyway). After the format, I plugged in the phone, the drives were successfully installed and my Lumia is working as intended.

    Sorry I can't offer any "cleaner" solution.
    Muessig likes this.
    08-28-2014 02:36 PM

Similar Threads

  1. Airplane Mode Problem
    By Derrizah in forum Nokia Lumia 520
    Replies: 3
    Last Post: 08-28-2014, 10:45 AM
  2. Viber problem
    By WPCentral Question in forum Ask a Question
    Replies: 0
    Last Post: 08-28-2014, 06:34 AM
  3. lumia 630 update 1
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-28-2014, 04:00 AM
  4. When cyan update for preview users
    By Rakesh Racky in forum Nokia Lumia 520
    Replies: 0
    Last Post: 08-28-2014, 03:57 AM
  5. 520 Airplane Mode Problem
    By Derrizah in forum Ask a Question
    Replies: 0
    Last Post: 08-28-2014, 03:34 AM
LINK TO POST COPIED TO CLIPBOARD