1. JamesPTao's Avatar
    Since I've updated to the windows phone developer preview 8.1 my bluetooth wont pair. I have a nokia luna bluetooth headset and a jabra bluetooth device. Each device attempt to pair and the nfc on the luna even starts the price but it fails every time. Never had that problem with wp8.0. Anyone had this issue or any advice. Would appreciate it. I have a nokia 920. Thanks.
    05-29-2014 03:07 AM
  2. Alphageek_UK's Avatar
    Sorry, I have not had this problem with my L1520.

    I know it's a pain, but have you tried resetting your 920 to see if that helps?
    05-29-2014 04:01 AM
  3. Allan Eckmann's Avatar
    Sorry mate I have a Lumia 920, but I "only" have the Black update since the 8.1 update is not available yet here in DK.
    But everything works fine, so I'm really hoping that WHEN I get the 8.1 update, it won't mess up things :-)
    05-29-2014 04:04 AM
  4. Allan Eckmann's Avatar
    Oh, another thing.... Recently my phone froze, and as you know there is no easy way to disconnect the battery as I am used to from previous Nokia phones. However I went and bought a L5 screwdriver (had to buy a whole set) and just screwed off the cover, liftet the tape up and disconnected the battery and assembled it again and everything worked fine.... You might wanna give that a go
    05-29-2014 04:08 AM
  5. JamesPTao's Avatar
    I've soft and hard reset it no difference. Its the weirdest thing. Going to try the diagnostic app.
    05-29-2014 04:44 AM
  6. JamesPTao's Avatar
    I don't have the 8.1 update, using the dev preview for wp8.1. This os the only issue I've come across outside of OneDrive saved folder thumbnail getting stuck.
    05-29-2014 04:52 AM
  7. bijooo's Avatar
    Try to pair on both phone in one time . It will be ok .and for sending by bluetooth first tap on other device to connect . After it connected try to send
    05-29-2014 08:36 AM
  8. undulose's Avatar
    I've heard that Bluetooth is a real issue for WP 8.1 now since Nokia's firmware for it hasn't come yet.
    05-29-2014 08:58 AM
  9. JamesPTao's Avatar
    I've heard that Bluetooth is a real issue for WP 8.1 now since Nokia's firmware for it hasn't come yet.
    Yeah, can't wait for nokia's firmware update
    05-29-2014 02:35 PM
  10. Anglerdk's Avatar
    I have also have some issues with dp 8.1 and Bluetooth on my L925 (parrot mki9200) where the ad2p seems disconnected , but the phone is connected... Normally I can connect with choosing Bluetooth audio on the parrot.

    Perhaps you can clear your headset ?
    05-30-2014 12:45 AM
  11. SnailUK's Avatar
    Have you deleted any existing pairings? The last couple of times I've done an update, I've had to delete my existing pair to get things to work properly.
    05-30-2014 12:50 AM
  12. JamesPTao's Avatar
    Yes it now shows nothing under paired devices but everytime I click pair it fails.
    05-30-2014 07:04 PM
  13. cesar ruiz1's Avatar
    I'm using the Lumia 1520 and since last phone update for 8.1 preview pairing cannot be established and volume rockers stop working I also have no sound on device.
    05-30-2014 10:34 PM
  14. JamesPTao's Avatar
    I'm using the Lumia 1520 and since last phone update for 8.1 preview pairing cannot be established and volume rockers stop working I also have no sound on device.
    I'm thinking its not wp8.1 itself just the fact that we are using a new os essentially without new drivers (updated Nokia software). I haven't had any other issues but this one, but nothing seems to help. For your issue I would try a soft reset and if it doesn't work a hard reset. Should fix the sound and rocker issues. I don't think ill be able to solve the Bluetooth issue until I get Nokia cyan update.
    05-30-2014 11:20 PM
  15. buzzbonner's Avatar
    I'm also having the same problem pairing with my hands free car system. Has worked perfectly until the WP8.1 Dev Preview. I'm using a Nokia 1520.
    07-02-2014 01:20 AM
  16. Blackadder_100's Avatar
    Been having an issue with voice guided navigation instructions when using Here Drive + since 8.1 dev preview update. Would not pair with my Tom Tom hands free until I factory reset the TT. Now the audio has a "buzzing" quality in the background and sometimes Here + freezes while navigating. Streaming music to the TT sounds fine. Hoping 8.1 general release and/or Cyan firmware will resolve it.
    07-02-2014 01:58 AM
  17. ttxzee's Avatar
    Oh, another thing.... Recently my phone froze, and as you know there is no easy way to disconnect the battery as I am used to from previous Nokia phones. However I went and bought a L5 screwdriver (had to buy a whole set) and just screwed off the cover, liftet the tape up and disconnected the battery and assembled it again and everything worked fine.... You might wanna give that a go
    you don't have to do all that work for a "remove battery" reset. just hold volume down and power until the phone vibrates and nokia logo shows up. :)
    07-02-2014 02:59 PM
  18. Mushtaq-ur-Rehman's Avatar
    I am having problem in pairing Luna Bluetooth with my Nokia Lumia 1520....I have Denim update... Please anyone help?
    03-12-2015 02:20 AM

Similar Threads

  1. Replies: 18
    Last Post: 06-16-2014, 11:18 PM
  2. This is Crazy, Lumia 820 overheat on it's own after last 8.1 update
    By imadous in forum Windows Phone 8.1 Preview for Developers
    Replies: 18
    Last Post: 06-11-2014, 09:59 AM
  3. Replies: 2
    Last Post: 05-29-2014, 05:14 AM
  4. 1520 and Runtastic Bluetooth HR Monitor
    By davewoodallpilot in forum Nokia Lumia 1520
    Replies: 1
    Last Post: 05-29-2014, 02:46 AM
  5. Replies: 3
    Last Post: 05-28-2014, 11:06 PM
LINK TO POST COPIED TO CLIPBOARD