1. SteveSAPA's Avatar
    I have 5 email accounts and all work fine accept one which is my work email using exchange. It works fine when I'm connected to my work WiFi but any other time I either get an error code (80072EFD) or that my certificate is not trusted. Any idea what it could be?

    The non trusted certificate comes up on my surface pro 2 but I ticked the ignore button so I never have any issues on that.
    08-29-2014 07:14 PM
  2. aikidaves's Avatar
    Sounds like your Exchange server is inside your corporate firewall, so people outside your company's network can't access it. Can you get a VPN connection through the firewall?
    08-29-2014 09:11 PM
  3. Kebero's Avatar
    Is there an external hostname, such as mail.domain.com?
    08-29-2014 09:29 PM
  4. SteveSAPA's Avatar
    All I did was put in my email, password, and server name which is the same I did on my iphone. It works perfectly on my iphone.
    08-30-2014 03:59 AM
  5. SteveSAPA's Avatar
    It also worked fine on wp8.
    08-30-2014 04:23 AM
  6. SteveSAPA's Avatar
    PS: Thanks for the quick replies.
    08-30-2014 04:24 AM
  7. Pulserider's Avatar
    Something must have changed with the email settings. Maybe you must confirm with your IT department but just something you can try is to change the "Sign with S/MIME" to OFF and the "Encrypt with S/MIME" to OFF?

    Also make sure of the correct Exchange ActiveSync address and remember the "https://"
    09-01-2014 09:15 AM
  8. SteveSAPA's Avatar
    Thanks for your help. I will try it when I get my phone back from Nokia. Had to get the screen fixed.
    09-05-2014 05:15 AM
  9. foxbat121's Avatar
    It has nothing to do with S/MIME which is an email encryption setting. What you need to do is talk to your IT to find out the Mobile ActiveSync server information. However, I suspect your issue is simply the configuration. Typically, an internet facing ActiveSync server (that your phone talks to) must use SSL (https) to secure the communication. SSL requires a certificate. There are two types of SSL certificate: self-generated and public trusted. The former is what a lot of small company uses because it is free. The later requires a yearly fee to purchase a real certificate from publically trusted certificate authority (CA). Mobile phones all come loaded with common known CA root certificates so that any of the certificates issued by them will be recognized. However, this is not the case with self-generated certificates which is what OP encounters. Desktop Windows has work around built-in to let it trust those self-generated certificates easily. On mobile, you will have to import the certificate (preferably the root certificate) manually to the device to grant the trust.

    All this could be avoided if your IT did the job correctly (by purchasing a real certificate).
    SteveSAPA likes this.
    09-05-2014 07:40 AM
  10. SteveSAPA's Avatar
    It has nothing to do with S/MIME which is an email encryption setting. What you need to do is talk to your IT to find out the Mobile ActiveSync server information. However, I suspect your issue is simply the configuration. Typically, an internet facing ActiveSync server (that your phone talks to) must use SSL (https) to secure the communication. SSL requires a certificate. There are two types of SSL certificate: self-generated and public trusted. The former is what a lot of small company uses because it is free. The later requires a yearly fee to purchase a real certificate from publically trusted certificate authority (CA). Mobile phones all come loaded with common known CA root certificates so that any of the certificates issued by them will be recognized. However, this is not the case with self-generated certificates which is what OP encounters. Desktop Windows has work around built-in to let it trust those self-generated certificates easily. On mobile, you will have to import the certificate (preferably the root certificate) manually to the device to grant the trust.

    All this could be avoided if your IT did the job correctly (by purchasing a real certificate).
    You sure know what you are talking about. I spoke to our IT guy. We had a self-generated certificate. We just bought the proper one and all works fine.

    Thanks for your help!!
    11-02-2014 02:05 AM

Similar Threads

  1. [L630] Enabling cortana problem [Portugal]
    By Miguel Correia in forum Ask a Question
    Replies: 4
    Last Post: 10-18-2014, 07:55 PM
  2. Stop the Music when using a GPS Navigation in-car Bluetooth?
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-29-2014, 10:30 PM
  3. Major messaging and call-log problems after updating to Cyan
    By WPCentral Question in forum Ask a Question
    Replies: 1
    Last Post: 08-29-2014, 08:48 PM
  4. Replies: 4
    Last Post: 08-29-2014, 06:01 PM
  5. Problems after Red Stripe deal promotion
    By igorkulman in forum Developers Corner
    Replies: 0
    Last Post: 08-29-2014, 11:40 AM
LINK TO POST COPIED TO CLIPBOARD