1. hfgdskjhfdsjhfdsjkf's Avatar
    When i connect my headset the ring sound is tunneld into the earphones by some stupid reason. If the phone rings, how should I hear the signal if the headset is connected and not put into my ears?

    Question 2.
    Why do i have to restart the phone everytime the connection dies? For example if i walk into a "dead spot" (no connection in area). To get the connection back later i have to restart the phone, why?

    The crap phone I use is Nokia Lumia 1520.

    Regards
    10-28-2014 01:40 PM
  2. her3814's Avatar
    1st question... The same I'm asking myself I have a 630 and even alarms sound in my headsets and sometimes don't listen alarms :\ .. Second thing is really weird.. Maybe you should take it to a Care store so they can take a look at your phone and maybe they'll give you a new one of it's a hardware issue
    10-28-2014 01:46 PM
  3. mj0's Avatar
    The sound issue has been driving me nuts as well. No way to get it fixed right now, Microsoft needs to address that in some future update. For now, the only solution is to use a bluetooth headset such as the Nokia BH-121 (or any other bluetooth headset). That way you have two different ring tones - the phone is ringing and so are the headphones, albeit they have a different ringtone. Doesn't work for notification sounds such as messages or calendar events though, those are once again only available in the headphones.
    10-29-2014 03:23 AM
  4. alex athanasopoulos's Avatar
    When I have my headphones plugged in my L920 I still get to hear the ringing from both the headphones and the phone.

    About your second question/problem I suggest you go to Nokia care to check it, or maybe wait for a software fix.
    10-29-2014 03:44 AM
  5. MATRIX RELOADED's Avatar
    When i connect my headset the ring sound is tunneld into the earphones by some stupid reason. If the phone rings, how should I hear the signal if the headset is connected and not put into my ears?
    Try to do this: plug in your earphones into the phone then click the volume buttons. When the volume menu shows up click the arrow down at the upper right corner to show more volume menu. There is a bell icon at the bottom right (ringer on), click it and this should solve your problem.

    Question 2.
    Why do i have to restart the phone everytime the connection dies? For example if i walk into a "dead spot" (no connection in area). To get the connection back later i have to restart the phone, why?
    Happens to all cellphones from time to time. Even to my wife's GS5. No need to restart the phone, just go to airplane mode for awhile then back. This should reset your connection.

    The crap phone I use is Nokia Lumia 1520.
    Mate, L1520 is far from being crap, I should know cause I'm using one.
    10-29-2014 04:39 AM
  6. mj0's Avatar
    Try to do this: plug in your earphones into the phone then click the volume buttons. When the volume menu shows up click the arrow down at the upper right corner to show more volume menu. There is a bell icon at the bottom right (ringer on), click it and this should solve your problem.
    Not for me it doesn't. It only enables/disables the ringer in the headphones but the phone's speaker remains dead silent as long as there's anything plugged in.

    alex athanasopoulos: what OS are you running on your L920, 8.0 or 8.1? I'm certain this is a software rather than hardware issue so it might be either a new bug that came with 8.1 or something that has been already fixed in more recent DP versions.
    10-29-2014 04:50 AM
  7. Siddharth Bhosle's Avatar
    I have a 535 that was updated recently. the headphone bug is still there :(
    My GF thinks i deliberately avoid picking up her calls and doesn't believe me when I tell her that its Microsoft's fault :P
    05-27-2015 01:26 AM
  8. True Lie's Avatar
    I've been having the same problem for LONG time...
    The solution is to activate the vibration...
    01-21-2017 12:03 PM

Similar Threads

  1. Android Lollipop looking good (so far)
    By thesachd in forum Phone Wars
    Replies: 229
    Last Post: 11-15-2014, 04:19 AM
  2. Replies: 12
    Last Post: 11-02-2014, 03:53 AM
  3. Why is my system taking 4.57 GB?
    By iAdrian23 in forum Windows Phone 8.1
    Replies: 7
    Last Post: 10-30-2014, 01:15 AM
  4. Why doesn't Xbox One dual-boot with Windows?
    By bjax in forum The Xbox Lounge
    Replies: 4
    Last Post: 10-28-2014, 05:10 PM
  5. Why can't you share photos from a phone to this site?
    By Hotvak123 in forum Ask a Question
    Replies: 5
    Last Post: 10-28-2014, 03:37 PM
LINK TO POST COPIED TO CLIPBOARD