The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. wlupus's Avatar
    Have a Lumia 830 with preinstalled Lumia Denim. Glance updated to the last version (3.1.0.21). I switched off saver mode, but glance still shows battery with a shield on it. Also buttons (back, windows and search) do not have a light as if saver mode switched on. Does anyone faced with that problem?
    11-11-2014 07:54 AM
  2. furkanavshar's Avatar
    Yes, the solution is:

    1) Reset your phone
    2) When resetting is completed, complete your installation steps
    3) When the phone is ready to use, quickly go to Settings > Date+Time
    4) Set the year like 2150 or more
    5) Go to Settings, tap the Device Hub
    6) Uninstall it
    7) Set the date as auto again

    Problem is solved.

    Never open Device Hub even once! Uninstall it and don't install again.

    p.s. If you open Device Hub even once, battery saver crashes and your issue comes over again. Then you must reset your phone to solve it.
    Last edited by furkanavshar; 11-11-2014 at 09:33 PM.
    wlupus likes this.
    11-11-2014 09:15 PM
  3. wlupus's Avatar
    Thank you for your responce!

    Could you, please, clarify: under reset you mean hard or soft reset?
    Last edited by wlupus; 11-12-2014 at 01:05 AM. Reason: grammar
    11-12-2014 01:05 AM
  4. furkanavshar's Avatar
    Hard reset. Settings > About > Reset your phone

    But please remember; after the reset, never open Device Hub and remove it by the following these steps I've written my first reply.
    11-12-2014 01:10 AM
  5. wlupus's Avatar
    Thank you very much. I will try it, even if I don't want to reinstall all apps again... Where did you get this soulution? Does anyone post that issue on Microsoft Support?
    11-12-2014 01:41 AM
  6. furkanavshar's Avatar
    Your welcome!

    I've discovered this solution myself; performing hard resets, updating apps one by one and opening them one by one on 5 different Lumia devices for 4 months.
    This solution is permanent. Works 100%
    And this bug belongs to Device Hub 100%
    I informed Lumia team about the solution, then they've confirmed this bug is related to "Device Hub" app. But the relevant team doesn't know the reason.
    11-12-2014 02:04 AM
  7. wlupus's Avatar
    You are a great man, lumia team has to sing a legends in your fame :)
    I have my Lumia 620 with Cyan Update, and there is no any problem with it. Thus, it only happens with WP 8.1 GDR1 or Denim Update, is it?
    11-12-2014 02:14 AM
  8. furkanavshar's Avatar
    Are you sure? Because this issue comes over Lumia 520, 820, 920, 1320 and 1520 with pure Cyan(w/out PD) and also GDR1 PD, also Denim w/out PD
    Please see this thread. There are various Lumia devices fighting against this issue: http://forums.windowscentral.com/win...esnt-work.html

    Your 620 has not this problem? Although you opened Device Hub last days?
    11-12-2014 03:11 AM
  9. wlupus's Avatar
    I can't check it in a moment, but I can definitely say, that I opened device hub at least once about month ago on my Lumia 620 with official Cyan Update, and there is no such kind of issue. Could this problem influence on weather on glance feature? I successfully switched it on on Lumia 620, but it seems to not working on 830...
    11-12-2014 11:47 PM
  10. wlupus's Avatar
    Problem with "always on" shield on battery on glance was solved with the last update of Glance Screen. Dim/light buttons was fixed with the last update of Device&Hub app. Now it is not necessary to hard-reset, just update it and whooala. Thanks for support.
    furkanavshar likes this.
    03-01-2015 02:36 AM

Similar Threads

  1. #MoreLumia - Was that it?
    By secher in forum Upcoming & Rumored Phones
    Replies: 40
    Last Post: 11-26-2014, 11:07 AM
  2. Is Here City Lens available for Lumia 730?
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 11-11-2014, 09:00 AM
  3. Why is my Kuwo Music Player couldn't be opened?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 11-11-2014, 04:55 AM
  4. Replies: 0
    Last Post: 11-11-2014, 01:50 AM
  5. How do I view images in landscape mode?
    By muralidharan lumino in forum Windows Phone 8.1
    Replies: 1
    Last Post: 11-10-2014, 11:15 PM
LINK TO POST COPIED TO CLIPBOARD