1. Beppe Gissi's Avatar
    ...and I do, but it's such an irrational thing.

    I've been using WP for a week now, and besides all the fantastic things here (speed, UI, the "feel" you have a premium OS even if you paid just 100 ), I've been through some really painful issues. And they're a lot for only one week of usage.

    -IE keep crashing everytime I play an embedded YouTube video
    -IE sometimes crashes when I write some comments (also on here)
    -Battery Saver went crazy yesterday and didn't provide proper informations for a while (it showed that only IE and Gmail were using battery, when I've been using WhatsApp all day and it had no usage)
    -I fixed Battery Saver, then just now I updated it to the new version, and it doesn't open anymore. I've setted "show usage in last 48 hours" and since then it just crashes. I can't do anything.

    I still love WP, but damn...I never imagined I would have all this problems in my first WP week.
    11-12-2014 04:26 PM
  2. spaulagain's Avatar
    What device? I've had no such issues. YouTube in browser has been pretty solid on WP for me. Especially with the better video controls in 8.1.
    Karthik Naik likes this.
    11-12-2014 04:28 PM
  3. xandros9's Avatar
    I highly recommend trying myTube or Metrotube.
    Karthik Naik likes this.
    11-12-2014 04:31 PM
  4. Nicholas Maguire's Avatar
    Yeah, I've had no such problems. And as suggested, try myTube or Metrotube for Youtube videos, They are great.
    Karthik Naik likes this.
    11-12-2014 04:34 PM
  5. Beppe Gissi's Avatar
    What device? I've had no such issues. YouTube in browser has been pretty solid on WP for me. Especially with the better video controls in 8.1.
    630. Try to tick the new option "show usage in the last 48 hrs" and maybe you will see. YouTube in browser works properly only on mobile site, which is ok, but is a pain when it comes to embedded videos in websites.
    11-12-2014 04:35 PM
  6. Beppe Gissi's Avatar
    So, now I have done a soft reset (2nd in few days lmao) and battery saver doesn't crash anymore. But now every app has 0% usage.

    This is getting ridiculous, I think battery saver hates me.
    11-12-2014 05:12 PM
  7. Karthik Naik's Avatar
    ...and I do, but it's such an irrational thing.

    I've been using WP for a week now, and besides all the fantastic things here (speed, UI, the "feel" you have a premium OS even if you paid just 100 ), I've been through some really painful issues. And they're a lot for only one week of usage.

    -IE keep crashing everytime I play an embedded YouTube video
    -IE sometimes crashes when I write some comments (also on here)
    -Battery Saver went crazy yesterday and didn't provide proper informations for a while (it showed that only IE and Gmail were using battery, when I've been using WhatsApp all day and it had no usage)
    -I fixed Battery Saver, then just now I updated it to the new version, and it doesn't open anymore. I've setted "show usage in last 48 hours" and since then it just crashes. I can't do anything.

    I still love WP, but damn...I never imagined I would have all this problems in my first WP week.
    download youtube HD
    11-13-2014 03:57 AM
  8. Karthik Naik's Avatar
    So, now I have done a soft reset (2nd in few days lmao) and battery saver doesn't crash anymore. But now every app has 0% usage.

    This is getting ridiculous, I think battery saver hates me.
    dont rely on battery savers on any os imho
    they all use up battery themselves most of the time
    11-13-2014 03:58 AM
  9. RumoredNow's Avatar
    Ever since I've had my 1520.3, I run with Battery Saver off and never worry about it.

    wp_ss_20141113_0001.jpgwp_ss_20141113_0002.jpg
    Karthik Naik likes this.
    11-13-2014 08:45 AM

Similar Threads

  1. Lumia goes back to home by itself
    By deadtorights in forum Nokia Lumia 1520
    Replies: 7
    Last Post: 11-14-2014, 11:07 AM
  2. Thoughts on switching to Android
    By netowp in forum Android Phones
    Replies: 9
    Last Post: 11-13-2014, 07:21 PM
  3. Is there way to take screenshot with the Lumia 520 without the powerbutton?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 11-12-2014, 05:26 PM
  4. Thoughts on switching to Android
    By netowp in forum Windows Phone 8.1
    Replies: 3
    Last Post: 11-12-2014, 03:44 PM
  5. Replies: 0
    Last Post: 11-12-2014, 02:42 PM
LINK TO POST COPIED TO CLIPBOARD