1. eseerc's Avatar
    I purchased a Nokia 520 off of Amazon a couple days ago to give the WP OS a try (I currently use an iPhone). I have an outlook.com email account and set that up on my phone. I noticed that the phone seems to have to re-download longer email conversations each time I open up a message. Is this normal behavior for a WP?
    12-30-2014 08:38 PM
  2. xandros9's Avatar
    I'm not sure. Have you poked into the account settings and made the phone download emails from a longer time period perhaps? (default is the past 7 days, that may be it)
  3. xandros9's Avatar
    I'm not sure. Have you poked into the account settings and made the phone download emails from a longer time period perhaps? (default is the past 7 days, that may be it)
    RumoredNow and Laura Knotek like this.
    12-30-2014 09:13 PM
  4. RumoredNow's Avatar
    Check the settings...

    Settings > email + accounts > tap the account name > download email from (use this dropdown to select a length of time)

    You may be saving too short a span on your device.
    Laura Knotek and xandros9 like this.
    12-30-2014 09:15 PM
  5. Keith Brooks's Avatar
    You also got the Lumia 520 which has slower connection speeds. Lumia 520 doesn't support 4G at all. I have a Lumia 521, it supports low-end 4G, but not 4G LTE. The Lumia 1320 I'm getting soon does support 4G LTE. Also whenever you first set something up the first time and go to run it, it usually take's longer the first time, especially for any email/messaging, etc. apps. Just let it do it's job and later it will speedup as all your past emails are already downloaded. I have mine setup to get all my emails and after maybe 3-5 minutes the first time, the lag is gone.
    Laura Knotek and xandros9 like this.
    12-31-2014 12:24 AM
  6. eseerc's Avatar
    You also got the Lumia 520 which has slower connection speeds. Lumia 520 doesn't support 4G at all. I have a Lumia 521, it supports low-end 4G, but not 4G LTE. The Lumia 1320 I'm getting soon does support 4G LTE. Also whenever you first set something up the first time and go to run it, it usually take's longer the first time, especially for any email/messaging, etc. apps. Just let it do it's job and later it will speedup as all your past emails are already downloaded. I have mine setup to get all my emails and after maybe 3-5 minutes the first time, the lag is gone.
    Thanks for the info. I actually do not have the phone hooked up for cellular use, I only have it on through the WiFi in my home since I only purchased the phone to become familiar with the OS. I do have the email setup to download all messages, but the phone seems to go through a "loading message" prompt when I pull up any message that is a rather long conversation back and forth. Even though the phone is set to download all emails, it seems to have to re-download any of these with longer conversations.
    12-31-2014 07:40 AM
  7. Harrie-S's Avatar
    Open your email app > Push the 3 dots ... > go to settings > scroll down to "always download full message and internet pictures" and mark it.

    This may do the trick.
    RumoredNow likes this.
    12-31-2014 07:53 AM
  8. eseerc's Avatar
    Open your email app > Push the 3 dots ... > go to settings > scroll down to "always download full message and internet pictures" and mark it.

    This may do the trick.
    Thanks for the tip, I already had that option checked though.
    12-31-2014 08:34 AM

Similar Threads

  1. Finding New Music on XBox Music (8.1)
    By sweetback1911 in forum Groove Music
    Replies: 2
    Last Post: 01-15-2015, 08:00 AM
  2. Newbie question about Microsoft surface rt
    By davidhk129 in forum Microsoft Surface for Windows RT
    Replies: 18
    Last Post: 01-14-2015, 05:22 PM
  3. WP Store bug or not?
    By Boris NevermorE in forum Windows Phone 8.1
    Replies: 5
    Last Post: 12-31-2014, 03:24 PM
  4. Can I get some help setting up my outlook.com email?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-30-2014, 02:59 PM
  5. Microsoft has new plans to close the Windows 'app gap', Android support still possible
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 12-30-2014, 11:20 AM
LINK TO POST COPIED TO CLIPBOARD