1. Abhinav Singh7's Avatar
    When i click on the store icon it shows loading for a few minutes then jumps back to the start screen. This has been happening for a couple of hours. I tried a normal restart and a soft reset. Nothing works. I'm able to open it by opening a windows phone store link in internet explorer but directly clicking on the tile just takes me back to the start screen. I'm running wp8.1.1(dp) with lumia Cyan.
    02-11-2015 07:15 AM
  2. pankaj981's Avatar
    This happens when either the Microsoft account is stuck in syncing or when the store is having issues (regular maintenance). Give it a few hours more (or a day). If it still doesn't work then hard reset it is
    02-11-2015 07:31 AM
  3. Abhinav Singh7's Avatar
    Contacted Microsoft support. They told me the store app is corrupted and I need to do a hard reset. Instead I took out my sd card and everything started working fine. Then I put it back in store stopped working. Finally I formatted the memory card and everything is fine.
    02-12-2015 02:24 PM

Similar Threads

  1. Replies: 1
    Last Post: 02-13-2015, 02:31 AM
  2. Why isn't my Lumia 920 showing file explorer anymore (XP)?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-11-2015, 08:59 AM
  3. Microsoft Band page on Face Book
    By bksalt in forum Microsoft Band & Band 2
    Replies: 1
    Last Post: 02-11-2015, 07:42 AM
  4. Why is my phone making a clicking noise or cracking noise?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 02-11-2015, 07:29 AM
  5. Replies: 4
    Last Post: 02-11-2015, 06:32 AM
LINK TO POST COPIED TO CLIPBOARD