The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
03-11-2015 08:27 AM
56 123
tools
  1. sean spamilton's Avatar
    Hey all,

    I'm wondering if I'm alone in this. I've just made the jump to Windows phone (Nokia Lumia 830 w/ Denim) from android, as I've been looking forward to Win 10. I love the start screen and live tiles, and overall the experience has been good. I don't need a ton of apps, and what is available is sufficient for my needs, BUT..

    There are a large number of webpages that don't load correctly when in mobile view. I've gotten blank pages with "error" on the phone, but more often will just get pages that have sections trailing off outside of the viewing area or links that overlap with other links. I can switch to desktop mode which allows me to view the webpages but having to zoom in all the time and have the page re-render is a huge PIA. Forum sites are especially problematic. I've tried just about every browser available. IE, Opera Mini, UC Browser, maxxthon, Surfy; they all run into the same problems. I love the phone but if I can't browse websites properly I'm going to have to revert back to android :(. I really wanted to love this phone and give WP a chance!

    Are there any updates coming soon that might address these issues? / is anyone else experiencing the same problems?

    thanks :)
    02-21-2015 03:11 PM
  2. Jazmac's Avatar
    You have a large number of sites but don't mention any of them. Give us 5.
    02-21-2015 03:15 PM
  3. shishu1's Avatar
    Yup. You maybe alone in this. Maybe something wrong with your WiFi. And maybe mention some sites plz?
    02-21-2015 03:32 PM
  4. sean spamilton's Avatar
    I can give you 4. These seem like the biggest culprits - and happen to be the ones I browse most often. While there's plenty that do work well - I'm just assuming that there will be more that won't as I haven't had the phone for very long. I've included screenshots of what I'm talking about. The error screen is from CBC news. It gets you to the mobile site well enough but when you click on any link you get error. The other 2 are of a typical forum screen in mobile mode.

    Don't get me wrong, there's plenty I do like. The start screen blows away the other OS's, the text input is superior, and I am giddy about Cortana. It's just the darn browser.

    Cbc.ca
    Avsforum.com
    hardwareheaven.com
    Bikeforums.net

    wp-3.jpg
    wp-2.jpg
    Click image for larger version. 

Name:	wp 2.jpg 
Views:	33 
Size:	130.1 KB 
ID:	97919
    Attached Thumbnails wp-1.jpg  
    02-21-2015 03:39 PM
  5. sean spamilton's Avatar
    Hey all, thanks for your responses. I've replied with sites and some screenshots but need to wait for a moderator to approve them before they are posted.

    I must again mention that I'm not trying to dig on WP. I LOVE windows and have always been a PC guy. There's also a ton of stuff WP gets right, but perhaps you'll see what I'm talking about when my images are approved. If it's just me that's great as it means that it's something that can be rectified with a setting perhaps.
    02-21-2015 03:41 PM
  6. shishu1's Avatar
    You can try deleting your history as well. I have seen this trick work many times for various problems. I'll get a better understanding after the images are approved though.
    02-21-2015 03:44 PM
  7. shishu1's Avatar
    Yeah I just opened the sites you mentioned. I found no trouble. Looks like a problem with your connection .
    02-21-2015 03:51 PM
  8. sean spamilton's Avatar
    Hmm... Well I guess I could understand how connection problems would give me an "error" screen, but not how it would produce websites with text out of the viewing area or overlapping hotlinks.

    I'm also using the phone in two places where I've never had any trouble before, work & home - though indeed in this instance work seems more problematic with respect to the CBC website.

    Are you saying that those pages render perfectly on your end? Bizarre. I wonder if the app "tapatalk" I was using previously had something to do with the better rendering. On android when you browse to the site (having allowed the app to run before) it automatically uses the app in conjunction with your browser to display the site, where as on WP the tapatalk app seems to need to be accessed specifically and then the site browsed through the app. I'm just brainstorming.

    The CBC site though definitely doesn't work with the mobile version wherever I happen to be. Just tried it again. It opens, but when you click on a link you just get a white screen w/ or w/ out an error message.

    Maybe the CBC mobile site is experiencing issues and it just happened to coincide with my switching phones?
    02-21-2015 04:06 PM
  9. Jazmac's Avatar
    Thanks for posting those sites. On my 1520, all did ok except for AVSFORUM.com. I got a page similar to what you posted. Seems to render ok on my android. But the rest looked normal on my 1520 using IE.
    02-21-2015 06:51 PM
  10. Jagadeeshvanum's Avatar
    Hey, i understood you.. A few sites are rendered bad in mobile view. So, i always go with desktop view. When you have a badly rendered page, put your phone in landscape mode. Then the part of the page cut out is visible or by refreshing the page you can view it perfectly. But in portrait there's problem with few mobile sites(lenskart, paytm for example in India). I guess these are being improved gradually through updates. Sites i had problem with , in 8.10.12537 software version were working absolutely fine in 8.10.14219. But that paytm mobile site is a headache in internet explorer and uc browser, but works fine in opera mini.
    02-21-2015 07:10 PM
  11. anon(5445874)'s Avatar
    Don't worry, Spartan/Edge will be here soon. Also, I don't have any issues with websites.
    Jazmac likes this.
    02-21-2015 07:27 PM
  12. Rich 3's Avatar
    My wife is leaving WP and going back to Apple for this very reason. She says WP is by far her favourite phone interface but she can't cope with having to often having to use a different device to use the internet. Examples: Fatface.com (clothing shop), she can't logon to Santander banking, Vodafone.co.uk shop page loads for a few seconds then crashes. I'd love her to stay in WP but I just don't know how to make this stuff better.
    02-22-2015 02:50 AM
  13. Rich 3's Avatar
    My wife is suffering the same and is now going back to ios. She loves the WP interface but is fed up with having to keep going to another device to use a different browser. Examples over the last few days: Fatface (clothing), she can't login to Santander banking, Vodafone (uk) shop site loads ok then crashes and the tab closes. I get the same issues on my 1020 which is on developer preview.
    02-22-2015 05:04 AM
  14. Legoboyii's Avatar
    My wife is suffering the same and is now going back to ios. She loves the WP interface but is fed up with having to keep going to another device to use a different browser. Examples over the last few days: Fatface (clothing), she can't login to Santander banking, Vodafone (uk) shop site loads ok then crashes and the tab closes. I get the same issues on my 1020 which is on developer preview.
    Santander is one of the worst banks on earth, switch already!
    02-22-2015 05:13 AM
  15. Rich 3's Avatar
    That may be true, but it's not really the point :), why can I turn on my old iphone 4s that I haven't updated for years and use websites which won't run on WP. We went into town yesterday and tried on an 820 and 920 in store, still no luck. The sites render ok on ie11 on PC
    Last edited by Rich 3; 02-22-2015 at 05:44 AM.
    02-22-2015 05:34 AM
  16. Ymanish's Avatar
    Me and my friend hv the same problem with ie. It renders few sites bad and then crashes quite often.
    02-22-2015 05:34 AM
  17. Ripper Cornelio's Avatar
    Android has a better web browser, i hope this change on Windows 10 (will hace to wait almost another year to see) this os is always waiting to fix their problems, this is how i see xda developers
    Attached Thumbnails wp_ss_20150222_0003.png  
    02-22-2015 10:37 AM
  18. Ripper Cornelio's Avatar
    Another one :v
    Attached Thumbnails wp_ss_20150222_0004.png  
    Jorge Holguin likes this.
    02-22-2015 11:15 AM
  19. shishu1's Avatar
    Ironically, the most crashes I experience are on this site - windows central :P
    02-22-2015 01:35 PM
  20. sean spamilton's Avatar
    Ironically, the most crashes I experience are on this site - windows central :P
    That doesn't surprise me. It seems to stumble over forums the most for me.

    It certainly sounds like I'm not alone in this. I'd like to think Spartan is going to improve on the experience, however seeing as how all the available WP browsers experience the same glitches, I'm inclined to think it's a platform specific problem.

    I guess I'm going to have to decide (in the next few days while I'm within the window of return) whether the great start screen > the problematic browsing experience.
    02-22-2015 01:41 PM
  21. shishu1's Avatar
    Yah but crashing is not the same as a website not rendering properly. Anyways all the best to you ! :)
    02-22-2015 01:48 PM
  22. Jorge Holguin's Avatar
    I got that issue with The Verge and Engaget; the second one happened after the DP on my 1520
    02-22-2015 02:31 PM
  23. DJCBS's Avatar
    Well...you were used to Chrome or Firefox on Android and then moved to IE on Windows Phone.
    It's normal you notice the downgrade in quality. Chrome and Firefox are superior browsers in all platforms they're available.


    IE explorer has evolved with time on WP and it's better than it was. But it's still not Chrome or Firefox. However it's worth mentioning that Microsoft is preparing Spartan which will probably replace IE on WP and is supposed to be a far better browser. So, I think we'll see improvements when Windows Phone 10 and Spartan arrive to the rendering of webpages on WP devices.
    02-22-2015 02:35 PM
  24. Iain_S's Avatar
    the cbc.ca is mostly good, but when going to the news section does give me the same error as you. All other sites render just fine.
    02-22-2015 05:50 PM
  25. Iain_S's Avatar
    XDA renders just fine for me, nothing like what you have there.
    02-22-2015 05:52 PM
56 123

Similar Threads

  1. Replies: 8
    Last Post: 03-11-2015, 09:52 PM
  2. Websites think I am on IE6/7, or 8 when I am actually on IE11.
    By skstrials in forum Internet Explorer
    Replies: 2
    Last Post: 02-21-2015, 11:52 AM
  3. Pebbles website is counting down
    By Lloyydd in forum Smartwatches
    Replies: 2
    Last Post: 02-20-2015, 03:16 AM
  4. Internet Explorer in the Windows 10 phone preview has a new rendering engine
    By WindowsCentral.com in forum Windows Central News Discussion
    Replies: 0
    Last Post: 02-12-2015, 01:30 PM
  5. How do I get my virtual keyboard to autofill in certain websites (SP3)?
    By Windows Central Question in forum Ask a Question
    Replies: 3
    Last Post: 02-10-2015, 04:05 PM
LINK TO POST COPIED TO CLIPBOARD