1. gGpRxLightningx's Avatar
    Recently I bought an unlocked Nokia Icon. It is unlocked, so I assumed it would work with my carrier just like my Nokia 920. I turned it on, transferred my number into a micro SIM. It was working perfectly. Then I updated my phone, and it was still picking up my carrier. Now all of a sudden it says invalid SIM/Missing SIM card. I can't download Access Point and I can't change any of the APN to my carrier's. Can anyone help?
    06-28-2015 07:27 PM
  2. wgrs's Avatar
    Contact problem? Try cleaning the SIM, move it in and out the slot a few times.
    06-28-2015 08:52 PM
  3. gGpRxLightningx's Avatar
    The thing is that I put my SIM card into an iPhone 5s just to see if my SIM was the problem. It worked just fine on the iPhone. So, could dropping the phone have anything to do with it?
    06-28-2015 10:52 PM
  4. RumoredNow's Avatar
    So, could dropping the phone have anything to do with it?
    It could. Dropping a phone can do any number of things...

    Also there is a possibility that money was owed on the device and it is now black listed.

    DO NOT post your IMEI here. Go over to Swappa and use their IMEI checker: https://swappa.com/esn?ref=mobilenat...pUvbUpU3139347
    gGpRxLightningx likes this.
    06-29-2015 10:53 AM
  5. gGpRxLightningx's Avatar
    No, the phone is legit. It's not blacklisted.
    RumoredNow likes this.
    06-29-2015 01:47 PM

Similar Threads

  1. Step Counter stopps counting on a Lumia 640 DS
    By franzmueller555 in forum Windows Phone 8
    Replies: 4
    Last Post: 03-01-2016, 04:58 AM
  2. Overheat issue on 10149 and Lumia 1520
    By maclancer in forum Windows 10 Mobile Insider Preview
    Replies: 11
    Last Post: 07-06-2015, 07:51 AM
  3. Keyboard inputs in Lumia 640xl
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 07-05-2015, 03:09 PM
  4. Why do I still get the "open tasks screen" of wp8.1 after updating to 10149 ?!
    By Mohamed Elgamal in forum Windows 10 Mobile Insider Preview
    Replies: 0
    Last Post: 06-28-2015, 07:12 PM
  5. [L640] Sync problem with gmail contacts?
    By Windows Central Question in forum Ask a Question
    Replies: 0
    Last Post: 06-28-2015, 07:09 PM
LINK TO POST COPIED TO CLIPBOARD