01-19-2016 06:49 AM
47 12
tools
  1. stocktiki's Avatar
    Experiencing a major issue - that I believe is connected with WP 8.1 and Denim. Simply stated - GPS doesn't work with any third-party applications.

    Initially saw this with a Lumia 830. Here Drive, Copilot and other GPS apps keep dropping GPS during driving. I made sure all updates applied. Tried hard and soft resets. Made sure location services turned off - but still - the 830 would initially get a location - but it will freeze after a short time. The default Microsoft-made Maps app works - but that doesn't provide real-time turn-by-turn voice navigation.

    I figured it was just a conflict with AirWatch or other software my company required.

    But then - my wife just got a Lumia 640 (Cricket) and is having the exact same issue. Here, Copilot and other third party apps cannot find and reliably hold a GPS signal good enough for driving directions.

    Intrigued, I downloaded the highly recommended (on this forum) "Hardware Tests" app - to test the GPS. On both the 830 and the 640 the GPS test says "Position source: WiFi" - accuracy 115m - NOT satellite.

    Ironically - our daughter's Lumia 520 works great for driving navigation an in hardware tests shows satellite.

    Thinking this affects newer handsets on "denim." Could someone else test their 640 or 830s or recent Verizon 7 series to see if this issue is widespread. I think it is.

    Thanks!
    prasath1234 likes this.
    08-17-2015 12:20 PM
  2. pankaj981's Avatar
    I have the GPS working flawlessly on my 830 running Denim, in the US and also abroad.
    ven07 and RumoredNow like this.
    08-17-2015 01:15 PM
  3. RumoredNow's Avatar
    Some RM-983 owners are saying they have GPS issues over in the 830 forum... May be a bad build on that variant. IDK what to say about Cricket 640 as I've not followed it.
    ven07 and pankaj981 like this.
    08-17-2015 02:37 PM
  4. libra89's Avatar
    Hmm, this is interesting. I have a 640 (T-Mobile Variant) and I would have to test this with Here Drive when I am going out next. I am going somewhere tonight (a short distance though, like 15 minutes) so I can test this and report back later.

    Edit: I have turned location off in settings for maps, have updated maps, and we'll see how it is. I'll either edit this post again or make a new post in this thread.

    Edit2: I didn't run into the issue you guys seem to be having, even when I purposely went off course from the GPS directions. In those cases, it quickly adjusted to direct me to the right course.
    Last edited by libra89; 08-17-2015 at 04:45 PM.
    pankaj981, ven07 and TechFreak1 like this.
    08-17-2015 03:02 PM
  5. Kevin Houle1's Avatar
    Never had a problem with GPS on either my ativ s or Nokia 1020.
    ven07 likes this.
    08-17-2015 07:18 PM
  6. stocktiki's Avatar
    Thanks everyone for testing this. Could someone run Hardware Tests apps and report back what the GPS test indicates the source and accuracy to be?

    Thanks everyone!
    08-17-2015 10:28 PM
  7. Cody Patterson's Avatar
    I've had lots of Gps problems with my icon(929). I tested the hard ware twzt app and it said, satelite, but I have as well had an issue with it freezing. Especially if I am using the gps, go off the app and cone back sometimes it had frozen.

    The biggest issue I have with Here Drive though myself or any mapping program (and it may just be the 928 & 929 that have these problems is that the car or arrow representing the car doesn't immediately move when you turn the phone like in the iOS counter parts app. So if I am turning it doesn't turn immediately fluidly, it is a more abrupt turn and it's like it is expecting me to turn but get confused if I don't instead of just following what my actual car does.
    08-17-2015 10:40 PM
  8. SteveNoza's Avatar
    It seems like the GPS in my Icon isn't that great, When using maps in bad cell coverage areas, it does not get my location, or is very slow. This is even before the 8.1 update. If I get around to it i'll test it.
    08-17-2015 10:43 PM
  9. Cody Patterson's Avatar
    The 8.1 update, are you talking about you still have 8 not 8.1? Because the newest update to 8.1 itself doesn't fix any of those issues.
    08-17-2015 11:36 PM
  10. SteveNoza's Avatar
    The 8.1 update, are you talking about you still have 8 not 8.1? Because the newest update to 8.1 itself doesn't fix any of those issues.
    You had stated on your original post you thought it was happening with the 8.1/Denim, I was just saying my Icon's GPS has always been weak, even on 8.0/Cyan.
    08-18-2015 08:47 AM
  11. jaimeastin's Avatar
    Your phone needs access to the sky... , so on the dash is preferred... Depending on your physical location (in the car and in the world), you may not been in view of a enough satellites...

    I have not had an issue with any of my phoes (900, 920, 1420, 635, or the new 640) which are all att ... Make sure your maps are downloaded, turn off Wi-Fi and data, then try to use the apps... Let it solely work off the gps and see... Just for testing.
    RumoredNow likes this.
    08-18-2015 09:04 AM
  12. Cody Patterson's Avatar
    I didn't state that on my post. I've always had the problems on both my icon and my 929. I'm not the original poster I'm someone agreeing that these problems exist.
    SteveNoza likes this.
    08-18-2015 06:04 PM
  13. Cody Patterson's Avatar
    Your phone needs access to the sky... , so on the dash is preferred... Depending on your physical location (in the car and in the world), you may not been in view of a enough satellites...

    I have not had an issue with any of my phoes (900, 920, 1420, 635, or the new 640) which are all att ... Make sure your maps are downloaded, turn off Wi-Fi and data, then try to use the apps... Let it solely work off the gps and see... Just for testing.
    Sadly that is not the solution to the problems we have been facing.
    08-18-2015 06:04 PM
  14. SteveNoza's Avatar
    Your phone needs access to the sky... , so on the dash is preferred... Depending on your physical location (in the car and in the world), you may not been in view of a enough satellites...

    I have not had an issue with any of my phoes (900, 920, 1420, 635, or the new 640) which are all att ... Make sure your maps are downloaded, turn off Wi-Fi and data, then try to use the apps... Let it solely work off the gps and see... Just for testing.
    Yeah, I was thinking about the possibility that the Icon is slow switching from cellular/ WiFi to the GPS. My last phone, a BlackBerry Q10, had a great GPS, in fact I had ViewRanger (a mapping GPS app that's sadly not available on Windows Phone), and it worked as well as my handheld Garmin 76S does!
    prasath1234 likes this.
    08-18-2015 10:39 PM
  15. Rich215's Avatar
    I've had lots of Gps problems with my icon(929). I tested the hard ware twzt app and it said, satelite, but I have as well had an issue with it freezing. Especially if I am using the gps, go off the app and cone back sometimes it had frozen.
    What is the twzt app?
    08-19-2015 08:17 AM
  16. RumoredNow's Avatar
    What is the twzt app?
    I believe that is a typo for test app. Hardware test app.
    08-19-2015 09:46 AM
  17. Cody Patterson's Avatar
    I believe that is a typo for test app. Hardware test app.
    Yeah sorry
    RumoredNow likes this.
    08-19-2015 09:58 PM
  18. RumoredNow's Avatar
    Yeah sorry
    No apologies necessary. Show me a user who has no typos and I'll show you a user who never types anything. Haha.
    08-19-2015 10:10 PM
  19. tangledW's Avatar
    Yep. GPS connectivity is as bad it's Bluetooth on all of my 830 Lumias. It's simply a poorly built/designed phone.
    Last edited by tangledW; 08-20-2015 at 11:22 AM.
    08-19-2015 10:30 PM
  20. pankaj981's Avatar
    Yep. GPS connectivity is as bad it's Bluetooth on all of my 830 Lumias. It's simply a poorly built/designed phone.
    I think you missed the IMO
    08-20-2015 02:04 PM
  21. tangledW's Avatar
    I think you missed the IMO
    Nah, I'm on my 4th one. It's a piece of crap.
    08-20-2015 05:08 PM
  22. wgrs's Avatar
    No problems with 730 and 640. I was driving thousands of km with Here Drive.

    The 640 is particularly good. The 730 sometimes needs 30-60 seconds for a reliable GPS lock.
    libra89 likes this.
    08-20-2015 11:26 PM
  23. pankaj981's Avatar
    Nah, I'm on my 4th one. It's a piece of crap.
    In that case it's unfortunate because my 830 (RM-985) does not have any problems.
    08-21-2015 01:45 AM
  24. anon(9707071)'s Avatar
    ok people i have HUGE issues on my L640 XL !!! after one week of tests i can CONFIRM that GPS offline, only works when i AM close to HOME!!!!! WTF ??? yes first time i tested it was there...but 3km away and nothing GPS is dead !!!
    harware apps did say by default gps is cellular (of couse all cellular is OFF and my sim is 2G only) and the fix is to activate airplane mode redo the test and it says source location satellite....

    why does GPS only work when home? i did everything: soft reset, hard reset, uninstall etc...nothing seems to FIX this!! any ideas would be appreciated !!!

    does that mean that hardware wise my gps is ok ? i would prefer that the issue is software....

    the problem like someone told me is that Microsoft enables GPS by cellular by default!!! whyyyyy ?!!!! crappppppp
    Last edited by nenito2k; 11-19-2015 at 01:17 PM.
    11-18-2015 11:36 AM
  25. offroadjunkie's Avatar
    I'm new here and all but don't you want your GPS turned on to use navigation even with offline maps? Why wouldn't you want it using the satellite?
    libra89 likes this.
    11-19-2015 01:19 AM
47 12

Similar Threads

  1. Do, does Windows 10 not work with Avast at all?
    By Windows Central Question in forum Windows 10
    Replies: 3
    Last Post: 09-05-2015, 10:29 AM
  2. [Help] Windows 10 has no internet access?
    By JIM McMannes in forum Ask a Question
    Replies: 8
    Last Post: 08-18-2015, 07:26 AM
  3. How to synchronise Liumia 930 Wieless with PS (windows 10)?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-17-2015, 12:43 PM
  4. Why can't I open Windows store?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 08-17-2015, 12:34 PM
  5. Windows 10 update slowdown my pc
    By guru don in forum Ask a Question
    Replies: 0
    Last Post: 08-17-2015, 11:46 AM
LINK TO POST COPIED TO CLIPBOARD