1. Birgitte Sciarretta's Avatar
    I have a Lumia 640 LTE that I use with a Straighttalk T-Mobile sim. This works great, I can browse the internet on my cellular network, I can send MMS and people see the pics I send. But I can't receive MMS. I get a message to download media content but it never shows up.

    I have a feeling it is not the APN settings, I have tried about 15 different configurations and the settings I have now work great except for receiving MMS. Any other settings won't let me send MMS or browse the internet.

    If not APN, what else can I try? I have owned my phone since July and have yet to receive a single MMS....
    Arlan Henry likes this.
    10-09-2015 04:56 PM
  2. gordonfink's Avatar
    When you bought the phone, did you register it on your account (provide your carrier the IMEI)?

    I had a similar thing with ATT, where, after a few months, their system figured out I had an IMEI mismatch, and I stopped receiving MMS. I called them, they updated their system, and all was good.
    10-09-2015 07:15 PM
  3. Birgitte Sciarretta's Avatar
    No, the IMEI was registered. I have never been able to receive a single MMS since I bought it. I can send them fine, though.
    10-09-2015 07:21 PM
  4. gordonfink's Avatar
    Can you access internet explorer? Seems like there must be a data setting someplace.
    10-09-2015 07:45 PM
  5. Birgitte Sciarretta's Avatar
    I have no problem accessing Internet Explorer on the cellular network or with Wifi. Like I am saying, I don't think the error is in the APN settings. I have read how people were able to set up fake access points (with apps that are no longer available). Is there a way to do that currently?

    Never mind, I got it. APN settings are as follows:

    For Straight Talk with T-Mobile, use these settings:

    For Internet, just put wap.tracfone for APN and save.
    For MMS:

    APN: wap.tracfone
    WAP Gateway: 216.155.165.40
    WAP Port: 8080
    MMSC: http://mms.tracfone.com
    MMSC port: 80
    Max MMS Size: 10485
    Last edited by Birgitte Sciarretta; 11-23-2015 at 02:50 PM.
    10-09-2015 07:51 PM
  6. lockvine's Avatar
    I haven't found a good fix yet but a work around that seems to work fine for me is to turn off wifi then download the message. I only have problems sending and receiving MMS's when i'm on wifi. Turn that off everything works fine.
    05-23-2016 02:08 PM

Similar Threads

  1. Ditch iPhone for Lumia 830?
    By Windows Central Question in forum Nokia Lumia 830
    Replies: 4
    Last Post: 12-11-2015, 02:48 AM
  2. Microsoft is not ready to do "whatever it takes" for Windows Mobile
    By JohnIvory in forum Microsoft News & Rumors
    Replies: 115
    Last Post: 11-06-2015, 09:49 AM
  3. App never pinned to start
    By honda accord 99 in forum Nokia Lumia 1520
    Replies: 2
    Last Post: 10-09-2015, 04:40 PM
  4. With a Surface 3 and Windows 10, does anyone know how to keep the camera function unlocked?
    By Windows Central Question in forum Microsoft Surface Pro 3
    Replies: 0
    Last Post: 10-09-2015, 04:38 PM
  5. Replies: 0
    Last Post: 10-09-2015, 04:25 PM
LINK TO POST COPIED TO CLIPBOARD