1. hardywang's Avatar
    I am pretty sure it is either an OS bug or hardware bug, but I don't know which one it is.I have BLU Win HD with both SIM cards inserted, Wind Mobile slot 1, Rogers slot 2. So by default the cellular data comes from SIM 1, which is Wind.I want to make Rogers my cellular data connection so I go to Settings -> cellular + SIM -> SIM for data connection to pick SIM 2: ROGERS. The phone will disconnect and reconnect from both networks at same time in order to switch the data connection. From this point on I have experienced several behaviours:
    • Most of the time after cellular networks comes back, Wind (SIM 1) is always in "away" mode. Since I also have the setting Data roaming options to be "don't roam", it looks like this setting also blocks Rogers network (SIM2) from using any data. I would assume "don't roam" should only be limited to one single SIM not entire phone level.
    • There are also a few time after both networks are connected, all the settings are switched back to it was: data is from Wind (SIM1).

    I believe if I simply pull out Wind (SIM1), it works fine with just a Rogers SIM. But with both SIM cards inserted I have some trouble.Any idea is it a common problem? Somebody also experienced same issue? Is there a way to fix?
    12-18-2015 10:52 AM
  2. Zulfigar's Avatar
    Have you tried swapping the two SIM cards locations?
    12-18-2015 11:03 AM
  3. hardywang's Avatar
    Have you tried swapping the two SIM cards locations?
    No, I haven't. BLU's 2 slots are 1 micro SIM and 1 standard SIM. I probably need a SIM cutter first to swap them.
    12-18-2015 03:00 PM
  4. Zulfigar's Avatar
    Ahh, I see, I think I recall that the data on SIM 1 gets primary function, so swapping the two might actually solve your issue.
    12-19-2015 12:09 PM

Similar Threads

  1. How can I _completely_ turn off message sounds?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 12-23-2015, 08:56 AM
  2. Replies: 81
    Last Post: 12-22-2015, 02:13 AM
  3. Guys the data on my phone will be reset/delete if i upgrade from 8.1 to win 10
    By Windows Central Question in forum Ask a Question
    Replies: 2
    Last Post: 12-18-2015, 11:12 AM
  4. Does WhatsApp have automatic backup to ONE DRIVE?
    By emjey in forum Windows Apps
    Replies: 1
    Last Post: 12-18-2015, 07:14 AM
  5. Replies: 1
    Last Post: 12-18-2015, 03:08 AM
LINK TO POST COPIED TO CLIPBOARD