1. windobuddies625's Avatar
    Today my Lumia 1320 battery while using it with 2G at 49% suddenly showed 9% and said battery critical so I plugged it in and then after a few secs it started charging from where it was initially 49%. Weird!
    01-22-2016 08:17 AM
  2. Jazmac's Avatar
    Bad battery. Same happened to my 1520. So I replaced it.
    Guytronic likes this.
    01-22-2016 08:30 AM
  3. windobuddies625's Avatar
    Bad battery. Same happened to my 1520. So I replaced it.
    How old is your 1520?
    01-22-2016 08:55 AM
  4. djeire84's Avatar
    Today my Lumia 1320 battery while using it with 2G at 49% suddenly showed 9% and said battery critical so I plugged it in and then after a few secs it started charging from where it was initially 49%. Weird!

    You could also try checking on battery saver something might be running in the background it could prolong your battery, also you could hard reset your phone **note backup your phone first**
    01-22-2016 09:01 AM
  5. Jazmac's Avatar
    How old is your 1520?
    I can't be sure but it at least 3 years old. I didn't begin to have trouble with my 1520 until I visited the Technical Preview. Then the problems would not stop. Rolling back to 8.1 didn't resolve it either but the issue was more pronounced on W10M. One of the symptoms was if I snapped a picture with a full battery, my phone would shut down and restart. When it made it to the home screen, the battery was at almost 10 percent. Really odd. I launched one of my all time time waster games Red Herring and the phone would freeze up. When I restarted, battery was almost dead. Then I got my pry bar out and went in. Replaced the battery and its all good.
    Guytronic likes this.
    01-22-2016 09:40 AM
  6. windobuddies625's Avatar
    You could also try checking on battery saver something might be running in the background it could prolong your battery, also you could hard reset your phone **note backup your phone first**
    Did two hard resets and re installed wp 8.1 via WDRT. Nothing helped.
    01-22-2016 09:59 AM
  7. windobuddies625's Avatar
    I can't be sure but it at least 3 years old. I didn't begin to have trouble with my 1520 until I visited the Technical Preview. Then the problems would not stop. Rolling back to 8.1 didn't resolve it either but the issue was more pronounced on W10M. One of the symptoms was if I snapped a picture with a full battery, my phone would shut down and restart. When it made it to the home screen, the battery was at almost 10 percent. Really odd. I launched one of my all time time waster games Red Herring and the phone would freeze up. When I restarted, battery was almost dead. Then I got my pry bar out and went in. Replaced the battery and its all good.
    Well same here.. The phone was perfect with the battery giving 2 days with medium usage. Ever since the phone restarted after enrolling for build 10586.29 thru insider. The battery started to give me these weird issues and drain without usage also.
    01-22-2016 10:01 AM
  8. windobuddies625's Avatar
    My phone is only 1 year and 8 months.
    01-22-2016 10:01 AM
  9. Jazmac's Avatar
    Well same here.. The phone was perfect with the battery giving 2 days with medium usage. Ever since the phone restarted after enrolling for build 10586.29 thru insider. The battery started to give me these weird issues and drain without usage also.
    I'm not sure my solution will work for everyone but I do know how Microsoft builds its software. It will use any and every morsel of memory that can be addressed in the device. If there is a weakness, it'll be exposed. I've seen it in PC's. I suppose that is what happened with my phone and probably what's going on with yours. As long as you stayed with Win 8/8.1, you're good. Make the phone re-sample memory and its a whole new ball game from then on.
    Guytronic likes this.
    01-22-2016 08:27 PM
  10. djeire84's Avatar
    Did two hard resets and re installed wp 8.1 via WDRT. Nothing helped.

    Me thinks replacement battery is in order.
    Jazmac likes this.
    01-22-2016 10:09 PM
  11. windobuddies625's Avatar
    I'm not sure my solution will work for everyone but I do know how Microsoft builds its software. It will use any and every morsel of memory that can be addressed in the device. If there is a weakness, it'll be exposed. I've seen it in PC's. I suppose that is what happened with my phone and probably what's going on with yours. As long as you stayed with Win 8/8.1, you're good. Make the phone re-sample memory and its a whole new ball game from then on.
    After getting the update I did not download or install 10. Hard reset and stuck with 8.1 only.
    01-22-2016 10:26 PM

Similar Threads

  1. "Something's Wrong"
    By Richard Durishin in forum Cortana
    Replies: 1
    Last Post: 01-25-2016, 11:27 AM
  2. What battery life cycle is normal?
    By hardywang in forum Microsoft Lumia 950 XL
    Replies: 27
    Last Post: 01-25-2016, 10:06 AM
  3. Errr, why I don't see free dock offer any more in Lumia Offer app?
    By hardywang in forum Microsoft Lumia 950 XL
    Replies: 7
    Last Post: 01-22-2016, 10:34 PM
  4. Replies: 1
    Last Post: 01-22-2016, 02:19 AM
  5. I can't install any apps in my store, why?
    By Windows Central Question in forum Ask a Question
    Replies: 1
    Last Post: 01-21-2016, 11:35 PM
LINK TO POST COPIED TO CLIPBOARD