06-05-2014 04:46 PM
109 12345
tools
  1. Asrialys's Avatar
    So anyone still having trouble getting Album Art to stick without using some app? You'll need Windows Media Player and the artwork. Just open the library on Windows Media Player and drag and drop the appropriate art on the appropriate song or album. Done.

    Note: If there are any songs that don't have a set artwork, then the last artwork you used will appear for that song when played on Windows Media Player. However, that's just a weird quirk. That song doesn't actually have that artwork attached to it.

    Geez. Don't abandon something useful like Zune until you can replace it with something just as useful, if not better, Microsoft. It's not like everyone has songs that are in your store. None of mine are :P
    Muessig, Whachusay and dgr_874 like this.
    07-26-2013 01:06 AM
  2. Daves6's Avatar
    Hey guys, posted a thread few days back and got a reply to here but didn't find the solution here. Any help?
    this is the problem: http://forums.windowscentral.com/win...ic-player.html
    08-01-2013 05:23 AM
  3. Whachusay's Avatar
    One of the moderators led me to this thread because I'm having a weird but annoying issue on my Lumia 920. All of my music appears correctly in Windows Media Player but for some reason, weird text shows up on my phone when it comes to music I have in other languages. I read your post, downloaded Media Monkey to make sure my tags were correct, everything appears fine in Media Monkey, but it still is coming out weird on my phone. Any idea what the issue is and how to fix it?

    Here is my post with screenshots of my problem.

    I really like my phone but I am very particular about organization... Hehe.
    08-03-2013 06:31 PM
  4. Asrialys's Avatar
    One of the moderators led me to this thread because I'm having a weird but annoying issue on my Lumia 920. All of my music appears correctly in Windows Media Player but for some reason, weird text shows up on my phone when it comes to music I have in other languages. I read your post, downloaded Media Monkey to make sure my tags were correct, everything appears fine in Media Monkey, but it still is coming out weird on my phone. Any idea what the issue is and how to fix it?

    Here is my post with screenshots of my problem.

    I really like my phone but I am very particular about organization... Hehe.
    I can get Japanese characters (haven't tried anything else) to appear on my Lumia 925 just fine. However, I edited my tags using the Zune software. Apparently, editing the "TItle" on Windows Media Player doesn't actually change the file's Title tag. Trying to edit the tag from File Explorer doesn't seem to work either. What the heck Microsoft?

    Anyway, I would thing Media Monkey would work. Haven't tried it myself, but I would think any tag editor that does its job properly would work...

    How are you modifying the tags, if at all? Are you retyping the characters? Copying and pasting?
    08-04-2013 02:02 AM
  5. Muessig's Avatar
    I think the MusicBrainz Picard tool I mention in the OP will let you edit your actual file data, but I'd have thought Media Monkey would let you do it too. Try MusicBrainz Picard and see if that does the trick for you.
    08-04-2013 02:27 AM
  6. Whachusay's Avatar
    I can get Japanese characters (haven't tried anything else) to appear on my Lumia 925 just fine. However, I edited my tags using the Zune software. Apparently, editing the "TItle" on Windows Media Player doesn't actually change the file's Title tag. Trying to edit the tag from File Explorer doesn't seem to work either. What the heck Microsoft?

    Anyway, I would thing Media Monkey would work. Haven't tried it myself, but I would think any tag editor that does its job properly would work...

    How are you modifying the tags, if at all? Are you retyping the characters? Copying and pasting?
    That's the thing, my music appears fine in iTunes and in windows explorer - the title, everything. But when I sync to my phone all these weird characters come up. It doesn't happen with all my music though, just some. I have Korean and Japanese songs that show up fine on my phone and some that doesn't, so I'm starting to think its the files itself. Although everything appears fine on my computer. I would stop by to my local Microsoft store, but they aren't the most helpful there.
    08-04-2013 02:03 PM
  7. philippefv's Avatar
    Thanks for the very informative article. I have a Nokia Lumia 810. I have both "Music + Videos" and "Nokia Music" on my phone, but I do not have "Xbox Music". I also have a 6 Gig SD card in the phone. Everytime I rip and then sync Windows Media Center to the phone, I find that I have two (2) complete recordings on the phone. How do I delete an entire "album" from my phone? I only need one copy and the extra copy eats into my free space on the SD card.

    Many thanks.
    08-04-2013 04:35 PM
  8. WPhoney's Avatar
    All of my music appears correctly in Windows Media Player but for some reason, weird text shows up on my phone when it comes to music I have in other languages. [...]

    Here is my post with screenshots of my problem.
    My guess: the tags were written using a particular Character Encoding (perhaps UTF-8, Korean JOHAB, Chinese Simplified GBK, etc). The software in your computer supports the particular Character Encoding your tags are using, but the app on your phone does not.

    The solution is to re-write the problematic tags using a Character Encoding that is supported by both your PC applications and your phone app. Alternatively, you can install a different music app and see if it supports that particular Character Encoding.
    08-04-2013 04:37 PM
  9. Whachusay's Avatar
    My guess: the tags were written using a particular Character Encoding (perhaps UTF-8, Korean JOHAB, Chinese Simplified GBK, etc). The software in your computer supports the particular Character Encoding your tags are using, but the app on your phone does not.

    The solution is to re-write the problematic tags using a Character Encoding that is supported by both your PC applications and your phone app. Alternatively, you can install a different music app and see if it supports that particular Character Encoding.
    Thank you, that makes a lot of sense. Some of the characters work so, so I'm going to assume (could be wrong) that some of the character encoding is supported and some of it isn't. I downloaded Nokia Music and it's not any different than Xbox Music - still having the same issue. I understand what you are saying by rewriting the problematic tags using a supported Character Encoding, but I am not knowledgeable as to how to do that.
    08-04-2013 06:30 PM
  10. WPhoney's Avatar
    I understand what you are saying by rewriting the problematic tags using a supported Character Encoding, but I am not knowledgeable as to how to do that.
    I don't know either. Try asking at a Music/MP3 forum. The iTunes forum, for example.
    08-04-2013 06:53 PM
  11. Whachusay's Avatar
    I don't know either. Try asking at a Music/MP3 forum. The iTunes forum, for example.
    Thanks for your help!
    08-04-2013 07:05 PM
  12. iGeorge23's Avatar
    Thanks for this great forum!
    08-04-2013 07:36 PM
  13. Asrialys's Avatar
    Thank you, that makes a lot of sense. Some of the characters work so, so I'm going to assume (could be wrong) that some of the character encoding is supported and some of it isn't. I downloaded Nokia Music and it's not any different than Xbox Music - still having the same issue. I understand what you are saying by rewriting the problematic tags using a supported Character Encoding, but I am not knowledgeable as to how to do that.
    Do you mind saving one of these songs to SkyDrive or something and then share the link to me over PM. I want to take a look at it and try a thing or two.
    Whachusay likes this.
    08-04-2013 08:02 PM
  14. Whachusay's Avatar
    Do you mind saving one of these songs to SkyDrive or something and then share the link to me over PM. I want to take a look at it and try a thing or two.
    Not a problem. I sent you a PM. Thanks!
    08-04-2013 09:58 PM
  15. MrTofu's Avatar
    Just came across this thread. Thanks OP!
    Muessig likes this.
    08-05-2013 11:30 AM
  16. Whachusay's Avatar
    Thank you, that makes a lot of sense. Some of the characters work so, so I'm going to assume (could be wrong) that some of the character encoding is supported and some of it isn't. I downloaded Nokia Music and it's not any different than Xbox Music - still having the same issue. I understand what you are saying by rewriting the problematic tags using a supported Character Encoding, but I am not knowledgeable as to how to do that.
    Well, it seems that I have found out what the name of my problem is - mojibake. And it does have to do with the character encoding of my music. I downloaded a program to help me with my issue. Foobar 2000. There is a component that actually lets me edit the metadata charset so I can stop having this problem. I'm still trying to figure out but I feel closer to solving my problem, and wanted to share in case anyone else comes across this issue.
    Muessig likes this.
    08-05-2013 01:15 PM
  17. Muessig's Avatar
    Well, it seems that I have found out what the name of my problem is - mojibake. And it does have to do with the character encoding of my music. I downloaded a program to help me with my issue. Foobar 2000. There is a component that actually lets me edit the metadata charset so I can stop having this problem. I'm still trying to figure out but I feel closer to solving my problem, and wanted to share in case anyone else comes across this issue.
    I'm pretty sure that you can edit the metadata in MusicBrainz Picard as above, but it's great to have options so I'll add FooBar 2000 into the OP. Thanks!
    Whachusay likes this.
    08-05-2013 01:28 PM
  18. Whachusay's Avatar
    I'm pretty sure that you can edit the metadata in MusicBrainz Picard as above, but it's great to have options so I'll add FooBar 2000 into the OP. Thanks!
    I'm pretty sure I'm doing something wrong. In MusicBrainz Picard my music appears correctly, but I re-write the tags just because I know I'm having issues, and when I sync my music, it still comes up with the mojibake nonsense. I wish anyone else with the issue luck, because I am about to give up.
    08-05-2013 02:45 PM
  19. Asrialys's Avatar
    So did Foobar work for you? I couldn't even get MP3Tag to get it to change on my phone. I can mess around with tags all I want with my other music and changes will be applied, but your file wouldn't transfer those changes to my phone, even though the tags were clearly different on my computer (Zune, Windows Media Player, File Explorer, etc.).
    08-06-2013 02:12 AM
  20. WPhoney's Avatar
    I'm pretty sure I'm doing something wrong.
    Maybe the root of the problem is deeper than the tags themselves. Download the freeware MP3 Diags and see if there's some malformed/corrupted element inside the file. I've used this program several times to fix MP3s that wouldn't play or whose tags had problems. Warning: this program isn't very intuitive, so you'll need to spend some time playing with it and reading the documentation to figure it out.

    Keep us posted on your progress.
    Muessig and Whachusay like this.
    08-06-2013 02:59 AM
  21. Whachusay's Avatar
    So did Foobar work for you? I couldn't even get MP3Tag to get it to change on my phone. I can mess around with tags all I want with my other music and changes will be applied, but your file wouldn't transfer those changes to my phone, even though the tags were clearly different on my computer (Zune, Windows Media Player, File Explorer, etc.).
    Yeah, that's the problem I'm having. It shows completely normal on my computer but on the phone it looks like a mess. Foobar got me closer to solving the problem so I thought, but it still didn't work.
    08-07-2013 08:43 PM
  22. Whachusay's Avatar
    Maybe the root of the problem is deeper than the tags themselves. Download the freeware MP3 Diags and see if there's some malformed/corrupted element inside the file. I've used this program several times to fix MP3s that wouldn't play or whose tags had problems. Warning: this program isn't very intuitive, so you'll need to spend some time playing with it and reading the documentation to figure it out.

    Keep us posted on your progress.
    I'll try this out, and let you know. Thank you all for your help.
    08-07-2013 08:45 PM
  23. Whachusay's Avatar
    Maybe the root of the problem is deeper than the tags themselves. Download the freeware MP3 Diags and see if there's some malformed/corrupted element inside the file. I've used this program several times to fix MP3s that wouldn't play or whose tags had problems. Warning: this program isn't very intuitive, so you'll need to spend some time playing with it and reading the documentation to figure it out.

    Keep us posted on your progress.
    It worked! This program worked! When I scanned my files, it showed me all the issues and offers fixes for them. Thank you so much!!!
    Muessig likes this.
    08-07-2013 09:31 PM
  24. WPhoney's Avatar
    It worked! This program worked! When I scanned my files, it showed me all the issues and offers fixes for them. Thank you so much!!!
    You're welcome, mate! Enjoy your tunes!
    Whachusay likes this.
    08-07-2013 09:37 PM
  25. Asrialys's Avatar
    lol Was just about to suggest the old method of burning affected music to an audio CD, and then ripping everything. Would probably need to re-tag everything though. However, it did work for me.

    But WPhoney's method might probably be more efficient...
    Whachusay likes this.
    08-07-2013 09:42 PM
109 12345

Similar Threads

  1. Best Windows Phone 8 music and playlist manager
    By RonV42 in forum Windows Phone 8
    Replies: 7
    Last Post: 03-16-2015, 10:42 AM
  2. Replies: 3
    Last Post: 04-18-2013, 12:25 AM
  3. Replies: 6
    Last Post: 02-03-2012, 06:38 PM
  4. Replies: 8
    Last Post: 12-07-2011, 11:56 AM
  5. A missed Opportunity. Windows Phone and LTE
    By jdevenberg in forum Windows Phone 7
    Replies: 10
    Last Post: 11-07-2011, 08:35 PM
LINK TO POST COPIED TO CLIPBOARD