1. castewa88's Avatar
    On the Albums pivot in the Photo Hub, all of the Local and Facebook albums with at least one picture show a picture on the album tile. However, the SkyDrive tiles are just blank (or black) even if they do have a picture in album. In WP7, these covers also showed one of the pictures, but on my Lumia 920 (WP8) they won't. Any ideas?
    11-19-2012 06:41 PM
  2. vdubskey's Avatar
    This is also happening to me. It happened to my Mobile Uploads folder first. So I deleted it. Restarted the phone. Added it back. Restarted the phone and it was fine. Now my other albums on SkyDrive are doing it. But I just recently added a totally new folder and that one has an album cover. It makes the album view look ugly with a bunch of grey tiles.
    11-25-2012 09:30 PM
  3. castewa88's Avatar
    I thought I'd resolved the issue by creating all new folders and moving my photos to the new folders. This made the album covers show, so I thought there must've just been something corrput with the older folders and I deleted them since they had been emptied when I moved the pics over. Now, the problem has come back with all of the new folders. Like you said, it makes the view ugly with all of the grey tiles. It must be some kind of bug with the SkyDrive integration. Maybe that can find it and fix it on SkyDrive without having to update the phone OS.
    11-26-2012 12:39 PM
  4. vdubskey's Avatar
    Yea I was gonna tweet windows phone support but I'm still having them look into why board express isn't letting me purchase it. I'll shoot them a tweet tomorrow. They are actually pretty quick with responses.
    11-26-2012 09:46 PM
  5. castewa88's Avatar
    I talked with them last week. (https://twitter.com/castewa88/status/271398090471264256)

    That led me to the temporary fix of deleting and recreating the folders. The fix just didn't last.
    11-27-2012 08:46 AM
  6. tibere86's Avatar
    +1

    Count me in as another one having this issue.
    12-08-2012 11:11 PM
  7. CJ Thunder's Avatar
    I have been having this issue on WP7 and now in W8 as well. Can't say about WP8, but it is an issue.
    12-08-2012 11:34 PM
  8. E Lizzle's Avatar
    Same problem here. There's also an issue where videos taken on the phone have a gray icon on the skydrive website.

    -E
    12-09-2012 09:08 AM
  9. CJ Thunder's Avatar
    Looks perfect on SkyDrive app for Xbox. So WP7 and W8 errors...
    12-12-2012 12:13 AM
  10. Lundon44's Avatar
    Unfortunate to see it's been months with still no fix in sight. Slowly each folder in becoming greyed out over time. Also note that you cannot pin these grey folders to the homescreen anymore.

    Very unfortunate...
    03-25-2013 02:45 PM
  11. pmhgeneral's Avatar
    Unfortunate to see it's been months with still no fix in sight. Slowly each folder in becoming greyed out over time. Also note that you cannot pin these grey folders to the homescreen anymore.

    Very unfortunate...
    This has been on going for some time now. Here is another link for you.
    http://forums.windowscentral.com/win...-previews.html
    Sent from my {Nokia 822} using Board Express.
    03-25-2013 03:26 PM
  12. E Lizzle's Avatar
    Looks perfect on SkyDrive app for Xbox. So WP7 and W8 errors...
    FWIW it looks OK in the skydrive app for WP8, just not in the internal Photos hub.
    03-25-2013 04:12 PM
  13. pmhgeneral's Avatar
    I have just found this out, I did this test, 1st I made all new albums, moved pictures, deleted old ones in SkyDrive and all was ok for over 3 weeks. BUT then I turn off my phone then turn it back on and YES they are gone again. This happened before and I thought I would do this test to see for sure. So just don't turn off your phone and you're good to go. So I guess it's like having a car but not being able to drive it forward but only in reverse like Windows Phone is heading.
    03-28-2013 06:51 PM
  14. Sam Wong's Avatar
    I'm sure the issue is not related to phone being power off. I moved around all my Photo folders in Skydrive a few days ago. The covers appear ok now and I power off my phone every night. I guess it is something else that trigger the issue but I'm not sure what.
    04-20-2013 08:38 PM
  15. pmhgeneral's Avatar
    I'm sure the issue is not related to phone being power off. I moved around all my Photo folders in Skydrive a few days ago. The covers appear ok now and I power off my phone every night. I guess it is something else that trigger the issue but I'm not sure what.
    well for me it is related to powering of the phone. All my photos are ok until I power off phone then "bam" there gone. MS email me and is working on it. No update as of today.
    06-20-2013 05:19 AM
  16. thinkdan's Avatar
    Same here. A few Skydrive albums show no cover picture. Annoying.
    06-20-2013 09:21 AM
  17. anon(4757114)'s Avatar
    Same problem here, never really noticed until this thread.
    06-20-2013 09:24 AM
  18. uopjo6's Avatar
    Can't believe this issue hasn't been addressed by MS for 8 months since launch. 8 months and no stupid thumbnail fix. Really?
    I haven't even begun with the Other Storage issue that has been ignored as well.
    06-28-2013 11:20 AM
  19. Colin920's Avatar
    I can't believe the problem still haven't got a fix after GDR2 Amber, I assume Microsoft developers don't really use WP8??? How can they not notice the problem and adjust it after 9 months. This is so embarrassing.
    08-22-2013 03:41 PM
  20. angusdegraosta's Avatar
    Happy December 2013... no fix!
    E Lizzle likes this.
    12-16-2013 03:04 PM
  21. sonus's Avatar
    You NEED to go to the skydrive website using Internet Explorer. Log in, and then right click the album folders that are missing in the photo hub. Select the option that reads something along the lines of, "This is a photo album."

    Restart your phone and then launch the photo hub. It should update.
    12-16-2013 04:45 PM
  22. E Lizzle's Avatar
    You NEED to go to the skydrive website using Internet Explorer. Log in, and then right click the album folders that are missing in the photo hub. Select the option that reads something along the lines of, "This is a photo album."

    Restart your phone and then launch the photo hub. It should update.
    They're already all set that way. It's not that the albums are missing, it's that the album cover is a blank black square. Just for some albums, randomly changing over the months. It's annoying because the total OS only has about a half dozen features, and to leave "photo album covers randomly broken" for a year is lame.

    -E
    neo158 likes this.
    12-17-2013 09:51 AM
  23. neo158's Avatar
    They're already all set that way. It's not that the albums are missing, it's that the album cover is a blank black square. Just for some albums, randomly changing over the months. It's annoying because the total OS only has about a half dozen features, and to leave "photo album covers randomly broken" for a year is lame.

    -E
    This is exactly it, it's the cover picture for the album that's missing.
    12-17-2013 10:05 AM
  24. EasilyTheBest's Avatar
    Its nearly 2014 and this problem is still not fixed on my phone Grrrr.
    Hello Microsoft, anyone listening...
    12-31-2013 09:07 AM
  25. jamie johnston's Avatar
    Has there been a fix for this yet?
    04-13-2014 11:31 AM

Similar Threads

  1. Is it possible to hide the skydrive albums in the pictures hub?
    By littlesteelo16 in forum Windows Phone 7
    Replies: 18
    Last Post: 03-06-2014, 07:27 PM
  2. Albums not appearing in photos hub
    By laska in forum Windows Phone 7
    Replies: 3
    Last Post: 10-06-2012, 05:51 PM
  3. Custom skydrive folders in pictures hub
    By mkr10001 in forum Windows Phone 7
    Replies: 1
    Last Post: 04-21-2012, 05:32 PM
  4. Facebook tagged photos in Pictures Hub outdated?
    By phazer89 in forum Windows Phone 7
    Replies: 2
    Last Post: 04-05-2012, 10:57 PM
  5. photo disappear in people hub after updated to Mango
    By rhkrqyr in forum Samsung Focus
    Replies: 5
    Last Post: 11-06-2011, 01:11 PM
LINK TO POST COPIED TO CLIPBOARD