1. mrjamesmoore's Avatar
    When I plugin my Lumia 920 to a Win8 64bit PC I get an error 'USB device not recognised'. I've tried the following but with no luck:
    - Changed the USB cable
    - Tried a different USB port including one on the back
    - Used a different PC (Win8 32bit)
    - Restarted the phone whilst connected
    - Checked for Updates with the phone connected (both on phone and PC)
    - Removed the 'Upperfilters' registry entry
    - Installed the Windows Phone 8 app (both desktop and metro)
    - Installed the Nokia PC Suite

    The phone doesn't even appear in Device Manager so there's no drivers for me to remove and/or update. Anyone got an idea of what could be wrong?

    Thanks,

    James
    04-01-2013 05:19 PM
  2. ttsoldier's Avatar
    You can also try using a Win 7 PC.

    I would assume you're using the original cable that came with the phone?

    Do you have any problems charging the phone?

    You could try a factory restore on the phone.
    04-01-2013 06:01 PM
  3. mrjamesmoore's Avatar
    Thanks for your suggestions.

    Yes the phone seems to charge OK and yes it's the cable that came with the phone. I've also tried two other cables. I've already tried a factory restore (left that off my list).

    I just tried on a Win7 PC (32-bit) and same thing there :( Given it doesn't work on 3 PCs to me it sounds like an issue with the phone?

    James
    04-01-2013 06:24 PM
  4. JammyGitz's Avatar
    open up a cmp prompt and type SET DEVMGR_SHOW_NONPRESENT_DEVICES=1then
    devmgmt.msc

    then click View and Show hidden devices. This will show every device ever connected to your computer in the past. Uninstall all the old ones because one of them is probably causing a compatibility issue. Anything you don't recognise, just delete (apart from obvious system stuff like the CPU / monitor / USB host controllers etc).
    04-02-2013 09:01 AM
  5. mrjamesmoore's Avatar
    That didn't work either Jammy but thanks for reply! I also tried connecting it to a Mac and still no joy.

    James
    04-02-2013 05:31 PM
  6. Ericonda1203's Avatar
    Hold down the volume down button and the power button for ten seconds and see if it resets. Worked for me.
    05-16-2013 01:03 PM
  7. Daniel Lucena1's Avatar
    Hold down the volume down button and the power button for ten seconds and see if it resets. Worked for me.
    Thank you.. this work for me on my lumia 720!!!
    07-13-2013 10:05 AM

Similar Threads

  1. Nokia Lumia 920 - Nokia Music not working
    By zfarooq in forum Nokia Lumia 920
    Replies: 5
    Last Post: 09-11-2013, 03:14 PM
  2. Replies: 33
    Last Post: 02-10-2013, 01:49 AM
  3. Again, Lumia 920 USB mass storage mode? (not using MTP)
    By maxplanet in forum Nokia Lumia 920
    Replies: 1
    Last Post: 01-16-2013, 09:36 AM
  4. Lumia 920 USB &mp3 as ringtones
    By tlegend2012 in forum Windows Phone 8
    Replies: 0
    Last Post: 11-07-2012, 09:42 PM
  5. "USB Device Not Recognized"
    By tripower in forum Windows Phone 7
    Replies: 2
    Last Post: 12-09-2010, 10:51 PM
LINK TO POST COPIED TO CLIPBOARD