1. razor1973's Avatar
    I have apps like Weather Flow and Amazing Weather HD configured to work in the background on my AT&T Lumia 920, but they never do. They never update my live tile until I open them again. I've tried blocking them and then allowing them again, uninstalling and then reinstalling them, ... Nothing works. Is this a common problem and is there a solution for it?
    04-06-2013 12:48 PM
  2. rockstarzzz's Avatar
    I have apps like Weather Flow and Amazing Weather HD configured to work in the background on my AT&T Lumia 920, but they never do. They never update my live tile until I open them again. I've tried blocking them and then allowing them again, uninstalling and then reinstalling them, ... Nothing works. Is this a common problem and is there a solution for it?
    They update regularly every 30 minutes for me. Not a problem, so don't think there is a solution. Perhaps reboot? It could be a terrible data connection.
    04-06-2013 12:49 PM
  3. th0mas96's Avatar
    reboot. And you can't have too many there, I once had 10 and none of them would update. Currently I have 6 an everything works lie it should :)
    04-06-2013 12:54 PM
  4. razor1973's Avatar
    No, no, I'm very disciplined and always block rogue apps that think they should be running in the background. I never have more than 5. See attached. This has been happening for months, so I've obviously rebooted many times. No luck.
    Attached Thumbnails wp_ss_20130406_0001.jpg  
    04-06-2013 01:03 PM
  5. ChMar's Avatar
    I have apps like Weather Flow and Amazing Weather HD configured to work in the background on my AT&T Lumia 920, but they never do. They never update my live tile until I open them again. I've tried blocking them and then allowing them again, uninstalling and then reinstalling them, ... Nothing works. Is this a common problem and is there a solution for it?
    Apps in the background need arming first. So after install you need to launch them from start screen.
    Now any working background agent can crash(due to various reasons). If crash occurs then it will get marked as bugged. Happens again and then it will not run in background until you rearm it.

    I don't know but maybe due to some connection issues those apps crashed in the background for you and were banned from rearming every 30 mins. If that is the case just realunch them from start and they will be rearmed in 30 mins.
    04-06-2013 01:03 PM
  6. razor1973's Avatar
    Apps in the background need arming first. So after install you need to launch them from start screen.
    Now any working background agent can crash(due to various reasons). If crash occurs then it will get marked as bugged. Happens again and then it will not run in background until you rearm it.

    I don't know but maybe due to some connection issues those apps crashed in the background for you and were banned from rearming every 30 mins. If that is the case just realunch them from start and they will be rearmed in 30 mins.
    Done that many times too. I've actually blocked them, then allowed them to run in background next time they run and run them again. I've even rebooted at this point and nothing, days later, weeks later.
    04-06-2013 01:05 PM
  7. Xpider_MX's Avatar
    uninstalling and reinstalling? and check the battery saver option, if it is on, the background apps will not work.
    04-06-2013 03:26 PM
  8. Shoulders's Avatar
    I have the same problem L920 on Orange(EE) in the UK.

    Got my phone when it launched in November and live tiles were working fine up until a month or so ago. Only have 4 background tasks (AppointTile, Fuse, WPcentral, Amazing Weather), and Facebook, which you can't block.

    After the 1308 update a week or so ago, They started working again for a few days and now have stopped again.

    I've done all the suggestions, and I turn my phone off at night so it gets at least a daily reboot.

    I had this with WP7 on occasion and hopped they'd sorted it in WP8, but they seemed to have re-introduced it again, after 4 months of it working fine.
    04-07-2013 02:26 PM
  9. razor1973's Avatar
    uninstalling and reinstalling? and check the battery saver option, if it is on, the background apps will not work.
    Uninstalled and reinstalled several times. Battery saver is off.
    04-07-2013 04:05 PM
  10. razor1973's Avatar
    No cigar, it seems. No background apps for me. =\
    04-09-2013 08:31 PM

Similar Threads

  1. Bank of America app not working?
    By btbam91 in forum Applications
    Replies: 22
    Last Post: 11-23-2014, 08:50 PM
  2. Replies: 7
    Last Post: 04-13-2013, 02:26 PM
  3. zune marketplace not working in canada
    By y2kunals in forum Applications
    Replies: 15
    Last Post: 10-04-2011, 01:57 PM
  4. HTC Connected Media App not working
    By JenkTJ27 in forum HTC Trophy
    Replies: 4
    Last Post: 09-30-2011, 01:08 PM
  5. USA Today app not working...
    By wolf1891 in forum Windows Phone 7
    Replies: 7
    Last Post: 08-05-2011, 04:06 AM
LINK TO POST COPIED TO CLIPBOARD