The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
  1. chucky's Avatar
    I have a Nokia Lumia 920 and most of the time there's a lag when I try to send a text message, the lag is about 10 - 15 seconds. Its really annoying, anyone has a solution for this problem or ever encounter this issue?? Thanks.
    05-21-2013 10:09 AM
  2. jfa1's Avatar
    I haven't noticed it but its possible I generally push send and then hit the windows button to open another window and continue with what I'm doing
    05-21-2013 10:58 AM
  3. eric12341's Avatar
    Haven't noticed this on my 8X
    05-21-2013 03:17 PM
  4. chezm's Avatar
    No lag on my 920 with SMS/MMS
    05-21-2013 03:41 PM
  5. chucky's Avatar
    Thats weird, I have bad luck or some **** I guess.. Or I might have to reset it.
    05-21-2013 07:41 PM
  6. rylapid's Avatar
    I have started experiencing this messaging lag, too, in recent months. When I try to send a message, the send icon will be grayed out, but the message will take about ten seconds to send. Also, I've experienced when I try to open up the messaging hub no threads will show, or when I click on a thread, I'll see the loading dots for about fifteen seconds.

    Has anyone else experienced these things and/or found a solution?
    12-30-2013 03:28 PM
  7. Teeksters's Avatar
    I've experience the same issue with the lagging. When I try to open a thread I will see dots loading for about 10-15 seconds and then after I click send it will take 10-15 seconds for it to move out of the compose area. It's really getting on my nerves and I am starting to consider getting another phone.
    01-10-2014 07:00 PM
  8. Dave Gilbert1's Avatar
    I have started experiencing this messaging lag, too, in recent months. When I try to send a message, the send icon will be grayed out, but the message will take about ten seconds to send. Also, I've experienced when I try to open up the messaging hub no threads will show, or when I click on a thread, I'll see the loading dots for about fifteen seconds.

    Has anyone else experienced these things and/or found a solution?
    Yes. All the time. Its so annoying. Factory reset will solve it temporarily. Im not resetting my phone though. Me and my friend experience this issue. Im using a ATT nokia lumia 920 and he is using a Lumia 810 from tmobile. Both get extremely frustrated with this issue. Sometime ill type up a message, then back out to home before it "sends" and then go back to see its not even there. If it was instant like it should be and was when I purchased the phone, that wouldn't be a problem. Sometimes it takes upwards to more than a minute to send and/or open a conversation with someone. If im busy this is not acceptable.
    03-07-2014 01:06 PM
  9. Dave Gilbert1's Avatar
    I wish there was more help on this issue. It seems to be fairly common. Sometimes its not a big deal but most of the time its really frustrating.
    03-07-2014 01:09 PM
  10. Saksham Sharma's Avatar
    No problem in my 520, been using it for 6 months. Never experienced any such thing.
    03-07-2014 01:25 PM
  11. rubenwidjaja's Avatar
    maybe your text already too much
    just clean and delete it
    03-07-2014 01:38 PM
  12. William Clemens's Avatar
    Same problem, but now I have started getting a lag in other areas as well like the storage app, various email apps. I'm not gonna factory reset my phone for the 5th time!
    03-14-2014 07:27 PM
  13. William Clemens's Avatar
    Okay, while looking into some other bugs on my phone, it was suggested to turn text messaging backup off. Doing that seems to have solved this problem as well! Messaging>settings> toggle text backup to off. Hopefully the problem doesn't return.
    haberll likes this.
    03-20-2014 04:11 PM
  14. haberll's Avatar
    Yes, I'm having the same issue with the message send lagging. Do not know of a solution. I have had nothing but problems with my 920. Seriously considering going with Android S5.
    Last edited by haberll; 05-13-2014 at 10:00 AM. Reason: added wording
    05-13-2014 09:56 AM
  15. kuzco18284's Avatar
    i had that same issue, so what i did was go on setting, then mobile+sim and changed the wifi connectivity to "dont use mobile data" and it works fine now ! hope it works for you guys
    05-22-2016 05:53 AM
  16. Don N1's Avatar
    Same problem, windows insider I think was a mistake, dangit, now I am probably going to lose a bunch of stuff trying to undo the 10.
    06-13-2016 09:29 PM

Similar Threads

  1. Replies: 5
    Last Post: 05-21-2016, 09:26 AM
  2. can't send text messages with photos
    By mjmartin01 in forum Nokia Lumia 822
    Replies: 3
    Last Post: 02-25-2013, 10:57 AM
  3. Problems sending text messages
    By Hupsakee in forum Nokia Lumia 822
    Replies: 9
    Last Post: 01-01-2013, 09:51 PM
  4. Sync errors with email and can't send text messages.
    By AshDOG in forum Nokia Lumia 920
    Replies: 1
    Last Post: 11-28-2012, 12:10 PM
  5. Replies: 3
    Last Post: 11-28-2012, 07:56 AM
LINK TO POST COPIED TO CLIPBOARD