1. billva's Avatar
    Hello,

    I just switched from Sprint to T-Mobile to get the 925 and I'm trying to figure how fix the incoming calls display. For all incoming calls, the number appears with the "1" in front, e.g., "1 202 555-1212". While this is only a minor annoyance when looking at the phone display, the real problem is when the 925 is connected to my car's Bluetooth/Nav system - the "1" is causing the number not to match the downloaded contacts - appearing on the display screen as "1-202-555-1212" instead of "Joe Blow - Mobile".

    Is there anyway I can fix the incoming call display on the phone or is there anything T-Mobile can do?

    Thanks
    09-12-2013 12:56 AM
  2. montsa007's Avatar
    Have you checked your contacts if that 1 prefix is present?
    09-12-2013 01:12 AM
  3. AR2186's Avatar
    Is your International Assist on in Phone settings?
    09-12-2013 08:02 AM
  4. billva's Avatar
    @montsa007 - No, none of my contacts have the 1 present

    @ar2186 - Yes, International Assist was on, but I turned it off an called myself and the "1" still shows.

    Can anyone who is on T-Mobile confirm the "1" does/doesn't display - at least that way I can narrow down whether this is a network issue or something with my phone.

    Thanks
    09-12-2013 12:37 PM
  5. montsa007's Avatar
    Try calling T mobile helpline rather than waiting for someone with Tmobile to respond?
    I have a 720 and never faced this problem
    09-12-2013 12:50 PM
  6. AR2186's Avatar
    On my T-Mobile Q10 it seem to come through with a 1

    Edit: I put the T Mobile SIM into my 928 and have the same issue, comes up as a 1. When I call from the same number on Verizon it drops the 1
    09-12-2013 01:35 PM
  7. montsa007's Avatar
    Should be with the T network.
    09-12-2013 02:14 PM
  8. billva's Avatar
    I didn't call TMobile first because I figured their tech support folks wouldn't have a clue so I just called them and after 10 minutes of hold they stated the setting couldn't be changed. That said, it looks like I'm getting conflicting info in this thread - montsa007 is saying this doesn't happen on his TMobile 720 - but ar2186's test seems to confirm it's a SIM/network issue.

    Could it be differences in the SIM cards, maybe the unlock status or something else?
    09-12-2013 02:54 PM
  9. gwinegarden's Avatar
    I've always been told that all contacts should have the 1 in front as it allows you to call the number, when you are out of town, without having to fiddle with it. If you are local, the network, simply, strips it off.
    09-12-2013 06:41 PM
  10. montsa007's Avatar
    I didn't call TMobile first because I figured their tech support folks wouldn't have a clue so I just called them and after 10 minutes of hold they stated the setting couldn't be changed. That said, it looks like I'm getting conflicting info in this thread - montsa007 is saying this doesn't happen on his TMobile 720 - but ar2186's test seems to confirm it's a SIM/network issue.

    Could it be differences in the SIM cards, maybe the unlock status or something else?
    Whoa, am in India and use Voda network on L720, I never said I use a Tmobile :/
    Our country code is +91, I do get calls from people in my contact which don't have a +91 prefix but never have a number shown on the screen, its always the contact name.
    09-13-2013 06:09 AM

Similar Threads

  1. Replies: 5
    Last Post: 04-03-2014, 03:40 PM
  2. 925 in-store purchase...
    By lewiedude in forum Nokia Lumia 925
    Replies: 4
    Last Post: 09-14-2013, 10:42 AM
  3. Age of Sorcery MMO Game
    By Lumia720Jomz in forum Nokia Lumia 720
    Replies: 1
    Last Post: 09-12-2013, 12:30 PM
  4. How to make an app that pulls in information from websites
    By Jas00555 in forum Developers Corner
    Replies: 2
    Last Post: 09-12-2013, 11:46 AM
  5. Replies: 1
    Last Post: 09-11-2013, 06:44 PM
LINK TO POST COPIED TO CLIPBOARD