1. Pedro Cavaleiro's Avatar
    I've tryed everything
    Removed facebook account removed Microsoft app from facebook and facebook link from Outlook.com and Windows Phone 8
    Uninstalled Facebook and Skype
    Rebooted the phone a lot switched from WiFi to 3G/4G
    Disabled Battery Saving.
    Nothing worked
    Even with facebook disconnected I got the error
    "Can't connect to chat" any ideas?
    10-03-2013 11:29 AM
  2. montsa007's Avatar
    Which Phone?
    Are you on GDR 2?
    10-03-2013 11:36 AM
  3. Pedro Cavaleiro's Avatar
    Yes I have GDR2
    10-03-2013 01:15 PM
  4. montsa007's Avatar
    A major area of concern, GDR 2 has that bug.
    10-03-2013 01:19 PM
  5. rockstarzzz's Avatar
    No it doesn't! I am on GDR2 and my chat has improve a lot! Am actually getting all my messages instantly!
    10-03-2013 01:24 PM
  6. montsa007's Avatar
    http://forums.windowscentral.com/win...dr2-fixes.html
    (Post #24)
    -----
    http://forums.windowscentral.com/win...ected-bug.html
    -----
    http://forums.windowscentral.com/win...-chat-bug.html
    -----

    These may not be 100% accurate but I've seen people complaining about it (Specially those who just migrated to GDR 2 update).
    10-03-2013 01:31 PM
  7. Pedro Cavaleiro's Avatar
    It's not only Facebook. When I've unlinked facebook I got the same error even after phone reboot
    "Can't connect to chat"
    And right now when I disable facebook chat it still gives me the error "Can't connect to chat"
    This is a very annoying bug
    Hope this get's fixed in GDR3
    Ebin Manuel likes this.
    10-03-2013 02:09 PM
  8. Ebin Manuel's Avatar
    same problem here, after amber update cant get connected to chat. I've tried everything from restarting to creating account again and again. Still no use !!!!!!!! I contacted Microsoft live chat regarding the issue and they replied that they are working on this issue. Even they cant find a solution, too bad!!
    10-11-2013 12:14 AM
  9. Wurstsalat's Avatar
    So far all posted solution doesnt work for me...but now i was able to fix it on this way:
    - go to https://account.live.com and login
    - select "add or change alias"
    - if you have no alias, create one...don`t use an @live.com address!
    - make one of your aliases which is not @live.com to the primary one
    - try to connect to Chat
    - it should work

    Hope this will help someone else...i think the main problem ist @live.com addresses, do not ask me why. If i revert to @live.com address, it breaks the IM.

    confirmed working
    @Outlook.de

    Maybe it depends on your account location settings and your top Level Domain of your account... (for example, i am from Germany, *.com doesnt work, *.de works...but cant test all because i cant change primary alias this often )
    12-18-2013 04:39 PM
  10. Alex Griciuc's Avatar
    Finally worked for me.
    After trying the battery saver settings and other solutions .. nothing worked.

    At leas for me, the problem was that my primary alias set up at https://account.live.com/ wasn't the same as the Microsoft account I had set up on my WP device.
    from accounts.live.com I've made my primary alias the same as the one I had set up on my WP phone. When I went back to Messaging everything was working fine.
    I think there is a problem between the way the microsoft api authenticates with the fb one. Microsoft must be sending the credentials of the MS account set up on the wp8 phone .. but the two apis are linked using the primary alias set up on accounts.live.com.
    Rohadani likes this.
    01-09-2014 04:51 AM
  11. drgeri's Avatar
    I have a Nokia Lumia 720,Amber update and never had any problems...last couple of days yes,my alias is the same as my Microsoft account on the phone,so I can't change that...with battery saver trick is fixes for a while,but after it can't connect again...what to do??

    Sent from my Nokia Lumia 720 using Tapatalk
    01-10-2014 06:58 AM
  12. Levi Normandeau's Avatar
    The German is right!

    I switched my alias to one ending in .ca (I live in Canada) and set up that alias on facebook as my primary and I didn't even have to restart my phone.
    02-16-2014 07:02 PM
  13. Rohadani's Avatar
    Same problem here, but this solved the issue. I've changed the main alias, suddenly the FB chat stopped working. After reading this thread, I switched back to the first alias, and Bing! FB chat works again!
    Thank you for the pertinent solution!
    06-30-2014 07:37 AM

Similar Threads

  1. Volume doesn't work while listening to Music
    By JoAndRoPo in forum Nokia Lumia 520
    Replies: 4
    Last Post: 10-20-2013, 01:38 AM
  2. Replies: 6
    Last Post: 10-06-2013, 11:34 PM
  3. Replies: 3
    Last Post: 10-04-2013, 10:05 AM
  4. Switching from 2 year contract individual plan to Family plan
    By yungcaspa in forum Nokia Lumia 1020
    Replies: 1
    Last Post: 10-03-2013, 09:09 AM
  5. How to use emulators
    By pedronev925 in forum Applications
    Replies: 1
    Last Post: 10-03-2013, 02:44 AM
LINK TO POST COPIED TO CLIPBOARD