1. Edward Austin's Avatar
    I apparently have an unlocked Lumia 620 (Carrier: CV GB).

    It works fine with an Orange (EE network) SIM - initially it shows a signal strength with a stop sign over it, but the stop sign disappears within 30 seconds and the phone works OK with GPRS, EDGE and 3G.

    I put in my O2 SIM and it boots up fine and even asks me to select Carrier for Data (O2 Prepay GPRS/EDGE/3G) which I do.

    Then I get the Signal indicator with a stop sign over it again (circular sign with a diagonal line through it) but it never goes. The stop sign stays!

    Sometimes it will show network as O2 UK, sometimes as NO SIM (or not registered or something like that...)

    Have tried to manually select network but the same happens, the network shows, I select, and then signal with stop sign through it!

    Is my phone really unlocked?

    The O2 SIM worked OK in my old Nokia 610.
    10-30-2013 03:15 PM
  2. stalemate1's Avatar
    I apparently have an unlocked Lumia 620 (Carrier: CV GB).

    It works fine with an Orange (EE network) SIM - initially it shows a signal strength with a stop sign over it, but the stop sign disappears within 30 seconds and the phone works OK with GPRS, EDGE and 3G.

    I put in my O2 SIM and it boots up fine and even asks me to select Carrier for Data (O2 Prepay GPRS/EDGE/3G) which I do.

    Then I get the Signal indicator with a stop sign over it again (circular sign with a diagonal line through it) but it never goes. The stop sign stays!

    Sometimes it will show network as O2 UK, sometimes as NO SIM (or not registered or something like that...)

    Have tried to manually select network but the same happens, the network shows, I select, and then signal with stop sign through it!

    Is my phone really unlocked?

    The O2 SIM worked OK in my old Nokia 610.
    Sounds to me like the sim card is not registered, take the sim card to the carrier/service provider and ask them about it...I bet its not registered, in south Africa all our sim cards have to be registered with RICA or it just says unregistered sim card and you cant use it.
    10-30-2013 03:35 PM
  3. eroselim's Avatar
    The problem may be in your Sim.
    11-03-2013 10:35 PM
  4. stalemate1's Avatar
    Yes, try the sim card in another device and see if it works.
    11-04-2013 12:51 AM

Similar Threads

  1. Surface 2 with cover turns on and drains battery in my bag
    By g808 in forum Microsoft Surface 2
    Replies: 13
    Last Post: 10-10-2014, 08:13 AM
  2. HDfury 2 (So you can use a Xbox one or PS4 on a NON-HDMI tv)
    By DavidinCT in forum Marketplace Archive
    Replies: 2
    Last Post: 11-03-2013, 01:48 AM
  3. A great article on OneNote
    By HeyCori in forum Microsoft Office
    Replies: 2
    Last Post: 10-31-2013, 10:31 AM
  4. Lumia 625 Coloured Cover
    By anon(7882979) in forum Nokia Lumia 625
    Replies: 1
    Last Post: 10-30-2013, 11:45 PM
  5. My Lumia 920 does not show notifications
    By williog in forum Nokia Lumia 920
    Replies: 3
    Last Post: 10-30-2013, 04:18 PM
LINK TO POST COPIED TO CLIPBOARD