1. Golou's Avatar
    I just went to the Nokia 1520 and dropped my iPhone 5. This is a work phone and I thought I would be different by getting a Windows phone. My problem is that when I am sent a text from people with iPhones I do not get the texts. I know this has to do something with the imessage, I have turned off imessage on my old iPhone, my iPad and iPad mini. I still do not get text messages. Can someone please help me to where I can get text messages again with from iPhone users. I don't want to go back to the iPhone. I love my big oversize banana. :)
    12-04-2013 09:51 AM
  2. N_LaRUE's Avatar
    Has anyone sent you a text message not using imessage? imessage is like Whatsapp but specific to iPhones. Do your friends use Whatsapp?

    There's no reason why you shouldn't get text messages that I can think of. Unless it wasn't setup correctly by your provider. Phone type doesn't matter as long as it's an actual text message and not a message app message.
    12-04-2013 09:56 AM
  3. blue1k's Avatar
    Has anyone sent you a text message not using imessage? imessage is like Whatsapp but specific to iPhones. Do your friends use Whatsapp?

    There's no reason why you shouldn't get text messages that I can think of. Unless it wasn't setup correctly by your provider. Phone type doesn't matter as long as it's an actual text message and not a message app message.
    Actually that's incorrect. Apple servers keep the number on file unless you disabled imessage before removing the SIM. That means texts won't arrive. Stupid yes.

    A solution is to go here and remove your phone number/apple id and disable imessage.

    https://idmsa.apple.com/IDMSWebAuth/...e.com/homePage
    LordGreylock likes this.
    12-04-2013 10:17 AM
  4. N_LaRUE's Avatar
    That is stupid but I'm not surprised.
    12-04-2013 11:01 AM
  5. LordGreylock's Avatar
    iMessage is a huge pain when you switch from an iOS device. What I've found works best to disable iMessage completely is change your iCloud (iTunes Account) password. This disabled iMessage on all my iOS devices. Just doing this alone should work fine. Also, I have noticed that a lot of my friends with iPhones didn't have the option enabled to "Send as SMS if iMessage is unavailable" (see screenshot below) so I had to tell them to turn that on otherwise I wouldn't get their messages even though iMessage was completely disabled on my end. I hope this helps, and enjoy your 1520, it's a beast!

    send-sms.jpg
    12-04-2013 11:34 AM
  6. LordGreylock's Avatar
    Actually that's incorrect. Apple servers keep the number on file unless you disabled imessage before removing the SIM. That means texts won't arrive. Stupid yes.

    A solution is to go here and remove your phone number/apple id and disable imessage.

    https://idmsa.apple.com/IDMSWebAuth/...e.com/homePage

    Just a quick note on this, it has worked in the past for me however more recently doing just that for some reason didn't work. That's why I ended up changing my Apple ID (iCloud) password, then iMessage was completely disabled.
    12-04-2013 11:38 AM

Similar Threads

  1. My 1520 is poppin'
    By JamesDax in forum Nokia Lumia 1520
    Replies: 27
    Last Post: 12-08-2013, 06:17 PM
  2. Nokia headphones
    By Andrew Brehm in forum Nokia Lumia 520
    Replies: 2
    Last Post: 12-06-2013, 05:42 AM
  3. Shortcuts4All updated to v3 and FREE for limited time
    By PablosOne in forum App Spotlight
    Replies: 3
    Last Post: 12-04-2013, 08:48 PM
  4. WP to-do in calendar on Win 8.1 desktop and Surface RT
    By Type14 in forum Windows Phone 8
    Replies: 4
    Last Post: 12-04-2013, 12:18 PM
  5. Swithchin from iphone4 to lumia 920
    By FredV78 in forum Nokia Lumia 920
    Replies: 1
    Last Post: 12-04-2013, 06:01 AM
LINK TO POST COPIED TO CLIPBOARD