1. someonecalledsukhjit's Avatar
    I have a 520 and suffer from frequent lags and crashes of apps. To my knowledge thats because of microsoft has restricted the RAM usage for apps. An app can mearly use 30 MB (as I found on forums). Other phones like 720 suffer from same problem. I really don't know if this is the case with 1 GB Ram phones or not.

    Using UC browser or game or even browsing sometimes is a really frustrating process coz of crashes. It also destroys my view of WP as a lagfree os. It is not. It has a serious flaw. I think MS needs to give devs a little more room for experimentation. I expect that to be solved in WP Blue. Action center was a must and they heard but this is as important as that.

    What do you guys think?
    02-11-2014 05:37 AM
  2. pmhgeneral's Avatar
    How's is your WiFi connection, I had a same problem and added a wireless network extender and had no other problems. Just a thought.
    02-11-2014 05:44 AM
  3. stamatis1's Avatar
    First of...for gods sake i own a lumia 520 too and have never experienced a single " lag " its dual core processor is more than enough for daily taks and also provides smooth gaming so please....it aint a hardwre issue nor its going to be fixed in wp blue
    yes our ram is reserved its 50 % for OS and 50 % for gaming / other tasks / apps but yet again it doesnt cause any problems regarding our phone's performance
    02-11-2014 06:16 AM
  4. ashu11sharma's Avatar
    Hi, I also have the same issue. This issue is more frequent while browsing on IE or If you are browsing using UC Browser in normal mode (i.e. speed mode, reader etc switched off). This problem has ruined my browsing experience as now I use only UC Browser and that too in speed mode.
    But neverthless, phone is responsive. (BTW i own Lumia 720)
    02-11-2014 06:54 AM
  5. someonecalledsukhjit's Avatar
    How's is your WiFi connection, I had a same problem and added a wireless network extender and had no other problems. Just a thought.
    Wifi reception is poor at times. Other than that no problem with wifi. I think there was something wrong with router only.
    02-11-2014 07:54 AM
  6. someonecalledsukhjit's Avatar
    First of...for gods sake i own a lumia 520 too and have never experienced a single " lag " its dual core processor is more than enough for daily taks and also provides smooth gaming so please....it aint a hardwre issue nor its going to be fixed in wp blue
    yes our ram is reserved its 50 % for OS and 50 % for gaming / other tasks / apps but yet again it doesnt cause any problems regarding our phone's performance
    Don't go all chuck norris. I am not saying its a bad phone. I am a WP fan and supporter. I am just saying. I faced some issues and others as well. Thats why I asked!
    02-11-2014 07:55 AM
  7. hs k's Avatar
    Don't go all chuck norris. I am not saying its a bad phone. I am a WP fan and supporter. I am just saying. I faced some issues and others as well. Thats why I asked!
    Lol, if he had gone all Chuck Norris you would have your face on the keyboard for blasphemy. like this: Thats why I fvbihybvwuigfbmwbvj waoerjd ghebing.
    02-12-2014 12:29 PM

Similar Threads

  1. Maps in South Korea and Japan?
    By KPF in forum Applications
    Replies: 1
    Last Post: 05-31-2014, 03:13 AM
  2. Power off when plugged in?
    By oditius in forum Nokia Lumia 1520
    Replies: 4
    Last Post: 02-11-2014, 07:57 AM
  3. Did anyone tried this battery? 2500mAh inside
    By Elia Levorato in forum Nokia Lumia 620
    Replies: 1
    Last Post: 02-11-2014, 04:18 AM
  4. Replies: 2
    Last Post: 02-11-2014, 02:34 AM
LINK TO POST COPIED TO CLIPBOARD