The Windows 10 April 2018 update has arrived! Get the new Dell XPS 15, starting at $999.99
03-11-2017 11:08 PM
38 12
tools
  1. Terry Carter's Avatar
    If you use NET10 with your windows phone (or a Samsung S4) here are the NEW APN settings. Net 10 has changed them in the last few weeks. They changed mine today. It took me over 4 hours to figure this out. DO NOT CALL Net 10 customer support they are too stupid to help anyone. If their prices was not 1/2 the price of At&t i would not use them. Well here is the APN settings that will make your internet & your MMS settings work:
    Lets start with the internet first:
    (name) (must be LARGE letters) NET10
    APN = tfdata (must be small letters)
    that is it, do not add or post anything else in your internet APN settings!

    Now lets do the MMS settings:
    name (must be all Large letters) NET10
    category= MMS
    MMSC= http://mms-tf.net
    APN= tfdata
    Proxy address = (must be in small letters) mms3.tracfone.com
    Proxy domain = mms-tf.net
    Proxy Port = 80

    Ok like i said i spent over 4 hours trying to figure out these "New" Apn settings for Net10. I hope this will save you some time! Like i said Please do not waste your time calling NET10 they are complete idiots when it comes to this!! Have a great day!!!
    Laura Knotek and smithcyn13 like this.
    02-22-2014 11:09 PM
  2. Laura Knotek's Avatar
    This should be helpful to a lot people. Thanks for sharing.
    02-22-2014 11:17 PM
  3. Amy_0074's Avatar
    What Windows phone are you using? I have a Nokia Lumia 920.
    03-10-2014 09:04 PM
  4. Erick Rojas1's Avatar
    thank you so much for you help internet is working now on my Nokia lumia 520 with the APN settings that you post
    the only problem I have is receiving pictures messages can some one help me please
    03-14-2014 11:25 PM
  5. tgp's Avatar
    thank you so much for you help internet is working now on my Nokia lumia 520 with the APN settings that you post
    the only problem I have is receiving pictures messages can some one help me please
    I have an Android, but my settings are slightly different than the OP's. My MMS works fine. Under MMSC= http://mms-tf.net I have MMS proxy= 66.209.11.33 . I'm not sure whether it would replace Proxy address = (must be in small letters) mms3.tracfone.com or Proxy domain = mms-tf.net (probably Proxy address). Try it in one, and if it doesn't work try the other. Try leaving the other as it's given here or leaving the other blank. Try every possible combination until it works!
    03-14-2014 11:31 PM
  6. Erick Rojas1's Avatar
    Fanally I got my phone working and I want to help some one who have the same issue like me here is what I got on my phone
    AT&T Nokia Lumia 520 with NET10 Sim card.

    internet apn

    APN: tfdata
    User name : NET10

    That's all don't put anything else.

    mms apn

    APN : tfdata
    User name : NET10
    password : blank don't put nothing
    WAP gateway (URL) : mms3.tracfone.com
    WAP gateway port : 80
    MMSC (URL) : http://mms-tf.net/
    MMSC port : 80

    I hope this will make some one happy have a nice day : )
    kmok and SusieCQ like this.
    03-14-2014 11:36 PM
  7. syncmaster22's Avatar
    I know this is a little off topic but I cant seem to get a straight answer while looking this up on the net. For the nokia 520 and net10. I was going to buy the 520 prepaid from at&t and a net10 att sim card. Is there anything special I have to do to activate it? Does the phone have to be unlocked or used on att for 6 months first, or can I just take the new phone, pop in the net10 att sim and go from there setting it up. I am not sure how this works. Thanks in advance.
    03-18-2014 06:41 PM
  8. tgp's Avatar
    I know this is a little off topic but I cant seem to get a straight answer while looking this up on the net. For the nokia 520 and net10. I was going to buy the 520 prepaid from at&t and a net10 att sim card. Is there anything special I have to do to activate it? Does the phone have to be unlocked or used on att for 6 months first, or can I just take the new phone, pop in the net10 att sim and go from there setting it up. I am not sure how this works. Thanks in advance.
    This is the answer: pop in the net10 att sim and go from there setting it up. You'll probably have to manually add or edit the APN settings, but unlocking or using on AT&T for 6 months is not necessary.
    syncmaster22 likes this.
    03-18-2014 07:22 PM
  9. jimmydewrag1's Avatar
    Worked great,thanx.peace
    05-26-2014 12:33 AM
  10. Jeremiah Grider's Avatar
    Fanally I got my phone working and I want to help some one who have the same issue like me here is what I got on my phone
    AT&T Nokia Lumia 520 with NET10 Sim card.

    internet apn

    APN: tfdata
    User name : NET10

    That's all don't put anything else.

    mms apn

    APN : tfdata
    User name : NET10
    password : blank don't put nothing
    WAP gateway (URL) : mms3.tracfone.com
    WAP gateway port : 80
    MMSC (URL) : http://mms-tf.net/
    MMSC port : 80

    I hope this will make some one happy have a nice day : )
    06-01-2014 11:08 PM
  11. SusieCQ's Avatar
    Wow! You are a god! Do you have any idea how hard this information is to find???
    06-24-2014 03:38 PM
  12. johnny rebel's Avatar
    these are the correct settings,dont need to type net10,
    sms message center number,(all phones
    have one,it is set by att ),change the"#" to "+",
    leave the number,

    DATA SETTINGS:
    APN: tfdata
    USER NAME:blank
    PASSWORD: blank
    PROXY SERVER (URL) :mms3.tracfone.com
    PROXY PORT: 80

    MMS SETTINGS:
    APN: tfdata
    USER NAME: net10
    PASSWORD: blank
    WAP GATEWAY (url) : mmsc
    WAP GATEWAY PORT: 80
    MMSC URL: http://mms-tf.net/
    MMSC PORT: 80
    MAXIMUM MMS SIZE : blank
    07-04-2014 08:58 PM
  13. johnny rebel's Avatar
    here are the settings for all net10 bring your own phones,
    sms message center number,(all phones
    have one,it is set by att ),change the"#" to "+",
    leave the number,

    DATA SETTINGS:
    APN: tfdata
    USER NAME:blank
    PASSWORD: blank
    PROXY SERVER (URL) :mms3.tracfone.com
    PROXY PORT: 80

    MMS SETTINGS:
    APN: tfdata
    USER NAME: net10
    PASSWORD: blank
    WAP GATEWAY (url) : mmsc
    WAP GATEWAY PORT: 80
    MMSC URL: http://mms-tf.net/
    MMSC PORT: 80
    MAXIMUM MMS SIZE : blank
    07-04-2014 09:00 PM
  14. thundertime88's Avatar
    my net10 mms settings do not work anymore I have the ones that go with the apn tfdata. anyone else have this problem?

    edit: deleted apn and mms and reenter the same settings and now no problems.
    08-13-2014 12:07 AM
  15. tinksrevenge's Avatar
    What were the settings you used to make it work? Net10 is useless for help.
    08-14-2014 06:45 AM
  16. backfat1's Avatar
    Just switched from a 521 to a 635. Data is working with only "tfdata" in the APN field. However, settings above are not working for MMS, but they were on the old 521. Agreed on Net10 lack of customer support - non-existent.
    08-25-2014 05:31 PM
  17. hercle's Avatar
    I used to have a 520 on net10 and bought a 635 and I am having the same problem internet is fine but mms settings are not working.
    Last edited by hercle; 08-26-2014 at 08:49 AM.
    08-25-2014 08:48 PM
  18. backfat1's Avatar
    Hopefully this weekend I'll have some time to figure this out - will post my settings if I get anything to work for MMS!
    08-26-2014 03:50 PM
  19. hercle's Avatar
    Good luck I just took my 635 back and got another 520 for now. Interestingly the 520 started doing the same thing after I updated it to 8.1 but after erasing and re inputing the MMS settings the text MMS worked again.
    08-26-2014 10:07 PM
  20. backfat1's Avatar
    Nice!
    08-27-2014 02:20 PM
  21. Kris Schumacher's Avatar
    Thanks for posting this.

    I've been using these settings and they have been working fine, but I just got the 8.1 update and now the MMS has stopped working. Any idea on what the new settings need to be with 8.1?
    09-07-2014 06:52 PM
  22. ssapre's Avatar
    Thanks for posting this.

    I've been using these settings and they have been working fine, but I just got the 8.1 update and now the MMS has stopped working. Any idea on what the new settings need to be with 8.1?
    This works on my unlocked 1020 for MMS as well (after Cyan+WP8.1 Update 1)-

    FIELD SETTINGS
    APN tfdata
    MMSC http://mms-tf.net
    MMS PROXY mms3.tracfone.com
    MMS PORT 80
    MMS_APN tfdata
    09-07-2014 09:30 PM
  23. todd boone76's Avatar
    Thanks for posting this.

    I've been using these settings and they have been working fine, but I just got the 8.1 update and now the MMS has stopped working. Any idea on what the new settings need to be with 8.1?
    Have tried all of these for my 920 Lumina with 8.1 update still can not picture messaging to work any help would be appreciated.
    09-08-2014 10:05 AM
  24. brookiesab's Avatar
    I just installed 8.1 on my Nokia Lumia 920 today and cannot get the MMS to work. I have deleted the setting and re-entered but to no avail. These settings in this thread are the same ones that were working fine with my phone yesterday before the update. I am a Net10 user and know better than to try to rely on them for any help! Hoping for a fix soon by someone on this forum.
    09-08-2014 08:15 PM
  25. dubbaYous's Avatar
    Try this go in to settings, cellular +SIM. Scroll down to and click sim settings. Click edit mms apn.
    Apn = tfdata
    User name = NET10 (all caps)
    Authentication =Pap
    WAP gateway = mms3.tracfone.com
    WAP gateway port = 80
    MMSC = http://mms-tf.net/
    MMSC port=80
    IP type = IPv4v6

    password and maximum MMS size are blank, then save.
    Should be good to go. 😃
    10-19-2014 10:35 PM
38 12

Similar Threads

  1. Music + Video Hub Settings Question.
    By Simeon6000 in forum Applications
    Replies: 3
    Last Post: 02-25-2014, 09:25 PM
  2. Tethering an AT&T 2520: can't connect to tablet hotspot
    By GizmoEV in forum Nokia Lumia 2520
    Replies: 2
    Last Post: 02-23-2014, 03:43 AM
  3. Settings/phone update not working fine
    By Aswin SpaceBound in forum Nokia Lumia 720
    Replies: 6
    Last Post: 02-23-2014, 01:56 AM
  4. Back cover clearance at Rogers (Canada)
    By Crushing Destroyer in forum Nokia Lumia 520
    Replies: 1
    Last Post: 02-22-2014, 10:15 PM
  5. Help please with setting up my nokia lumia 822 to straight talk
    By cainwoodard in forum Nokia Lumia 822
    Replies: 1
    Last Post: 02-22-2014, 10:14 PM
LINK TO POST COPIED TO CLIPBOARD