08-10-2016 11:07 AM
2,168 ... 2223242526 ...
tools
  1. rdjward's Avatar
    I had really bad battery problems with my Lumia 920 at first. When I received the device, I charged it fully as the documentation stated. It had a full charge by noon time. By supper time it was almost dead (or so I thought). Eventually it said "Goodbye" and powered off. I charged it again and the next day it lasted until supper time, and then said "Goodbye" to me again. I was curious so I tried powering the device back on and was presented with a low battery symbol, and then the device would power off again. I tried this a few times and eventually the phone booted back up again. I ended up using it for another 2 hours of very heavy use (video streaming and game playing). It said 0% battery life left the entire time I was using it. And then all of a sudden it simply powered off. I then gave it another full charge and it's been solid ever since. I took it off the charger at 8AM this morning and it's at 70% now. I work in an area that constantly goes in and out of service. In fact, my iPhone 4 could never last the full day, and if it did there would only be 20% left by supper.
    .
    I'm also from Halifax! Haha, we are the 920 guinea pigs in the city I suppose.
    11-21-2012 06:39 PM
  2. rdjward's Avatar
    It's closing in on 9PM and with my regular usage I still have 67% percent left after pulling off the charger at 8 AM. Quite pleased with this now.

    Stadifer: My phone was also initially killing nearly 10% of the battery per hour even if mostly idle, and it was draining so fast that if I had it plugged into a low-current USB port it would deplete almost as fast as it could charge if I did any real use on it. I've put a couple cycles on the batteries and did a hard reset and all seems to be going well now. I also didn't bother re-installing facebook after realizing that most of my use for it was already baked into the OS. I'm not sure if this contributed to the improvement or not. I wish there was a battery utility we could use to analyze this more closely.
    11-21-2012 06:40 PM
  3. cruzr96's Avatar
    So can anyone confirm the usefulness of the hard reset? I know a lot of people have bricked their phones, but for the ones who successfully reset the phone, has it worked? Or has performance stayed the same?
    11-21-2012 06:55 PM
  4. dkp23's Avatar
    I hard reset my phone twice, no improvement.

    I just received a replacement phone, hopefully this one fairs better than my original phone
    11-21-2012 07:20 PM
  5. robstunner's Avatar
    Mine slammed down today randomly. No idea why it lost so much as I've turned everything off. Three days ago battery life was so amazing I couldn't believe it. Something is def wrong. I watched battery go from %73 down to 69% and then magically up to 74% with no charging it.
    Sent from my RM-820_nam_att_100 using Board Express
    11-21-2012 07:42 PM
  6. chasevishnu's Avatar
    Check out my thread to fix the battery issue. It should definitely work. http://forums.windowscentral.com/nok...orary-fix.html
    11-21-2012 09:59 PM
  7. cdbstl76's Avatar
    I can tell you personally, that having to turn things off, restart, etc... all these advised fixes, don't fix everyone's problem. And honestly, not being able to use a phone as it's meant to function is NOT an acceptible solution. For me personally, I have been able to isolate the issue to the LTE use. I have spent the last few days in a rural town in Indiana (parent's house). No LTE. I live in STL(LTE). Only 4G HSPCA +. Guess what... yes, incredible batter life. The second I left LTE in STL, my phone's battery screamed back to life and allowed for my phone to function, background tasks and all, like it should be from the beginning. I was barely getting 8 hours of light to moderate use in STL. I will test again in STL when I return on Sunday, and turn of my LTE signal(wireless) and use Wi-fi only for a day. Sadly, tomorrow, Friday the 23rd, is my last day to return my phone in 14 days. However, should I find this test to prove me theory, there will be many communications going out to various involved entities to get this resolved or at the very least get an answer and a new phone. I'll let you all know what I find out. Happy Thanksgiving!
    11-22-2012 09:09 AM
  8. ssabat's Avatar
    The Apps for measuring battery life are the major culprit. I was losing 1% every 5 mins even in standby mode. Uninstall the battery life apps and then see.
    11-22-2012 09:17 AM
  9. ssabat's Avatar
    The apps for measuring battery life are a major cause in several cases. Uninstall them and then see.
    11-22-2012 09:19 AM
  10. ssabat's Avatar
    for me and several others, the battery measuring apps themselves have been a culprit. Uninstall them and then see.
    11-22-2012 09:21 AM
  11. ssabat's Avatar
    Unistall the battery measuring apps, that worked for me and some others i know.
    11-22-2012 09:23 AM
  12. ArgonNJ#CB's Avatar
    I call BS on this. This is probably zero use.
    11-22-2012 10:07 AM
  13. oakworth's Avatar
    So can anyone confirm the usefulness of the hard reset? I know a lot of people have bricked their phones, but for the ones who successfully reset the phone, has it worked? Or has performance stayed the same?
    Hi,i reset mine last night and had no problem in the reset but not a great improvement but since ready a few more post about 4 g and 3g ive switch highest speed connection to 3 g as im not on 4g yet so gunna monitor that.
    11-22-2012 10:14 AM
  14. Sandrobber's Avatar
    OK so phone one bricked. Went to the store and and received a new one. Now phone 2 same battery issue. So we bought 5 at work and charged and discharged them. So I'll be able to hear if people complain. New phone super hot almost burned my hand left it stinging for a few hours. I still have battery issues. To the extent I played civilization plugged in and the phone was draining. This didn't happen on the focus. Finally I hold my phone from the top(upside-down) and flick my wrist like ringing a bell and it rattles. Picked up other 920 and they don't. Back to the store tmrw
    11-22-2012 10:39 AM
  15. cruzr96's Avatar
    Hi,i reset mine last night and had no problem in the reset but not a great improvement but since ready a few more post about 4 g and 3g ive switch highest speed connection to 3 g as im not on 4g yet so gunna monitor that.
    So we're getting mixed results on that too, huh? :( I was hoping to use that as a last resort. Too bad for us AT&T users, we don't have the option to change speed connection. I definitely think that's the problem though. My phone runs on an LTE network all day, and six hours in idle drained it's battery life by ten percent. Anyone else experiencing bad idle drain with LTE networks?
    11-22-2012 10:48 AM
  16. Rob1701's Avatar
    Okay, so I bought my Black 920 on release day in the UK. It had a few issues, battery being poor for example... didn't think too much of it, seemed common enough and it made it through a day pretty much.
    Anyway, I took the phone back last week because the top of the case popped/flexed when it was pressed... but they had none in stock. So I went back a couple days later, again out of stock but they had yellow (which I originally wanted anyway...) so swapped for that.

    Anyway, the reason I'm posting... on my first day of use, took it off charge around 8am and its now nearly 5 and on 85%. My old 920, in the same time would be lucky to still be on 40%!
    11-22-2012 10:54 AM
  17. peachy001's Avatar
    I am at 57% 9 hours after charging to full. Oddly it went from 98% down to 93% while turned off. Been using it tonight for gaming and texting andsome calls. I can live with 24hours between charges, but I do have everything turned off.

    I am wondering if the wireless chargers will help or hinder.they charge slower so that should be better. But they do get warmer I am told.
    11-22-2012 04:29 PM
  18. franklasvegas's Avatar
    I purchased a L920 on 11-09. It was replacing an HTC Titan.
    Let it drain by reloading my apps setting up start screen.
    Fully charged it. The device appeared to be getting better battery life for the first couple of days - at one point seeing about 18/19 hours with moderate use.
    About 5 days into it I unplugged (fully charged) and placed on nightstand about 12:30AM. Awoke at about 8:30AM to a dead phone which I had to eventually soft-boot.
    AT&T store here found a replacement somewhere which I picked up Tuesday. Let it totally drain - recharged (seems VERY slow). Let it get to about 6% yesterday - recharged.
    From unplugging last night to this morning (about 8 hours) down to 18%. Fully recharged. Left house about 2:00PM - VERY light use. Phone showed up for 5 hours with 2 hours left.
    TOTALLY removed Nokia Drive+ just now & rebooted. Showed 11 hours left. 15 minutes now and shows 9 hours left. Doing nothing just sitting on my desk.
    I have maybe 4 apps doing live tile updates and all email set to 15minute & 30minute updates.
    Of course my 14-days with AT&T is out tomorrow - don't know what to do - maybe cycling a few more times will help.
    Something is major wrong. My Titan and WP7.5 never had these issues.
    Any other ideas? Although I think they have all been exhausted.
    Frustrating...
    11-22-2012 08:16 PM
  19. oakworth's Avatar
    So we're getting mixed results on that too, huh? :( I was hoping to use that as a last resort. Too bad for us AT&T users, we don't have the option to change speed connection. I definitely think that's the problem though. My phone runs on an LTE network all day, and six hours in idle drained it's battery life by ten percent. Anyone else experiencing bad idle drain with LTE networks?
    Hi switch my connection speed to 3g has made a big difference (as i cant really get 4g in my area anyway) i was at work last night so charged it up 100% then occasional use through the night (just facebook mainly) and watched a video on you tube,went to bed this morning and just got up to see my phone is on 76% battery life.
    i did have the usaul backround task switched off except the WEATHER CHANNEL and had wifi off but did have my location on in the setting,im quite happy with this.The thing is im not paying for a 4G contract as i cant get in my area yet but my default setting in setting was for 4G and only noticed to check on this forum and its defo works for me but if your running 4G and paying for it then lets hope they sort sumat for the 4G users.
    I love my phone but tend to expect a few problems with a new released phone and just waiting till next monday so i can order the free wireless charger so thats gunna be interesting

    Hope this helps
    11-23-2012 06:22 AM
  20. stressds's Avatar
    The ONLY thing that has worked for me is to turn location services off!

    I've tried everything else, including:
    1. Factory reset
    2. Shutting wifi, bluetooth, nfc etc. off
    3. Going from LTE to 3G

    Then I shut off location services and I can go through a full day and still have close to 60% battery life by the end of the day. That being said, I've called my carrier and told them I have a faulty battery and it gets really hot on use (it does), and they are sending me a brand new one. So we'll see if that makes a difference.
    11-23-2012 04:10 PM
  21. mcbredditor's Avatar
    The ONLY thing that has worked for me is to turn location services off!...
    On my third lumia 920. Shutting Location off is the only thing that has worked.
    11-23-2012 04:20 PM
  22. ncxcstud's Avatar
    I typically get anywhere between 14-18 hours of use - mostly 15 hours.

    I think what is really throwing people around is that the battery use meter is dynamic. If you play a lot of games - you'll run the battery down quickly. If all you do is check e-mail here and there, send a few texts, and such your battery will last longer.

    I'm not sure if I should go to the store and replace mine before Tuesday (when my 14 days are up) in hopes that I'll get one with a better battery...

    Though, I do know that based on my use this battery handles A LOT more than my focus could - even though it is lasting the same amount of time (hours wise). I'm DOING a lot more with my 920 than I did with my Focus. If I did all the things with my Focus that I've done with my 920, it'd last far less (plus its battery is smaller).
    11-23-2012 04:22 PM
  23. akaR07's Avatar
    Same exact scenario happened with me on my 920. Battery lasted 6 hours, recharged and lasted another 6 hours and I noticed it was warm to hot all the time. I rebooted and that seemed to cure the battery drain - warm phone issue which is back to 12 hours with 60% 70% left.
    It seems like the processor gets stuck on a memory leak or some app even though noting shows running. I have Nokia Drive blocked in Background.
    11-23-2012 04:42 PM
  24. dkp23's Avatar
    So i got replacement phone for my original on Friday. So after dong all the set up, drained the battery and recharged to 100%. The first full day, the phone actually lasted all the way through 12am with just under 20% left. Earlier in the day, there was similar type drain that i had with my original phone, but not s fast. But weird battery behavior did happen with my new phone:

    My phone was at 71% before we went into the movies to watch skyfall, then once the credits started i went to turn my phone on silent and decided to check the battery and the battery increased to 74%. OK that was weird, after 10 or so minutes on standby, i decided to check again and it stayed at 74% So i was happy no crazy standby draining like i had with my original phone. So after the movie was over which was probably 2 hours, i looked at my phone again and the battery decreased from 74% to 67%, then the "here we go again" feeling went through me, i felt i had another lemon.

    So afterwards, i just decided to uninstall skype all the together and it actually helped. From that point on, on standby, my phone never drained more than 3% and only drained if i turned on my phone to use which i do a lot. So i think skype is a major culprit, after i took skype out, my phone also didnt get as warm in use as well. So by end of the day, i was able to get my phone full use with just under 20% left from 8am to 12:30 am. So i was happy

    Fast forward to today, i took my phone off the charger at 7:30 and it 3:00pm right now and i am at 50%, with my old phone, i would be 20-30% by this time and i pretty much used my phone for a full two hours surfing IE10 on in a mall while waiting for my gf to finish blackfriday shopping. This was also using LTE.

    By 11pm, i think i should easily make another fulls day worth of batter so right now, im happy with the battery performance.

    Along with the skype removal, i called att to find out why i never get LTE anymore which i did with my 900 and, they think my data connection got stuck on 4g somehow and needed to reset me off their server, so now i get LTE all the time.

    So we'll see how things playout next couple days, but so good so far.
    11-23-2012 05:01 PM
  25. cruzr96's Avatar
    Yep, sounds like decent battery life to me. Mine runs easily for more than twelve hours now after I discharged the battery. Still jealous of some folks here who say that the phone lasts them 2 or 3 days, but with the amount of defects out there I'm not replacing mine anytime soon just because of adequate battery life.
    11-23-2012 05:09 PM
2,168 ... 2223242526 ...

Similar Threads

  1. Replies: 33
    Last Post: 08-14-2013, 03:02 PM
  2. how much does your battery drain during wordament?
    By akiman911 in forum Windows Phones
    Replies: 5
    Last Post: 01-29-2013, 08:04 AM

Tags for this Thread

LINK TO POST COPIED TO CLIPBOARD